Hello everybody,
Just wanting to share my experience with you. Today one of my colleagues asked me if there is an opensuse distrubion friendly enough for a newbie to watch movies, listen some music and navigate on net. Well I said I use opensuse and it is great. Just download the livecd and take a look. So he did. It took some time to boot and this is understandable I said, configuration, no hdd. Then it opened up and what do you know it looked nice and worked. He said ok, let's test the browser and clicked on mozilla firefox that was seating proudly on desktop. Entered youtube and surprise - no flash plugin. Well no problem mozilla is helping us , he clicked on download, and after several tries he downloaded the plugin. Opened dolphin, located the plugin and install it. Still no luck. Oh well too bad. Let's try some audio. We went to yast and look at the sound card. It was there but it was not configured. Why? Who knows.
No the sound worked. Back to mozilla. We opened the package manager, and it said no repositories? Why? Who knows. I googled a little, installed the standard though missing repositories and then looked for adobe flash. No luck. Then searched for mozilla and we found a swfdec plugin and said well, let's give it a try. Well it worked, but my friend was already lost for linux.
Maybe if the audio card was already configured, and internet worked out of the box at full, he would have give it a shot. Who knows.