Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problems with sound in USB Headset

  1. #1
    Join Date
    Jun 2008
    Location
    Stockholm
    Posts
    76

    Default Problems with sound in USB Headset

    Hi all.

    I'm trying to get my new USB headset working (Logitech ClearChat Pro USB) on my openSUSE 11.1 box running KDE 4.2.4. I have configured the headset as a USB Audio sound card in Yast/Hardware/Sound and also set it to be the primary card. Playing a test sound in Yast/Hardware/Sound/Other works fine. But playing test sounds using command line and the speaker-test application does not work as fine. When I specify which PCM device name to use it works, the command looks like this;

    Code:
    speaker-test -Dplug:front -c2 -l5 -twav
    This produces a test sound in my USB headset. But when I do not specify which playback device to use to force the test to use the default device I hear nothing in the USB headset. The command look like this;

    Code:
    speaker-test -c2 -l5 -twav
    Issuing this command produces a test sound in the headset I have attached to the internal sound card (Intel) and not in the USB headset. Why is my USB headset not the default device when I have set it to be the primary sound card in Yast/Hardware/Sound?

    Regards, Micke.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems with sound in USB Headset

    I'm on vacation, and no time to look at this in detail.

    So, instead, is there anything here in this wiki that might help:
    USB headphones - openSUSE

  3. #3
    Join Date
    Jun 2008
    Location
    Stockholm
    Posts
    76

    Default Re: Problems with sound in USB Headset

    Thanks for the input, oldcpu. I was kind of hoping to get your attention.

    I have already tried the instructions in the wiki you suggested. Setting up the headphones as a primary card in Yast/Hardware/Sound works fine and playing a test sound using Yast/Hardware/Sound/Other/Play Test Sound also works fine, I have sound in my USB headset.

    When I do a speaker test with "speaker-test -Dplug:front -c2 -l5 -twav" I also have sound in the USB headset.

    But when I do a speaker test with "speaker-test -c2 -l5 -twav" (not specifying a playback device) I have no sound in my USB headset. Instead, the sound comes out of my headphones connected to the internal sound card (which is configured as a secondary sound card in yast).

    Sound from Amarok also ends up in the headphones connected to the internal sound card and not in the USB headphones.

    It seems to me that the system hasn't recognized my USB headphones as the primary sound card although it is setup to be the primary sound card in Yast/Sound.

    Logging in and out of KDE also plays sound in the headphones connected to the internal sound card and not the USB headphones as I think it should.

    Right now I'm not making any progress, I could use a hint how to proceed. Reconfigure alsa?

    Regards, Micke.

  4. #4
    Join Date
    Jun 2008
    Location
    Stockholm
    Posts
    76

    Default Re: Problems with sound in USB Headset

    I have managed to come a bit further now.

    Spotify, Amarok 2.1.1, Twinkle and KDE system sounds all use the USB headset now (which is setup in Yast as the primary sound card). Twinkle also uses the USB headset microphone as input device. In KDE's Configure Desktop/Multimedia I have made the USB headset as the preferred output and audio capture device by putting it in top of all the lists.

    Playing any media in Firefox however fails to play sound in the USB headset, instead the internal sound card is used which I think is really strange since the USB headset is setup as the primary card in Yast and also made the preferred device in KDE's configuration.

    Amaraok 1.4.10 (Packman version using xine) also doesn't play audio using the USB headset, instead the sound goes through the internal sound card. Because of this I changed to version 2.1.1 instead.

    What do I have to do to make all multimedia applications honor the configuration where the USB headset is the primary device?

    /Regards, Micke.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems with sound in USB Headset

    Quote Originally Posted by thermopyle View Post
    What do I have to do to make all multimedia applications honor the configuration where the USB headset is the primary device?
    I do not have a USB headset, so don't wait for me to provide an answer, as I have no such headset to experiment.

    If it were me, I would log on to IRC freenode channel #alsa, and ask the guru's there for help. Typically one needs to ask a dozen or so times, spread across different times of the day, in order to have the best chance of obtaining the needed assistence to solve such problems. I use the program "xchat" for IRC chat communications.

  6. #6
    Join Date
    Jun 2008
    Location
    Stockholm
    Posts
    76

    Default Re: Problems with sound in USB Headset

    Thanks again oldcpu, I think I just cracked it.

    I saw another post on USB sound problems similar to mine that where solved by deleting both configurations in Yast (both internal sound card and USB headset) and then adding only the USB headset. Now I have sound in the headset from all my multimedia applications.

    Before this I tried to delete only the configuration for the internal sound card but this was not sufficient. They both have to be removed and then only the USB headset added again. I do not know if it's ok to add also the internal sound card after this, since I do not need it I will not try but it could be a case where the order of configuration is important (the post I saw in the forum hinted at that).

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems with sound in USB Headset

    Quote Originally Posted by thermopyle View Post
    Thanks again oldcpu, I think I just cracked it.

    I saw another post on USB sound problems similar to mine that where solved by deleting both configurations in Yast (both internal sound card and USB headset) and then adding only the USB headset. Now I have sound in the headset from all my multimedia applications.

    Before this I tried to delete only the configuration for the internal sound card but this was not sufficient. They both have to be removed and then only the USB headset added again. I do not know if it's ok to add also the internal sound card after this, since I do not need it I will not try but it could be a case where the order of configuration is important (the post I saw in the forum hinted at that).
    If you know where the configuration files are located, you could compare the "before" and "after" files, to see what the differences were.

    Glad to read you have had some success.

  8. #8

    Default Re: Problems with sound in USB Headset

    Quote Originally Posted by thermopyle View Post
    Thanks again oldcpu, I think I just cracked it.

    I saw another post on USB sound problems similar to mine that where solved by deleting both configurations in Yast (both internal sound card and USB headset) and then adding only the USB headset. Now I have sound in the headset from all my multimedia applications.

    Before this I tried to delete only the configuration for the internal sound card but this was not sufficient. They both have to be removed and then only the USB headset added again. I do not know if it's ok to add also the internal sound card after this, since I do not need it I will not try but it could be a case where the order of configuration is important (the post I saw in the forum hinted at that).
    Does this mean you have deleted the sound card config of your system and now only USB headset config remains?? So this implies that before you dleted your config files somewhere the system sound card was getting priority than the USB headphones.. IMO.

    I have also bought a Logitech USB head phone recently, before that I was having Microsoft Lifechat USB headphones and I having the issues as you have said.. When I play some video or audio from Web browsers or VLC the sound comes out from the system speakers (Not USB) (Just today I was looking in VLC settings to find out if there is some option to give preference to USB headphones like I do in Amarok 2.1, but could not find it) . After configuring USB headphone (MS Life Chat) in Yast --> sound I gave the higest priority to USB headphones in KDE Control center --> Sound and Amarok 2.1 separately.

    Oh yeah one more thing, I am running KDE 4.3 and I recently updated to Kernel 2.6.31 and after that I even had not to configure my Logitech USB headphones in Yast, they were detected automatically...

    Why I am saying all this is because I think what you did was a workaround, there must be some way to prioritize a specific sound card over others for every application.
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems with sound in USB Headset

    Quote Originally Posted by vendetta18 View Post
    Why I am saying all this is because I think what you did was a workaround, there must be some way to prioritize a specific sound card over others for every application.
    There are ways to prioritize multiple sound cards. There is guidance here:
    MultipleCards - ALSA wiki

    I've never had a PC with multiple cards, so I have no experience with this myself.

    Also, USB sound devices tend to bring into other aspects into play, such as hot plug automounting functionality, ... etc ..

  10. #10

    Default Re: Problems with sound in USB Headset

    Quote Originally Posted by oldcpu View Post
    Also, USB sound devices tend to bring into other aspects into play, such as hot plug automounting functionality, ... etc ..
    That is why I mentioned that I am having Kernel 2.6.31 right now . Before that every time unplugged and plugged my USB headphone, I had to to go through the steps if configuring and giving preference to USB headphones in Yast --> sound.

    But now after installing Kernel 2.6.31, whenever I plug in my USB headphone it gets detected automatically and sound starts coming out from it without doing any configuration for it in Yast --> sound (But I had to "prefer" this device over others in KDE Control Center --> sound and Amarok 2.1). Installing Kernel 2.6.31 also solved my another problem (How to configure USB modem in opensuse 11.1 - Page 3 - openSUSE Forums).
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 8GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE Leap 42.1
    +Plasma 5, Kernel 4.1.20-11-default x86_64

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •