Results 1 to 8 of 8

Thread: trouble getting a gui and loading nvidia drivers

  1. #1
    Join Date
    Sep 2009
    Location
    Vermont, USA
    Posts
    4

    Default trouble getting a gui and loading nvidia drivers

    Im new to Linux but not to computers. I installed Suse 11.1 and since then I cant get it to come up with a GUI. I searched around and think that I need to install the drivers for my geforce 8800 GTS. Found the drivers and put them onto a fat 32 USB ext hd. now my problem is that whenever I load the drivers it wants to build a kernel? Forgive me Im not near the computer in question so I cant tell you the precise errors. But I told it to make one of its own like it said to do in several forums. Then it said I didnt have gcc installed. Used yast to install that. Then it said I didnt have libc installed so I got that from yast also. Now it cant find the kernel.h? Or that it might be in a different location. Has anyone run into this? Sorry if this post is a bit quick but Im in a hurry. Will post more detail later.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: trouble getting a gui and loading nvidia drivers

    First start the software installer and install the Linux Kernel Development PATTERN.

    Then:

    Open a terminal window and follow instructions below. It's writen for both 32bit and 64bit, you will see.

    mkdir NVIDIA
    cd NVIDIA
    ++ a folder NVIDIA is created in /home/YOURUSERNAME and entered

    ++ now on a 32bit system do:
    wget ftp://download.nvidia.com/XFree86/Li...18.36-pkg1.run
    ++ on a 64bit system do:
    wget ftp://download.nvidia.com/XFree86/Li...18.36-pkg2.run
    ++ this downloads the driver from the NVIDIA site, into current folder

    ++ now on 32bit do:
    su -c 'sh NVIDIA-Linux-x86-185.18.36-pkg1.run -q'
    ++ on 64bit do:
    su -c 'sh NVIDIA-Linux-x86_64-185.18.36-pkg2.run -q'
    ++ Enter rootpassword when asked for. The installer will start, Accept the license, hit OK when asked for, until finished.

    ++ After install, you have to configure the driver, since you changed it for VESA:
    su -c 'sax2 -r -m0=nvidia'
    ++ Enter rootpassword. MIND: after the -m is a zero. Click Change Configuration, check values for videocard and monitor resolition. Save and exit.
    ++ Driver is now installed and configured. On next kernel update there's no need for the sax2 command, since Xorg is already configured to use the nvidia driver.
    ++ Now we need to change to runlevel 5 to get your gui back:

    su -c 'init 5 && exit'
    ++ Enter rootpassword and you should be presented with the kdm login screen.


    Good luck !!

    And a warm welcome
    Last edited by Knurpht; 16-Sep-2009 at 12:54. Reason: welcome
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: trouble getting a gui and loading nvidia drivers

    Make sure you have installed gcc, make, kernel-source, and kernel-syms. I remember getting this error with milestone 6, and I was missing kernel-syms.

    NVIDIA/The hard way - openSUSE
    Klaatu Barada Nikto

  4. #4
    Join Date
    Jul 2008
    Location
    United Kingdom
    Posts
    1,146

    Default Re: trouble getting a gui and loading nvidia drivers

    openSUSE should by default at least give you a GUI. (lacking hardware acceleration and not allowing access to the full range of a resolutions, but a GUI non the less)

    Did you try starting in safe mode?

    Make sure you have installed gcc, make, kernel-source, and kernel-syms. I remember getting this error with milestone 6, and I was missing kernel-syms.
    Just to help you out a bit more, that would be the command
    Code:
    sudo zypper install kernel-source kernel-syms make gcc

  5. #5
    Join Date
    Sep 2009
    Location
    Vermont, USA
    Posts
    4

    Default Re: trouble getting a gui and loading nvidia drivers

    alright in reply to Knurpht, i didnt figure out how to get the kernel development pattern. is it through yast? i searched through the software management pages.

    in reply to 67GTA, i went through and double checked and i do have all 3 installed.

    in reply to Axeia, i tried booting in safe mode with the same result. it goes through and checks the hardware and after a bit with no errors it brings me to a login but everything is still in a command prompt.

    when i run the NVIDIA drivers these are the error messages i get:

    No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from NVIDIA ftp site (ftp://download.nvidia.com)?

    yes (option)

    No matching precompiled kernel interface was found on the NVIDIA ftp site; this means that the installer will need to compile a kernel interface for your kernel.

    yes

    error: the kernel header file
    '/lib/modules/2.6.27.7-9-default/build/include/linux/kernel.h' does not exist. The most likely reason for this is that the kernel source path '/lib/modules/2.6.27.7-9-default/build/' is incorrect. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on redhat linux systems, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed. If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option.

    thank you for all the help. its surprising at how quickly i've received responses to my thread.

  6. #6
    Join Date
    Sep 2009
    Location
    Vermont, USA
    Posts
    4

    Default Re: trouble getting a gui and loading nvidia drivers

    i have been assuming based on other posts i've read in various forums that this is a graphics driver issue. could this be something else? i did have the option to configure my display properties when i installed from a suse dvd.

  7. #7
    Join Date
    Sep 2009
    Location
    Vermont, USA
    Posts
    4

    Default Re: trouble getting a gui and loading nvidia drivers

    Bump

    should i move this to a better category?

  8. #8
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: trouble getting a gui and loading nvidia drivers

    Can you not add the Nvidia repo and let YAST pick out your drivers for you?

    As previously mentioned a new install of OpenSUSE should at least give you a GUI using the vesa drivers. Is your Linux starting normally without errors to runlevel 3? If you see a command prompt for your login enter your username and password and after a successful login type:

    Code:
    init 5
    That should get you back to a gui using VESA providing everything is confugured correctly. Don't worry about any monitor resolutions at this stage.

    If you get this far you should be able to add the Nvidia repo to YAST's repo list
    by selecting YAST - Software - Software repositories. It's under the list of community repo's. Just add it and exit.

    Now use the normal YAST way of installing software to get the correct Nvidia driver and the assosiated Kernel module. YAST should actually picks the correct files for you ones the repo is added. I have never compiled drivers for my 8800GT in OpenSUSE.

    If you are still not getting anywhere I would think your installation is broken, possible due to a faulty disc. It can cause all sorts of unpredictable complaints.

    Main point are:
    - New installation should always give you a gui unless you specifically selected not to do this.
    - I would not compile drivers yourself untill you learn a bit more about Linux so use the repo's until then.
    - If you are downloading a Linux disc ALWAYS check the md5sum before burning and follow the instructions mentioned in the sticky in the install/boot section of this forum.
    Last edited by Dexter1979; 19-Sep-2009 at 07:03. Reason: Added points
    "To err is human... to really foul up requires the root password."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •