Results 1 to 5 of 5

Thread: Apache mod_security ?

  1. #1

    Default Apache mod_security ?

    Hello,

    How important is to use mod_security for Apache, and how to install it? Is it sufficient just to install it by yast and to reload apache web server? Or there are any modifications that need to be done, if how?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Apache mod_security ?

    It can be installed through Yast. AFAIK no special actions required.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Apache mod_security ?

    after installing it with yast and reloding apache this is apache output:

    Syntax error on line 3 of /etc/apache2/conf.d/mod_security2.conf:
    Invalid command 'SecRuleEngine', perhaps misspelled or defined by a module not included in the server configuration

  4. #4

    Default Re: Apache mod_security ?

    okay, I have solved above problem by adding "security2" to APACHE_MODULES= in /etc/sysconfig/apache2 and creating ".log" in "/srv/www/logs/modsec_debug.log", HOWEVER after checking Apache Mod Security by system it still shows OFF?

  5. #5

    Default Re: Apache mod_security ?

    Still looking for a solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •