Results 1 to 6 of 6

Thread: banshee cant play m4a files

  1. #1
    Join Date
    Feb 2009
    Location
    Manchester, UK
    Posts
    13

    Default banshee cant play m4a files

    Did a recent upgrade of KDE desktop to 4.3.1.

    Everything seemed to go OK, but one effect was I cant play .m4a files in banshee. Have looked at all the previous posts on this topic but with no effect.

    Multi-media and Restricted Format Installation Guide - openSUSE Forums
    &
    Check your multimedia problem in ten steps - openSUSE Forums


    Any ideas check that any one has would be welcomed.

    Here's what I have installed;


    @babylon:~> rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' MPlayer '*vlc*' | grep -v avahi | sort
    amarok-xine-1.4.10-26.2.1
    banshee-1-backend-engine-gstreamer-1.4.1-2.12
    gst-fluendo-mp3-2-37.3
    gstreamer-0_10-0.10.23-42.pm.44.1
    gstreamer-0_10-ffmpeg-0.10.7-42.pm.1
    gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
    gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.1
    gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1
    gstreamer-0_10-lang-0.10.23-42.pm.44.1
    gstreamer-0_10-plugins-bad-0.10.13-42.pm.1
    gstreamer-0_10-plugins-bad-lang-0.10.13-42.pm.1
    gstreamer-0_10-plugins-base-0.10.23-42.pm.42.3
    gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.42.3
    gstreamer-0_10-plugins-farsight-0.12.11-0.pm.5
    gstreamer-0_10-plugins-good-0.10.15-42.pm.1
    gstreamer-0_10-plugins-good-extra-0.10.15-42.pm.1
    gstreamer-0_10-plugins-good-lang-0.10.15-42.pm.1
    gstreamer-0_10-plugins-ugly-0.10.12-42.pm.1
    gstreamer-0_10-plugins-ugly-lang-0.10.12-42.pm.1
    gstreamer-0_10-utils-0.10.23-42.pm.44.1
    gstreamer-utils-0.10.23-42.pm.44.1
    libavc1394-0-0.5.3-129.6
    libavcodec52-0.5-1.pm.8.2
    libavdevice52-0.5-1.pm.8.2
    libavformat52-0.5-1.pm.8.2
    libavutil49-0.5-1.pm.8.2
    libgstapp-0_10-0-0.10.8-6.5
    libgstinterfaces-0_10-0-0.10.23-42.pm.42.3
    libgstphotography-0_10-0-0.10.13-42.pm.1
    libgstreamer-0_10-0-0.10.23-42.pm.44.1
    libpostproc51-0.5-1.pm.8.2
    libswscale0-0.5-1.pm.8.2
    libxine1-1.1.16.3-2.pm.5.3
    libxine1-codecs-1.1.16.3-2.pm.5.3
    MPlayer-1.0rc2_r29116-2.pm.28.1
    phonon-backend-gstreamer-0_10-4.3.1-31.1
    phonon-backend-xine-4.3.1-31.1
    xinetd-2.3.14-129.35
    xine-ui-0.99.5-221.38

    and here is the Packman repo confirmations

    @babylon:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}\n' gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly
    gstreamer-0_10-ffmpeg-0.10.7-42.pm.1-x86_64 -> PackMan :: Startseite
    gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1-x86_64 -> packman.links2linux.de
    gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.1-x86_64 -> packman.links2linux.de
    gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1-x86_64 -> packman.links2linux.de
    gstreamer-0_10-plugins-bad-0.10.13-42.pm.1-x86_64 -> PackMan :: Startseite
    gstreamer-0_10-plugins-base-0.10.23-42.pm.42.3-x86_64 -> PackMan :: Startseite
    gstreamer-0_10-plugins-good-0.10.15-42.pm.1-x86_64 -> PackMan :: Startseite
    gstreamer-0_10-plugins-good-extra-0.10.15-42.pm.1-x86_64 -> PackMan :: Startseite
    gstreamer-0_10-plugins-ugly-0.10.12-42.pm.1-x86_64 -> PackMan :: Startseite

    Banshee version:
    @babylon:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}\n' banshee-1-1.4.3-3.1 banshee-1-backend-engine-gstreamer-1.4.3-3.1 banshee-1-backend-platform-unix-1.4.3-3.1 banshee-1-extensions-default-1.4.3-3.1 banshee-1-lang-1.4.3-3.1
    banshee-1-1.4.3-3.1-x86_64 -> openSUSE Build Service
    banshee-1-backend-engine-gstreamer-1.4.3-3.1-x86_64 -> openSUSE Build Service
    banshee-1-backend-platform-unix-1.4.3-3.1-x86_64 -> openSUSE Build Service
    banshee-1-extensions-default-1.4.3-3.1-x86_64 -> openSUSE Build Service
    banshee-1-lang-1.4.3-3.1-x86_64 -> openSUSE Build Service

  2. #2
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: banshee cant play m4a files

    Since you have kde, try first to see that totem or amarok plays them.
    Totem should give an error.
    Try adding libmp4 from packman.

  3. #3
    Join Date
    Feb 2009
    Location
    Manchester, UK
    Posts
    13

    Default Re: banshee cant play m4a files

    Nice one, it was a problem with the libmp4 version...wasnt from Packman repo. Re-installed and all is now working. Cheers Whych.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,854
    Blog Entries
    14

    Default Re: banshee cant play m4a files

    Check the other codecs as well. You're/you were in a mix of Videolan and Packman packages.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: banshee cant play m4a files

    As Knurpht says, you only need the libdvdcss package from vlc.
    Install it, then disable the vlc repo.
    In general, get everything else from packman unless there is a compelling reason not to. When done, disable the repo again, keeping only packman.

  6. #6
    Join Date
    Feb 2009
    Location
    Manchester, UK
    Posts
    13

    Default Re: banshee cant play m4a files

    As I said all sorted, only had libdvdcss from vlc and it was disabled. Thanks again for the help

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •