Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: M7 and asus laptops (a7k esp.)

  1. #1

    Default M7 and asus laptops (a7k esp.)

    Hi all,

    I've upgraded from M6 to M7 successfully and am slowly configuring everything. Audio didn't work "out of the box", but it didn't in 11.1 either. Any other asus users get their laptop audio working? I'm starting to trouble shoot, but wanted to see if I needed to do the bug fix using the fix identified at the end of 11.1(using hda_verb)

  2. #2
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,920
    Blog Entries
    15

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by gavinto
    Hi all,

    I've upgraded from M6 to M7 successfully and am slowly configuring
    everything. Audio didn't work "out of the box", but it didn't in 11.1
    either. Any other asus users get their laptop audio working? I'm
    starting to trouble shoot, but wanted to see if I needed to do the bug
    fix using the fix identified at the end of 11.1(using hda_verb)
    Hi
    Sound, webcam, bluetooth, wireless etc all working fine here. Do have
    issues with the time when rebooting and requiring an fsck

    Gnome/Compiz DE going fine as well.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 Milestone 7 (i586) Kernel 2.6.31-rc9-7-desktop
    up 12:01, 2 users, load average: 0.09, 0.05, 0.07
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  3. #3

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by malcolmlewis View Post
    Do have
    issues with the time when rebooting and requiring an fsck
    .. which can (at least here) easily be solved by

    - syncing clock (via ntp)

    - syncing hwclock (systohc)

    - rebooting to init=/bin/sh

    and then running fsck once.

    After that no more clock related issues for me.

  4. #4

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by Akoellh View Post
    After that no more clock related issues for me.

    .. or not?

    After that procedure it worked fine, did several reboots.

    Then I shut down the machine, and after starting it up a few minutes ago, everything boots up fine, but I got curious.

    Although "date" showed the correct time now, "tune2fs -l" showed the last mount of "/" to be 2 hours in the future.

    On reboot this caused the machine on initial routine fsck to mount / read-only again.

    This is odd in two ways:

    1) Date gets set correctly but on mounting "/" the clock must have been 2 hours in the future, which could be explained that the time got corrected later during boot. Still there is the question, what set the time back to the wrong value on shutting down?

    2) Why does fsck on startup not automatically correct this error, I am very sure that this was standard behavior before, normally the default fsck on startup automatically tried to correct such errors unless they were really critical (this error is not one of that sort).


    Although fixing is easy (even booting in RL1 seems to work) it is pretty annoying.

  5. #5
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,920
    Blog Entries
    15

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by Akoellh
    Akoellh;2040345 Wrote:
    >
    > After that no more clock related issues for me.



    .. or not?

    After that procedure it worked fine, did several reboots.

    Then I shut down the machine, and after starting it up a few minutes
    ago, everything boots up fine, but I got curious.

    Although "date" showed the correct time now, "tune2fs -l" showed the
    last mount of "/" to be 2 hours in the future.

    On reboot this caused the machine on initial routine fsck to mount /
    read-only again.

    This is odd in two was:

    1) Date gets set correctly but on mounting "/" the clock must have been
    2 hours in the future, which could be explained that the time got
    corrected later during boot. Still there is the question, what set the
    time back to the wrong value on shutting down?

    2) Why does fsck on startup not automatically correct this error, I am
    very sure that this was standard behavior before, normally the default
    fsck on startup automatically tried to correct such errors unless they
    were really critical (this error is not one of that sort).


    Although fixing is easy (even booting in RL1 seems to work) it is
    pretty annoying.
    Hi
    Well I had thought I had it fixed as it appears /etc/init.s/boot.clock
    is buggy. What I did was change in timezone to set to --localtime.

    I tried your way (although always run ntp) but when at init/bin/sh
    shows a -5 hour error

    On shutdown I see the correct time is set, yet bootup borks and have to
    fsck.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 7 days 19:58, 2 users, load average: 0.00, 0.03, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  6. #6

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by Akoellh View Post

    After that procedure it worked fine, did several reboots.
    There's the problem.

    On reboot everything is fine.

    After shutting down the machine and then starting it again, clock and consequently last mount time are 2 hours in the future again.

    Code:
     date
    Di 15. Sep 21:50:34 CEST 2009
    
    # tune2fs /dev/sda2 -l|grep Last
    Last mounted on:          <not available>
    Last mount time:          Tue Sep 15 21:45:54 2009
    Last write time:          Tue Sep 15 21:45:54 2009
    Last checked:             Tue Sep 15 19:23:31 2009
    .. while the correct time is 19.45 here.

    If I will correct the time (sync with ntp, I explicitely booted the machine to RL1 this time, so there was no automatic sync without network connection) and reboot the machine, I already know, what's going to happen.

    Clock is set to UTC, /etc/sysconfig/clock looks like this:

    Code:
    cat /etc/sysconfig/clock 
    ## Path:                System/Environment/Clock
    ## Description:         Information about your timezone and time
    ## Type:                string(-u,--utc,--localtime)
    ## ServiceRestart:      boot.clock
    #
    # Set to "-u" if your system clock is set to UTC, and to "--localtime"
    # if your clock runs that way.
    #
    HWCLOCK="-u"
    ## Description: Write back system time to the hardware clock
    ## Type:                yesno
    ## Default:             yes
    #
    # Is set to "yes" write back the system time to the hardware
    # clock at reboot or shutdown. Useful if hardware clock is
    # much more inaccurate than system clock.  Set to "no" if
    # system time does it wrong due e.g. missed timer interrupts.
    # If set to "no" the hardware clock adjust feature is also
    # skipped because it is rather useless without writing back
    # the system time to the hardware clock.
    #
    SYSTOHC="yes"
    
    ## Type:                string(Europe/Berlin,Europe/London,Europe/Paris)
    ## ServiceRestart:      boot.clock
    #
    # Timezone (e.g. CET)
    # (this will set /usr/lib/zoneinfo/localtime)
    #
    TIMEZONE="Europe/Berlin"
    DEFAULT_TIMEZONE="Europe/Berlin"

    Now the problem in my case, these are virtual machines (VBox), so I can't be sure, if this is a problem related to the vboxadd-timesync service or any other "VM-related" issue, so I am not the one who could write a useful bugreport.

    If anyone has the same problem with 11.2 M7 actually installed on "real" hardware, try to reproduce the behavior, check the outputs on your machine and write a bug report!

  7. #7
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,920
    Blog Entries
    15

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by Akoellh
    Akoellh;2040387 Wrote:
    >
    >
    > After that procedure it worked fine, did several reboots.


    There's the problem.

    On _reboot_ everything is fine.

    After _shutting_down_the_machine_ and then starting it again, clock and
    consequently last mount time are 2 hours in the future again.


    Code:
    --------------------

    date
    Di 15. Sep 21:50:34 CEST 2009

    # tune2fs /dev/sda2 -l|grep Last
    Last mounted on: <not available>
    Last mount time: Tue Sep 15 21:45:54 2009
    Last write time: Tue Sep 15 21:45:54 2009
    Last checked: Tue Sep 15 19:23:31 2009
    --------------------


    .. while the correct time is 19.45 here.

    If I will correct the time (sync with ntp, I explicitely booted the
    machine to RL1 this time, so there was no automatic sync without network
    connection) and reboot the machine, I already know, what's going to
    happen.

    Clock is set to UTC, /etc/sysconfig/clock looks like this:


    Code:
    --------------------

    cat /etc/sysconfig/clock
    ## Path: System/Environment/Clock
    ## Description: Information about your timezone and time
    ## Type: string(-u,--utc,--localtime)
    ## ServiceRestart: boot.clock
    #
    # Set to "-u" if your system clock is set to UTC, and to "--localtime"
    # if your clock runs that way.
    #
    HWCLOCK="-u"
    ## Description: Write back system time to the hardware clock
    ## Type: yesno
    ## Default: yes
    #
    # Is set to "yes" write back the system time to the hardware
    # clock at reboot or shutdown. Useful if hardware clock is
    # much more inaccurate than system clock. Set to "no" if
    # system time does it wrong due e.g. missed timer interrupts.
    # If set to "no" the hardware clock adjust feature is also
    # skipped because it is rather useless without writing back
    # the system time to the hardware clock.
    #
    SYSTOHC="yes"

    ## Type:
    string(Europe/Berlin,Europe/London,Europe/Paris) ##
    ServiceRestart: boot.clock #
    # Timezone (e.g. CET)
    # (this will set /usr/lib/zoneinfo/localtime)
    #
    TIMEZONE="Europe/Berlin"
    DEFAULT_TIMEZONE="Europe/Berlin"
    --------------------



    Now the problem in my case, these are virtual machines (VBox), so I
    can't be sure, if this is a problem related to the vboxadd-timesync
    service or any other "VM-related" issue, so I am not the one who could
    write a useful bugreport.

    If anyone has the same problem with 11.2 M7 actually installed on
    "real" hardware, try to reproduce the behavior, check the outputs on
    your machine and write a bug report!
    Hi
    Ok, so after fluffing around and various shutdowns and booting into
    init=/bin/sh and rebooting, I got side tracked with searching the yast2
    sysconfig and had noticed it complaining about a module not found
    (ata_piix?).

    So I did two things, enable the interactive boot
    (in /etc/sysconfig/boot) and then removed the module from
    initrd_modules in YaST. This of course kicked in mkinitrd. So now I
    rebooted and the error had disappered, but low and behold the system
    booted fine. Turned off the interactive boot, and have shutdown and
    restarted numerous times and all is well.

    So fire up vmware workstation with a suspended 11.2 M7 (x86_64) session
    now and reboot, all was fine with this, it did show that it was
    carrying out a fsck but continued on. So once it booted su to root and
    ran /sbin/mkinitrd and it's all working fine on check on reboots or
    shutdown/restart.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 8 days 3:12, 2 users, load average: 0.45, 0.38, 0.36
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  8. #8

    Default Re: M7 and asus laptops (a7k esp.)

    Please read and contribute to this bug report, especially the people running their M7 on "real" hardware.

    https://bugzilla.novell.com/show_bug.cgi?id=534816

  9. #9
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,920
    Blog Entries
    15

    Default Re: M7 and asus laptops (a7k esp.)

    Quote Originally Posted by Akoellh
    Please read and contribute to this bug report, especially the people
    running their M7 on "real" hardware.

    https://bugzilla.novell.com/show_bug.cgi?id=534816
    Hi
    Comment and votes added

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 14:49, 2 users, load average: 0.68, 0.74, 0.36
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  10. #10

    Default Re: M7 and asus laptops (a7k esp.)

    Thx.

    So I will try the whole stuff with "localtime" now (which is AFAIK normally what you should use if you have a dualboot Win/linux) and see what happens.

    The most puzzling thing for me is still this "reboot == fine" but "halt == trouble".

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •