Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: No Compositing after install NVIDIA drivers

  1. #1
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default No Compositing after install NVIDIA drivers

    Hi Guys,

    I tried out KDE4.3 in Milestone 7 and I have to say it seems very stable and fast. My problem though is that I can't seem to enable compositing.

    I had to compile the drivers from scratch following the guide "Installing Nvidia the hard way" and configured SAX2 to use Nvidia. But I cannot enable compositing. When I go to Kwin, it says i need XDamage and XCompositing. I don't see it in YAST2.

    Can anyone tell me what I need to install?
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: No Compositing after install NVIDIA drivers

    xorg-x11-libs
    is listed for XDamage in 11.1

    search with .rpm provides checked.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default Re: No Compositing after install NVIDIA drivers

    Thanks caf,

    Do i need something else? If that is just Xdamage.
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: No Compositing after install NVIDIA drivers

    I honestly don't know. And not having M7 running except in a VM I can't compare really. I'm sure there are some running it with nvidia. You can but try I guess.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: No Compositing after install NVIDIA drivers

    I'm running Factory with latest NVIDIA beta driver.

    What is the NVIDIA card you're using. The official stable drivers do not support the latest (laptop)cards. Here's the NVIDIA ftp address, pick the latest from there.

    32bit : ftp://download.nvidia.com/XFree86/Linux-x86
    64bit : ftp://download.nvidia.com/XFree86/Linux-x86_64

    And....check the last three lines of /etc/X11/xorg.conf, they should be:

    Section "Extensions"
    Option "Composite" "on"
    EndSection
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default Re: No Compositing after install NVIDIA drivers

    I'm using a 8400M GS. Its not in any fashion new. I will check my xorg when i get home a 1 hours time. If that still doesn't work, I'm going to try the drivers your specified Knurpht.

    I downloaded these drivers from NVIDIA
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

  7. #7
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default Re: No Compositing after install NVIDIA drivers

    Thanks. IT works.

    I just had to change the xorg to on. it was off. lol. can't believe it was that easy. Thanks guys
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

  8. #8
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default Re: No Compositing after install NVIDIA drivers

    sorry to be a pain; but my xorg.conf is not saving after reboot. I have to manually change it.

    Plus when i installed compiz and started it. i lost my titlebar. I remember that you had to go to konsole and type emerald --replace but that did nothing.

    So i checked google and on a ubuntu forums, he recommended adding some options to the "devices" section. That worked but i caused some problems. After a few seconds, it would cut out and I can't start back compiz. So I uninstalled compiz and am using Kwin. Let me know what you guys think.
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: No Compositing after install NVIDIA drivers

    You may be a little confused:
    Using Compiz you can do as I do and just use it for effects but not as a window manager. Kwin is my window manager.
    Using Compiz and Emerald (emerald being the window manager part) can result in the title bar loss. And I'm sure someone like @ijbreakey will have an answer on this. It happened to me way back in 10.3 and kde3. I used the Fusion Icon to manage Compiz from the desktop and IIRC I just used that to emphasise the switch. it was almost like it just needed an extra push.

    With kwin I have never had an issue yet and emerald I can do without.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default Re: No Compositing after install NVIDIA drivers

    Yea i Know what is compiz and emerald. I really love the effects. Kwin works great and all but I will only use that on a work desktop or PC. but when it comes to my personal things, I kinda like compiz.

    I know that I would lose the titlebar, thats why i did the emerald --replace. Its just messed up.

    I will just stick with Kwin again for this settings for now. I can live with it. Thanks though
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •