Results 1 to 10 of 10

Thread: Read only filesystem

  1. #1
    linuxlive NNTP User

    Default Read only filesystem

    I installed opensuse milestone 7 and don't starts beacause when initialize, the system not mount any patitions with returns read only.
    My filesystem is ext4
    My grub is correctly, and fstab too.

    fstab:
    /dev/disk/by-id/ata-WDC_WD1600AAJS-75WAA0_WD-WCAS24200824-part1 / ext4 acl,user_xattr 1 1

    Grub:
    title Desktop -- openSUSE 11.2 Milestone 7
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31-rc9-7-desktop root=/dev/disk/by-id/ata-WDC_WD1600AAJS-75WAA0_WD-WCAS24200824-part1 resume=/dev/disk/by-id/ata-WDC_WD1600AAJS-75WAA0_WD-WCAS24200824-part3 splash=silent quiet showopts vga=0x31a
    initrd /boot/initrd-2.6.31-rc9-7-desktop

  2. #2

    Default Re: Read only filesystem

    I am pretty sure that there was a more elaborate message _why_ the FS is read only, normally there is a good reason for that.

    Boot with only a shell as "init" option (/bin/sh will be enough) and elaborate there, mostly a fsck will do the trick.

  3. #3

    Default Re: Read only filesystem

    I've had the same thing happen on one of my systems too. Unfortunately I can't get boot and when I do a recover there are no logs because... the FS is read only. I've installed 4 times now, the last one I switched from EXT4 to EXT3 and the exact same thing. Pretty sucky

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Read only filesystem

    Is this happening every time you start M7, or just occasionally? I have a similar problem, but it happens every other time I start M7. Fsck fails to fix errors and the file system is mounted read-only. Other times, the system fails to unmount when shutting down. I can't trace the source of this. Are you by any chance running 11.2 on VirtualBox?

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,316
    Blog Entries
    15

    Default Re: Read only filesystem

    Quote Originally Posted by chief sealth
    Is this happening every time you start M7, or just occasionally? I have
    a similar problem, but it happens every other time I start M7. Fsck
    fails to fix errors and the file system is mounted read-only. Other
    times, the system fails to unmount when shutting down. I can't trace the
    source of this. Are you by any chance running 11.2 on VirtualBox?
    Hi
    This is what worked for me to fix the issue on an ASUS netbook and a
    vmware machine;
    <http://forums.opensuse.org/pre-release-beta/421916-m7-asus-laptops-a7k-esp.html>

    First thing is to boot into your BIOS and check the date/time is
    correct, then if you boot the system and in the GRUB options add;
    Code:
    init=/bin/sh
    This should automatically run fsck on the affected root drive and will
    put you at a root prompt. If it doesn't automatically run, then for
    example (replace the example with your drive partition) run;
    Code:
    fsck /dev/sda2
    Now reboot and should now boot without errors.

    Once you system has booted, ensure the date/time is correct, you may
    wish to setup ntp at this point and ensure the time is correct.

    Now su to root user and;
    Code:
    /sbin/mkinitrd
    Shutdown/reboot and all should be ok now

    Note, my systems are set to localtime.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 0:22, 2 users, load average: 0.02, 0.16, 0.35
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Read only filesystem

    Malcolm wrote:
    >
    Quote Originally Posted by chief sealth
    > Is this happening every time you start M7, or just occasionally? I have
    > a similar problem, but it happens every other time I start M7. Fsck
    > fails to fix errors and the file system is mounted read-only. Other
    > times, the system fails to unmount when shutting down. I can't trace the
    > source of this. Are you by any chance running 11.2 on VirtualBox?
    >
    > Hi
    > This is what worked for me to fix the issue on an ASUS netbook and a
    > vmware machine;
    > <http://forums.opensuse.org/pre-release-beta/421916-m7-asus-laptops-a7k-esp.html>
    >
    > First thing is to boot into your BIOS and check the date/time is
    > correct, then if you boot the system and in the GRUB options add;
    >
    Code:
    > init=/bin/sh
    >
    > This should automatically run fsck on the affected root drive and will
    > put you at a root prompt. If it doesn't automatically run, then for
    > example (replace the example with your drive partition) run;
    >
    Code:
    > fsck /dev/sda2
    >
    > Now reboot and should now boot without errors.
    >
    > Once you system has booted, ensure the date/time is correct, you may
    > wish to setup ntp at this point and ensure the time is correct.
    >
    > Now su to root user and;
    >
    Code:
    > /sbin/mkinitrd
    >
    > Shutdown/reboot and all should be ok now
    >
    > Note, my systems are set to localtime.


    I too have the problem - it is caused by the last write and/or the
    last mount in the future. When it happens, I boot with "init=/bin/sh"
    in the GRUB option line, do the 'fsck /dev/sdaX', and then reboot.

    I too use localtime.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,316
    Blog Entries
    15

    Default Re: Read only filesystem

    Quote Originally Posted by Larry Finger
    Malcolm wrote:
    >
    Quote Originally Posted by chief sealth
    > Is this happening every time you start M7, or just occasionally? I
    > have a similar problem, but it happens every other time I start M7.
    > Fsck fails to fix errors and the file system is mounted read-only.
    > Other times, the system fails to unmount when shutting down. I can't
    > trace the source of this. Are you by any chance running 11.2 on
    > VirtualBox?
    > Hi
    > This is what worked for me to fix the issue on an ASUS netbook and a
    > vmware machine;
    > <http://forums.opensuse.org/pre-release-beta/421916-m7-asus-laptops-a7k-esp.html>
    >
    > First thing is to boot into your BIOS and check the date/time is
    > correct, then if you boot the system and in the GRUB options add;
    >
    Code:
    > init=/bin/sh
    >
    > This should automatically run fsck on the affected root drive and will
    > put you at a root prompt. If it doesn't automatically run, then for
    > example (replace the example with your drive partition) run;
    >
    Code:
    > fsck /dev/sda2
    >
    > Now reboot and should now boot without errors.
    >
    > Once you system has booted, ensure the date/time is correct, you may
    > wish to setup ntp at this point and ensure the time is correct.
    >
    > Now su to root user and;
    >
    Code:
    > /sbin/mkinitrd
    >
    > Shutdown/reboot and all should be ok now
    >
    > Note, my systems are set to localtime.


    I too have the problem - it is caused by the last write and/or the
    last mount in the future. When it happens, I boot with "init=/bin/sh"
    in the GRUB option line, do the 'fsck /dev/sdaX', and then reboot.

    I too use localtime.
    Hi Larry
    Can you try the mkinitrd command and see if it fixes it?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 1:41, 2 users, load average: 0.02, 0.04, 0.06
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  8. #8
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Read only filesystem

    Now it's either mounting read-only or failing to detect my keyboard.

  9. #9

    Default Re: Read only filesystem

    I've tried installing the 32-bit version on a Pentium 4 based machine, the 64-bit version on an AMD Phenom X4 based system, with similar results. Neither system appears to be having CMOS/battery/clock/etc., problems, and in fact the AMD based machine is quite new. I am using LVM on a SATA drive on both. I didn't manually request install of anything, such as an NTP client or some such that would establish an external time reference, so there should be no reason the time would jump around. I had no such problem with M6 on the same machines.

    When I try the repair mode, it claims it can't find a valid swap partition. It also claims that the kernel is missing some modules for initrd. Even after that partial repair, it still fails to fully install on either machine. I can use rescue mode to fsck the root LV, but the problem happens again.

    It's as though a proper timestamp is not being committed to the volume before being shutdown, even though I follow the long-standing superstition of Unix-like systems and manually "sync" three times before shutdown. I'm tempted to try to find the right spot in the K* scripts and add an "hwclock" command and some "sync" commands.

    It's also as though the repair mode is inconsistent with the running system, although that's not the first time I've seen that issue. That appears to be true even in the 11.1 GA.

    I too am using localtime.

    I note that there is a ticket on possible LVM problems in earlier Milestones and a more recent suspicion expressed in the ticket that there might remain some related problem.

    http://bugzilla.novell.com/show_bug.cgi?id=505670

    Don't know it the current probs are related, but it caught my eye because I'm using LVM and I believe I've seen some of the dev mapper complaints during one of the stages of install of M7.

    After much effort, haven't gotten a smoothly functioning, fully installed M7 on either machine, 32 or 64 bit.

  10. #10

    Default Re: Read only filesystem

    Please read and contribute to this bug report, especially the people running their M7 on "real" hardware.

    https://bugzilla.novell.com/show_bug.cgi?id=534816

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •