Results 1 to 7 of 7

Thread: Network Not Properly Starting on Bootup

  1. #1
    Join Date
    Nov 2008
    Location
    Minneapolis, MN
    Posts
    27

    Default Network Not Properly Starting on Bootup

    Hello,
    Recently after upgrading my kernel (via /repositories/Base:/Kernel/standard) I have had issues with the network not starting properly on bootup. The kernel is 100% SUSE-patched and behaves perfectly outside of that one issue. To get the network to "start" (DHCP issued, eth0 brought up) I have to 'rcnetwork start' in a shell. I've checked to make sure my config is right in both ifcfg-eth0 and 'config' for /etc/sysconfig/network, but nothing affects the outcome.

    How do I get the boot scripts to bring up eth0 and issue a DHCP on startup?

    Here's the output of 'rcnetwork start -o debug fake':

    Code:
    CONFIG            =
    INTERFACE         =
    AVAILABLE_IFACES  = eth0 wlan0
    PHYSICAL_IFACES   =  eth0 wlan0
    BONDING_IFACES    =
    VLAN_IFACES       =
    DIALUP_IFACES     =
    TUNNEL_IFACES     =
    BRIDGE_IFACES     =
    SLAVE_IFACES      =
    MANDATORY_DEVICES =
    VIRTUAL_IFACES    =
    SKIP              =
    start order       :  eth0 wlan0 ; ;
    Setting up network interfaces:
    ifup eth0 -o rc
        eth0      returned 0                                                                                                                         done
    ifup wlan0 -o rc
        wlan0     returned 0                                                                                                                         done
    ... still waiting for hotplug devices:
    SUCCESS_IFACES= eth0 wlan0
    MANDATORY_DEVICES=
    ... final
    SUCCESS_IFACES= eth0 wlan0
    MANDATORY_DEVICES=
    FAILED=0
    ifup-route noiface -o rc
    Setting up service network  .  .  .  .  .  .  .  .  .  .                                                                                         done
    Thanks.

  2. #2
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Network Not Properly Starting on Bootup

    Which network do you want to start - eth0 or wlan0?
    By default, eth0 should start automatically if the cable is connected.
    wlan0 is probably controlled by the network manager.
    If you go to yast>network devices, you ccan first change to using the traditional if up method and saving and then go back and adjust the settings for each card in the network manager settings.

  3. #3
    Join Date
    Nov 2008
    Location
    Minneapolis, MN
    Posts
    27

    Default Re: Network Not Properly Starting on Bootup

    Quote Originally Posted by whych View Post
    Which network do you want to start - eth0 or wlan0?
    eth0. wlan0 is unsed.

    By default, eth0 should start automatically if the cable is connected.
    In theory, yes.

    wlan0 is probably controlled by the network manager.
    I am not using NetworkManager.

    If you go to yast>network devices, you ccan first change to using the traditional if up method and saving and then go back and adjust the settings for each card in the network manager settings.
    I have tried to set eth0 to 'ifplugd' and 'auto' (auto is for on-boot apparently) - neither renew the IP on startup.

  4. #4
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Network Not Properly Starting on Bootup

    Try making wlan0 'not configured' in yast>network devices>net settings.
    (Choose the device and click edit>general)
    Set eth0 to 'at boot time'.

  5. #5
    Join Date
    Nov 2008
    Location
    Minneapolis, MN
    Posts
    27

    Default Re: Network Not Properly Starting on Bootup

    Quote Originally Posted by whych View Post
    Try making wlan0 'not configured' in yast>network devices>net settings.
    (Choose the device and click edit>general)
    Set eth0 to 'at boot time'.
    It is. wlan0's hardware was just added to the machine last night - this problem has existed for weeks. eth0 has been set to 'at boot time' as well (that's what 'auto' is in the config file). The trouble is the new kernel. The startup works fine under the stock kernel, but once it's updated to a non-stock kernel it stops working.

    There are several reasons for me to upgrade to 2.6.29+ - one primarily being support (and/or better support) for my Pinnicle HDTV TV Tuner card, as well as a few other less major reasons. I would just stay with the stock kernel, but it's not much of a practical solution.

    I've used Linux nearly exclusively for the past 8 years and despite my vast experience this bug has me stumped. I've tried everything I can, but for whatever reason it continues to not start on boot.

    Here's the exact output on boot:
    Code:
    Setting up (localfs) network interfaces:
        lo
        lo        IP address: 127.0.0.1/8
                  IP address: 127.0.0.2/8                                                   done
    Waiting for mandatory devices:  eth0 __NSC__
    11 10 9 7 6 5 4 2 1 0
        eth0      device: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
        eth0      DHCP4 client NOT running
        eth0      is down                                                                   failed
        eth0      interface could not be set up until now                                   failed
    eth0 is not so much as 'brought up' (e.g. not listed in ifconfig) on start, let alone an IP obtained.

  6. #6
    Join Date
    Nov 2008
    Location
    Minneapolis, MN
    Posts
    27

    Default Re: Network Not Properly Starting on Bootup

    Does anyone else have any ideas? I'm up to suggestions on how exactly to debug this.

    Thanks.

  7. #7
    Join Date
    Jul 2008
    Location
    Palmas, Tocantins - Brasil
    Posts
    23

    Default Re: Network Not Properly Starting on Bootup

    Hi,

    Same problem here as well:
    Code:
    Starting HAL daemondone
    Setting up network interfaces:
        lo        
        lo        IP address: 127.0.0.1/8   
                  IP address: 127.0.0.2/8   
        lo       
    done
    Waiting for mandatory devices:  eth0 __NSC__
    19 <notice>startproc: execve (/usr/bin/kdm) [ /usr/bin/kdm ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 TERM=linux SHELL=/bin/sh ROOTFS_FSCK=0 INIT_VERSION=sysvinit-2.86 KDEROOTHOME=/root/.kdm REDIRECT=/dev/tty1 COLUMNS=124 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x317 RUNLEVEL=5 SPLASHCFG=/etc/bootsplash/themes/openSUSE/config/bootsplash-1024x768.cfg PWD=/ LANG=en_US.UTF-8 PREVLEVEL=N LINES=44 QT_SYSTEM_DIR=/usr/share/desktop-data SHLVL=2 HOME=/ XCURSOR_THEME= WINDOWMANAGER= SPLASH=yes splash=silent ROOTFS_BLKDEV=/dev/disk/by-id/ata-WDC_WD1600AABS-61PRA0_WD-WMAP96207778-part6 _=/sbin/startproc DAEMON=/usr/bin/kdm ]
    18 17 16 15 14 <notice>checkproc: /usr/bin/kdm 3882
    13 12 11 10 9 8 7 6 5 4 3 2 1 0 
        eth0                                No interface found
    failed
    Setting up service network  .  .  .  .  .  .  .  .  .  .failed
    Starting service kdmdone
    It was functioning yesterday. After I've upgrade from kde 4.3 to 4.4 it stops starting on boot.
    Now only manually:
    Code:
    SUGEP-DMASI:/home/gilberto # ifup eth0
        eth0      device: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter (rev a0)
    
    SUGEP-DMASI:/home/gilberto # ifconfig                                            
    eth0      Link encap:Ethernet  HWaddr 00:1D:60:24:50:A7                          
              inet addr:10.121.1.94  Bcast:10.121.1.255  Mask:255.255.255.0          
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                     
              RX packets:914 errors:0 dropped:0 overruns:0 frame:0                   
              TX packets:522 errors:0 dropped:0 overruns:0 carrier:3                 
              collisions:0 txqueuelen:1000                                           
              RX bytes:527387 (515.0 Kb)  TX bytes:0 (0.0 b)                         
              Memory:ddec0000-ddf00000                                               
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:46 errors:0 dropped:0 overruns:0 frame:0
              TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0                            
              RX bytes:2300 (2.2 Kb)  TX bytes:2300 (2.2 Kb)       
    
    SUGEP-DMASI:/home/gilberto # cat /etc/sysconfig/network/ifcfg-eth0
    BOOTPROTO='static'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    IPADDR='10.121.1.94/24'
    MTU=''
    NAME='L2 100 Mbit Ethernet Adapter'
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='auto'
    USERCONTROL='no'
    
    SUGEP-DMASI:/home/gilberto # uname -a
    Linux SUGEP-DMASI 2.6.25.20-0.5-default #1 SMP 2009-08-14 01:48:11 +0200 i686 i686 i386 GNU/Linux
    Any tip here?

    Kinda regards,

    Gilberto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •