Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't switch sound output to headphones

  1. #1

    Default Can't switch sound output to headphones

    Acer Aspire 7530 laptop running suse 11.1 x86_64

    On this laptop in windows you have to switch the sound output to headphones using the soundcard's software

    I can't find any way to do this in suse

    The card is shown in Yast as MCP78S [Geforce 8200] High Definition Audio


    Anyone have any ideas how I can switch the sound output to the headphone socket?

  2. #2

    Default Re: Can't switch sound output to headphones

    31 views and no responses ... maybe I've asked on the wrong section?

  3. #3
    Join Date
    Apr 2009
    Location
    Stuttgart, Germany
    Posts
    114

    Default Re: Can't switch sound output to headphones

    Have a look here: SDB:AudioTroubleshooting - openSUSE

    Run the script and post the information.

  4. #4

    Default Re: Can't switch sound output to headphones

    The laptop's at home mate so I'll do that tonight (it's just coming up on lunchtime here)

  5. #5

    Default Re: Can't switch sound output to headphones

    Here ya go mate, here's the link:

    http://www.alsa-project.org/db/?f=9a...1b153b5aabc0e9

  6. #6
    Join Date
    Apr 2009
    Location
    Stuttgart, Germany
    Posts
    114

    Default Re: Can't switch sound output to headphones

    I see you also got the ALC888 (my laptop also got that one).

    Try to install/compile the newest alsa drivers.

    Then, in /etc/modprobe.d/sound add/modify the line:
    Code:
    options snd-hda-intel enable=1 index=0 model=auto
    where model can take one of the values specified in the "ALSA-configuration.txt" in the alsa-driver sources, after the line containing the string "ALC880". Here are some possible models:

    3stack-digout
    5stack
    5stack-digout
    6stack
    6stack-digout
    acer
    acer-aspire-4930g

    Every time you change the model string, restart the sound service using the command "/etc/init.d/alsasound restart" as root.

    If you're lucky you can find one model that works.
    Else you can ask in #alsa on freenode for someone to help you to set up a new model for your codec.

  7. #7

    Default Re: Can't switch sound output to headphones

    Before I tried your advice PVince81 I was getting a channel in kmix for headphones but there was no volume slider, like the channel was 'greyed out' so to speak

    Adding options snd-hda-intel enable=1 index=0 model=auto to /etc/modprobe.d/sound as you suggested did get the headphone channel enabled complete with volume slider, thought we were in business!

    (/etc/modprobe.d/sound was empty before doing this)

    Still don't get volume through the headphones though

    Even in windows with this card you can't just plug the headphones in and get sound through them, there's an I/O section in the card's 'control panel' and headphones have to be selected in there to get sound out of them and mute the speakers

    It's as if it's almost there but there's something I must do to 'tell' the card to send the output to the phones instead of the speakers ... god knows what though


    Incidentally there's also a file called sound.YaST2Save in /etc/modprobe with the following lines in it:

    options snd slots=snd-hda-intel
    # M71A.usNviCF37Y6:MCP78S [GeForce 8200] High Definition Audio
    alias snd-card-0 snd-hda-intel


    I'm assuming this file gets read in and wondering if the values in it might not be interfering

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Can't switch sound output to headphones

    Can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

    Please note I am on vacation, so my reply may be 3 or 4 days in coming.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Can't switch sound output to headphones

    Quote Originally Posted by Ecky View Post
    Adding options snd-hda-intel enable=1 index=0 model=auto to /etc/modprobe.d/sound as you suggested did get the headphone channel enabled complete with volume slider, thought we were in business!
    Note that instead of the model option "auto", there are many other options one can try instead. From the alsa-configuration.txt file for 1.0.18 of alsa:

    Code:
    	ALC883/888
    	  3stack-dig	3-jack with SPDIF I/O
    	  6stack-dig	6-jack digital with SPDIF I/O
    	  3stack-6ch    3-jack 6-channel
    	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
    	  6stack-dig-demo  6-jack digital for Intel demo board
    	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
    	  acer-aspire	Acer Aspire 9810
    	  medion	Medion Laptops
    	  medion-md2	Medion MD2
    	  targa-dig	Targa/MSI
    	  targa-2ch-dig	Targs/MSI with 2-channel
    	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
    	  lenovo-101e	Lenovo 101E
    	  lenovo-nb0763	Lenovo NB0763
    	  lenovo-ms7195-dig Lenovo MS7195
    	  lenovo-sky	Lenovo Sky
    	  haier-w66	Haier W66
    	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
    	  6stack-dell	Dell machines with 6stack (Inspiron 530)
    	  mitac		Mitac 8252D
    	  clevo-m720	Clevo M720 laptop series
    	  fujitsu-pi2515 Fujitsu AMILO Pi2515
    	  3stack-6ch-intel Intel DG33* boards
    	  auto		auto-config reading BIOS (default)
    Note they can only be applied one at a time, and alsa must be restarted between each attempt, either by restarting the pc, or by typing in a terminal: su -c 'rcalsasound restart' enter root password, restart one's mixer, and test the sound.

  10. #10
    Join Date
    Apr 2009
    Location
    Stuttgart, Germany
    Posts
    114

    Default Re: Can't switch sound output to headphones

    On my laptop I don't have a headphone channel. When I plug a headphone/external speakers into the jack, it will automatically switch to headphone/out mode and the laptop speakers will mute.

    In your case, like oldcpu advised, you can try the other model strings.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •