Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: vsftp log doesn't exist

  1. #1
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default vsftp log doesn't exist

    Hello all!

    I'm trying to configure vsftp with SSL but it gives me an error, so I want to see the logs.
    Problem is that the file /var/log/vsftpd.log doesn't exist.

    In the config file I have the following:
    # Log to the syslog daemon instead of using an logfile.
    #
    #syslog_enable=NO

    Is it correct?

    Best regards,
    Jorge

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,761

    Default Re: vsftp log doesn't exist

    IMHO this says that that loging goes to syslog (so not very clear). When you remove the # before the last line it says NOT to use syslog. I hope it then goes to a logfile. If this is the file you suspect it is, I can not say out of the info given here.

    Just try it, it will not fry your system
    Henk van Velden

  3. #3
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: vsftp log doesn't exist

    Hi!

    I tried to do as you told but no effect.

    I found an indication that probably I should have

    Code:
    # Set listen=YES if you want vsftpd to run standalone
    #
    listen=NO
    So that it runs as a service.

    But I have
    Code:
    # Set listen=YES if you want vsftpd to run standalone
    #
    listen=YES
    And it is told that this might be related to the lack of log. But if I change it to listen=NO it gives me an error and it won't start. And without log I can't find out what's going on...

    Best regards

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,761

    Default Re: vsftp log doesn't exist

    IMHO LISTEN should be yes if you start the daemon as a service. It should be no if you start it from xinetd because then xinetd does the listening.

    I do not know what method you use (because you did not tell). You could check if what you do is consistent which wht I tell you, but as it is functioning this does not matter to much.

    I doubt if the method you use has anything to do with the logging. We suppose that the logging is going now to syslog, do we?. Did you check if there is somthing in syslog?
    Henk van Velden

  5. #5
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: vsftp log doesn't exist

    IMHO LISTEN should be yes if you start the daemon as a service. It should be no if you start it from xinetd because then xinetd does the listening.
    Ok. It's working with LISTEN=YES. I don't want to use xinetd, in fact it's not even running, so that must be the reason why it doesn't start with LISTEN=NO.

    I doubt if the method you use has anything to do with the logging. We suppose that the logging is going now to syslog, do we?. Did you check if there is something in syslog?
    Ok, so comming back to the syslog_enable question, I've set it to NO to see if there is any /var/log/vsftpd.log file created. There isn't.
    I've changed it to syslog_enable=YES and there is nothing appearing on dmesg or /var/log/messages.
    Am I looking on the wrong place?

    Best regards,
    Jorge

  6. #6
    Camalen NNTP User

    Default Re: vsftp log doesn't exist

    jorgeraimundo wrote:

    > Ok, so comming back to the syslog_enable question, I've set it to NO to
    > see if there is any /var/log/vsftpd.log file created. There isn't.
    > I've changed it to syslog_enable=YES and there is nothing appearing on
    > dmesg or /var/log/messages.
    > Am I looking on the wrong place?


    Setting "syslog_enable=YES" should log messages to "syslog-ng", so you'll
    have to configure that part, creating the appropriate filters and
    facilities for vsftp before any file is created.

    Anyway, these settings should be enough:

    ***
    syslog_enable=NO
    vsftpd_log_file=/var/log/vsftpd.log
    ***

    The manual states:

    vsftpd_log_file
    This option is the name of the file to which we write the vsftpd style log
    file. This log is only written if the option xferlog_enable is set, and
    xferlog_std_format is NOT set. Alternatively, it is written if you have set
    the option dual_log_enable. One further complication - if you have set
    syslog_enable, then this file is not written and output is sent to the
    system log instead.

    Greetings,

    --
    Camalen

  7. #7
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: vsftp log doesn't exist

    Hello Camalen!

    Thank you for your reply!
    I did as told. In fact I'm placing my config here:
    Code:
    write_enable=YES
    dirmessage_enable=YES
    nopriv_user=ftpsecure
    
    local_enable=YES
    local_umask=022
    
    chroot_local_user=YES
    local_root=/srv/ftp/
    anon_root=/srv/ftp/pub/
    
    anonymous_enable=YES
    anon_world_readable_only=YES
    anon_upload_enable=NO
    anon_umask=022                                                               
    anon_mkdir_write_enable=NO
    
    syslog_enable=NO
    log_ftp_protocol=NO
    vsftpd_log_file=/var/log/vsftpd.log
    
    connect_from_port_20=YES
    
    idle_session_timeout=900
    
    pasv_enable=YES
    
    pam_service_name=vsftpd
    
    listen=YES
    
    ssl_enable=NO
    
    pasv_min_port=40000
    pasv_max_port=40500
    
    max_clients=10
    max_per_ip=3
    
    ssl_sslv2=NO
    ssl_sslv3=NO
    ssl_tlsv1=YES
    If I change log_ftp_protocol to YES the server won't start.

    Even with the explicit indication of syslog_enable=NO and vsftpd_log_file=/var/log/vsftpd.log the file isn't created.

    I'm getting puzzled.

  8. #8
    Camalen NNTP User

    Default Re: vsftp log doesn't exist

    jorgeraimundo wrote:

    > Hello Camalen!
    >
    > Thank you for your reply!
    > I did as told. In fact I'm placing my config here:
    >
    > Code:
    > --------------------
    > syslog_enable=NO
    > log_ftp_protocol=NO
    > vsftpd_log_file=/var/log/vsftpd.log
    > --------------------
    >
    >
    > If I change log_ftp_protocol to YES the server won't start.


    You don't have to change "log_ftp_protocol" to YES unless you really need
    it :-?

    What man page says is "This log is only written if the option xferlog_enable
    is set, and xferlog_std_format is NOT set." so test with
    xferlog_enable=YES and restart the daemon (rcvsftpd restart) :-)

    Greetings,

    --
    Camalen

  9. #9
    Join Date
    Sep 2009
    Location
    Alverca do Ribatejo, Portugal
    Posts
    53

    Default Re: vsftp log doesn't exist

    Here's what happens with the xferlog_enable=YES:

    Code:
    Shutting down vsftpd                                                                            done
    Starting vsftpd startproc:  exit status of parent of /usr/sbin/vsftpd: 1                        failed
    And the worse is that there's no log to see what's going wrong...

  10. #10
    Camalen NNTP User

    Default Re: vsftp log doesn't exist

    jorgeraimundo wrote:

    > Here's what happens with the xferlog_enable=YES:
    >
    >
    > Code:
    > --------------------
    > Shutting down vsftpd
    > done
    > Starting vsftpd startproc: exit status of parent of /usr/sbin/vsftpd: 1
    > failed
    > --------------------


    Ouch! Ok, ok... don't panic :-P

    Here is what I have:

    ***
    xferlog_enable=YES
    xferlog_std_format=YES
    dual_log_enable=YES
    ***

    Try to set these 3 options.

    > And the worse is that there's no log to see what's going wrong...


    If a dameon does not start you can review the usual logs (/var/log/messages
    and /var/log/warn).

    Greetings,

    --
    Camalen

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •