Results 1 to 4 of 4

Thread: holding key causes inability to type

  1. #1

    Unhappy holding key causes inability to type

    I'm using OpenSuse 11.0 with KDE 4.3.1 and I have the following problem:

    Whenever I hold any key for a prolonged period (e.g. holding shift for a while when working with Inkscape) I can't type anything anymore. I just don't get any input whatever I do on the keyboard unless I hold a key for a couple of seconds, then it finally accepts the input. This happens regardless of the key held down initially and with any application (KDE or Gnome). To get rid of it I have to log out and back in, so I suspect either X or KDE to be the problem.

    Does anybody know what's causing this and how to solve the issue? Many thanks in advance.

  2. #2
    platinum NNTP User

    Default Re: holding key causes inability to type

    slow keys, see:
    http://forums.opensuse.org/how-faq-r...-keyboard.html

    -welcome-

    --
    platinum

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: holding key causes inability to type

    Don't know, but I can give you some hint. Look in Systemsettings, Accessibility. AFAIK if you hold down the Shift for a long time on a fresh install/homedir, a question will pop-up asking you whether you want to use the accessibility features.
    Another way to find out, is to create a new user, login as that user, and see if same problem exists or can be reproduced. We then would know the problem lives in your homedir.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: holding key causes inability to type

    Thank you very much, following your advice and the above link I turned on the confirmation dialog for slow keys and it was indeed that feature being turned on without asking for permission or showing an info popup. A sign of poor default settings if you ask me... Anyway after disabling it once and for all I can finally get back to actually working with my box!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •