Results 1 to 2 of 2

Thread: ACPI & undiscovered usb bluetooth adapter

  1. #1

    Default ACPI & undiscovered usb bluetooth adapter

    Hello,

    I'm new to linux and looking for help with getting my bluetooth working.

    Here's what I know so far:

    I've installed openSUSE 11.1 64 bit KDE4 edition on a new hard drive I installed on my Motion Computing J3400 tablet PC by booting from a USB connected optical drive that had the above on an OSDisc.com live CD. The internal bluetooth adapter for this computer is connected via USB and (cf LE1600, linux, and bluetooth - Forums post 3) is turned off by default. It won't show up as a USB device until software tells it to turn on. Motion's specificatons say that the computer is ACPI 2.0 compliant, and so, in order to turn the bluetooth on I would expect from what I've learned so far, that I need to set /sys/class/rfkill/rfkill1/state to 1. However, /sys/class/rfkill only contains one folder: rfkill0 - for the wifi. From the INF file for Motion's Windows bluetooth driver, I have USB\Vid_10ab&Pid_1005 where I assume Vid is Vendor ID and Pid is Product ID. This makes it the bluetooth adapter from the Taiwanese company USI Co., Ltd. I think they also sell bluetooth adapters to Dell and Toshiba. If it matters, bluetooth worked for a few minutes after the install, but never since the first post-install reboot.

    Here's my questions:

    Is there any way I can use the Vendor and Product IDs to manually edit a file somewhere and tell the operating system that the device exists, so that I can subsequently request that it be turned on?

    Alternatively, is there any USB utility or acpid script that can try turning on this hardware at all the USB endpoints so that the OS can find it?

    The ACPIspec-2-0c document mentions querying USB device power status, but perhaps this situation is something different. Am I mistaken about this being an ACPI related problem?

    Thanks for taking the time to read and consider these words.

    John Banister

  2. #2

    Default Re: ACPI & undiscovered usb bluetooth adapter

    Note:

    Owing to a different problem, I had to reinstall.
    I installed OpenSuse 11.2 - KDE 4.3.1 "release 6"
    During automatic configuration, the OS found my internal
    bluetooth adapter.

    - John Banister

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •