Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Only kate 4.1.3 with KDE 4.3.1?

  1. #1

    Default Only kate 4.1.3 with KDE 4.3.1?

    Hi,

    I've upgraded KDE 4.1.3 to 4.3.1 using the KDE repositories kde-desktop and kde-community.
    However I can't find a new kate. The only one available is 4.1.3 from repo-oss.
    Where's the 4.3.1 version?

    Thanks,
    Koos

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    I don't know how you update the system, because most of the mirrors are down.
    You can wait till tomorrow, then can update Kate from software management.
    Search for Kate in search box and then choose version tab and select the latest version. Or right click and select update.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    You are likely confused by package renaming. Is your kate (kde4-kate)
    In 4.3 it is just kate.
    kde4-kate will need deleting

    This is my info

    Code:
    rpm -qi kate
    Name        : kate                         Relocations: (not relocatable)
    Version     : 4.3.1                             Vendor: openSUSE Build Service
    Release     : 78.4                          Build Date: Wed 09 Sep 2009 08:22:23 BST
    Install Date: Wed 09 Sep 2009 18:24:00 BST      Build Host: build27
    Group       : Productivity/Editors/Other    Source RPM: kdesdk4-4.3.1-78.4.src.rpm
    Size        : 2740355                          License: GPL v2 or later
    Signature   : DSA/SHA1, Wed 09 Sep 2009 08:24:51 BST, Key ID 58d8ff412e1efa87
    URL         : http://www.kde.org/
    Summary     : Advanced Text Editor
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    Found the culprit...
    kate 4.1.3 maps by default to a karaoke application.
    YaST does have a 4.3.1 version (from kde-desktop), but according to YaST this is the karaoke app. I installed the 4.3.1 regardless and now YaST says it's the text editor :-)

    Apparently there is a naming conflict bug. Two apps having the same name from different repos, are only displayed with the one name.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    Quote Originally Posted by koospol View Post
    Found the culprit...
    kate 4.1.3 maps by default to a karaoke application.
    YaST does have a 4.3.1 version (from kde-desktop), but according to YaST this is the karaoke app. I installed the 4.3.1 regardless and now YaST says it's the text editor :-)

    Apparently there is a naming conflict bug. Two apps having the same name from different repos, are only displayed with the one name.
    It's not a bug. It's as a result of the repo's you have added to get 4.3
    You should use the versions tab in software management in such cases. It may be exacerbated by your repo priorities if you have them wrong.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    <Darth Vader mode>

    There is _no_ conflict

    </Darth Vader mode>

    (SCNR, I always wanted to write this in a forum ...)

    Code:
    webpin kate
       29 results (16 packages) found for "kate" in openSUSE_111
    * kate: Advanced Text Editor
       - 4.3.66svn1016707 [KDE:/KDE4:/UNSTABLE:/Desktop]
       - 4.3.1 [KDE:/KDE4:/Factory:/Desktop]
       - 0.3.4 [home:/RedDwarf]
    * kate-devel: Advanced Text Editor Development Headers
       - 4.3.66svn1016707 [KDE:/KDE4:/UNSTABLE:/Desktop]
       - 4.3.1 [KDE:/KDE4:/Factory:/Desktop]
    * katesort: Kate Sort Plugin
       - 1.0 [KDE:/Community]
    * katesort-debuginfo: Debug information for package katesort
       - 1.0 [KDE:/Community]
    * katesort-debugsource: Debug sources for package katesort
       - 1.0 [KDE:/Community]
    * kateutils: Commandline tools to use libkate
       - 0.3.6 [packman]
    * faust-kate-extension: Faust Syntax Highlighting for kate
       - 0.9.9.4 [packman]
    * kde4-kate: Advanced Text Editor
       - 4.1.3 [suse-oss | KDE:/KDE4:/STABLE:/Desktop]
       - 4.2.4 [KDE:/42]
    * kde4-kate-devel: Advanced Text Editor Development Headers
       - 4.1.3 [suse-oss | KDE:/KDE4:/STABLE:/Desktop]
       - 4.2.4 [KDE:/42]
    * kdeaddons3-kate: A text editor for KDE
       - 3.5.10 [suse-oss | KDE:/KDE3 | home:/wstephenson]
    * libkate-devel: Codec for Karaoke and Text Encapsulation for Ogg
       - 0.3.6 [packman]
       - 0.3.4 [home:/RedDwarf]
    * libkate1: Codec for Karaoke and Text Encapsulation for Ogg
       - 0.3.6 [packman]
       - 0.3.4 [home:/RedDwarf]
    * libkate1-debuginfo: Debug information for package libkate1
       - 0.3.6 [packman]
       - 0.3.4 [home:/RedDwarf]
    * libkate1-debugsource: Debug sources for package libkate1
       - 0.3.6 [packman]
       - 0.3.4 [home:/RedDwarf]
    * perl-Net-Clickatell: Access to Clickatell HTTP API fro sending GSM text messages (SMS)
       - 0.30 [home:/cwh]
    * ufoai-kate-extension: UFO: ALIEN INVASION Syntax Highlighting for kate
       - 2.2.1 [packman]
    kate != kde4-kate != libkate1 != kateutils

    //Edit:

    However, if this "kate 0.3.4" from "home:RedDwarf" is this karaoke plugin, then inform the maintainer to repackage his "kate" (like i.e. packman does).

  7. #7

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    Quote Originally Posted by caf4926 View Post
    It's not a bug. It's as a result of the repo's you have added to get 4.3
    You should use the versions tab in software management in such cases.
    I get that, but that's the confusing part.
    Yast says kate 4.1.3 is a karaoke application.
    It's impossible to tell from the versions tab, that 4.3.1 is something completely different. So I had to install version 4.3.1 just on good fortune to find out I indeed I installed the text editor.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    Post your repo's for us:

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    Columns [Enabled, Refresh, Service] snipped for brevity.
    Code:
    koos@specht:~> zypper lr -d
    #  | Alias           | Naam                                               |Prioriteit | Type   | URI
    ---+-----------------+----------------------------------------------------+-----------+--------+--------------------------------------------------------------------------------------------------------
    1  | Mozilla         | Mozilla                                            |  99       | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/
    2  | kde-community   | kde-community                                      |  99       | rpm-md | http://download.opensuse.org/repositories/KDE%3a/KDE4%3a/Community/openSUSE_11.1_KDE4_Factory_Desktop
    3  | kde-desktop     | kde-desktop                                        |  99       | rpm-md | http://download.opensuse.org/repositories/KDE%3a/KDE4%3a/Factory%3a/Desktop/openSUSE_11.1/
    4  | openSUSE 11.1-0 | openSUSE 11.1-0                                    |  99       | yast2  | cd:///?devices=/dev/sr0
    5  | repo            | NVIDIA Repository                                  |  99       | rpm-md | http://download.nvidia.com/opensuse/11.1
    6  | repo-debug      | openSUSE-11.1-Debug                                | 100       | NONE   | http://download.opensuse.org/debug/distribution/11.1/repo/oss/
    7  | repo-non-oss    | openSUSE-11.1-Non-Oss                              | 100       | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/
    8  | repo-oss        | openSUSE-11.1-Oss                                  | 100       | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/
    9  | repo-source     | openSUSE-11.1-Source                               | 100       | NONE   | http://download.opensuse.org/source/distribution/11.1/repo/oss/
    10 | repo-update     | openSUSE-11.1-Update                               |  20       | rpm-md | http://download.opensuse.org/update/11.1/
    11 | repo_1          | VideoLan Repository                                |  99       | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.1/
    12 | repo_2          | Packman Repository                                 |  99       | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/
    13 | repo_3          | openSUSE Build-service - X11:Compiz                |  99       | rpm-md | http://download.opensuse.org/repositories/X11:/Compiz/openSUSE_11.1/
    14 | repo_4          | openSUSE BuildService - Spellen                    |  99       | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_11.1/
    15 | repo_5          | openSUSE Education                                 |  99       | yast2  | http://www.opensuse-education.org/download/repo/1.0/11.1
    16 | repo_6          | openSUSE BuildService - OpenOffice.org             |  99       | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.1/
    17 | repo_7          | openSUSE BuildService - Virtualisatie (VirtualBox) |  99       | rpm-md | http://download.opensuse.org/repositories/Virtualization:/VirtualBox/openSUSE_11.1/

  10. #10

    Default Re: Only kate 4.1.3 with KDE 4.3.1?

    Code:
    1/
    11 | repo_1          | VideoLan Repository                                |  99       | rpm-md | http://download.
    Disable or remove that.

    Columns [Enabled, Refresh, Service] snipped for brevity.
    Bad idea.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •