Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Error Installing SMPlayer

  1. #1

    Default Error Installing SMPlayer

    When I try to install SMPlayer (either from command line or through yast) I get the following error:

    Code:
    Problem: nothing provides libdirectfb-1.1.so.0 needed by MPlayer-1.0rc2_r29116-2.pm.28.1.i586
     Solution 1: do not ask to install a solvable providing smplayer
    I can then either accept (and not install SMPlayer) or cancel.

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Error Installing SMPlayer

    Did you updated your system after installation?
    Also, is packman repo added?
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  3. #3

    Default Re: Error Installing SMPlayer

    Yes - though I did have to manually add the repository via providing a link if that's relevant (I'm sure I remember it being in a list of ones to choose from last time I installed?)

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Error Installing SMPlayer

    Post the result of:

    zypper lr --details
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  5. #5

    Default Re: Error Installing SMPlayer

    Code:
    Repositories have been successfully exported to tails.repo.
    Tails.repo (which I'm guessing you want ) contains:
    Code:
    [11.0]
    name=11.0
    enabled=0
    autorefresh=1
    baseurl=http://download.videolan.org/pub/vlc/SuSE/11.0/
    path=/
    type=rpm-md
    keeppackages=0
    
    [Packman-RPMs]
    name=Packman-RPMs
    enabled=1
    autorefresh=1
    baseurl=http://packman.mirrors.skynet.be/pub/packman/suse/11.0/
    path=/
    type=rpm-md
    keeppackages=0
    
    [openSUSE 11.1-0]
    name=openSUSE 11.1-0
    enabled=0
    autorefresh=0
    baseurl=cd:///?devices=/dev/sr0
    path=/
    type=yast2
    keeppackages=0
    
    [repo-debug]
    name=openSUSE-11.1-Debug
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/debug/distribution/11.1/repo/oss/
    path=/
    type=yast2
    priority=100
    keeppackages=0
    
    [repo-non-oss]
    name=openSUSE-11.1-Non-Oss
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/distribution/11.1/repo/non-oss/
    path=/
    type=yast2
    priority=100
    keeppackages=0
    
    [repo-oss]
    name=openSUSE-11.1-Oss
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/distribution/11.1/repo/oss/
    path=/
    type=yast2
    priority=100
    keeppackages=0
    
    [repo-source]
    name=openSUSE-11.1-Source
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/source/distribution/11.1/repo/oss/
    path=/
    type=yast2
    priority=100
    keeppackages=0
    
    [repo-update]
    name=openSUSE-11.1-Update
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/update/11.1/
    path=/
    type=rpm-md
    priority=20
    keeppackages=0

  6. #6

    Default Re: Error Installing SMPlayer

    I am just wondering if people read their info before they actually post it.

    Did you have a look at your output?

    Or in other words, what do you think will happen, if you mix openSUSE versions in your repo list?

  7. #7
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Error Installing SMPlayer

    Assuming that you are in openSUSE 11.1, am i right?
    Don't mix different version of openSUSE repos with each other.
    Now, the repo added for packman is for 11.0 which is:

    Index of /pub/packman/suse/11.0

    Ok, now open YaST-> software repositories and add this repo through URL:
    Index of /pub/linux/misc/packman/suse/11.1

    Note: Make sure, that you disabled the other one, i would recommend delete it before adding the above provided one.

    And try to install smplayer now.

    EDIT: @Akoellh: You are right, and thats why i clear the idea for him here.
    Last edited by mmarif4u; 13-Sep-2009 at 02:36. Reason: To add more comments.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  8. #8

    Default Re: Error Installing SMPlayer

    Quote Originally Posted by mmarif4u View Post
    EDIT: @Akoellh: You are right, and thats why i clear the idea for him here.
    You forgot the second wrong repo, videolan is also 11.0.

  9. #9
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Error Installing SMPlayer

    Quote Originally Posted by Akoellh View Post
    You forgot the second wrong repo, videolan is also 11.0.
    Huh..good caught.
    Actually i saw that, that was disabled, so i did not say anything about it.
    Anyway Azhtabak delete both repos, only packman is enough.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  10. #10

    Default Re: Error Installing SMPlayer

    Quote Originally Posted by mmarif4u View Post
    Actually i saw that, that was disabled, so i did not say anything about it.
    Correct, but it would be enabled at any time with one click, calling for more trouble immediately after that.

    Quote Originally Posted by mmarif4u View Post
    Anyway Azhtabak delete both repos, only packman is enough.
    I fully agree.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •