Results 1 to 10 of 10

Thread: Automount problems with 11.1

  1. #1

    Default Automount problems with 11.1

    Greetings All,

    I have a number of externally mounted, SATA drives, each formatted EXT2, with unique labels. Each drive has an entry in /etc/fstab with a LABEL= statement so that each drive has a unique mount point. There are also a couple of partitions on the main drive that are NOT in the fstab, and so are not
    normally mounted (by design).


    Under SUSE 11.0 this worked fairly well. When a drive was powered on, I only needed to issue a
    sudo mount -a
    command to make the drive available.


    After installing SUSE 11.1 (with a clean install), I've discovered that things appear to work a bit differently. Although I can still mount drives using the mount command, I am besieged by pop-up messages asking me if I want to open the drive in a new window. Not only am I getting messages for the just mounted drive, but also for the unmounted partitions on the main drive!

    If I select "Open In New Window" from this pop-up, I get one of two messages:
    "Permissions denied"
    or
    org.freedesktop.hal.storage.mount-fixed uth_admin_keep_always <-- (action, result)

    Which makes these pop-ups not only annoying, but useless.


    Is there a way to turn off these messages without affecting automount for CDs/DVDs?

    Even better: Is there a way for a drive specified in fstab (or someplace else) to be automatically and silently mounted when it is powered on? I am using KDE 3.5 in SUSE 11.1, as I was in 11.0.


    Thanx in advance to any kind soul who can render some advise.


    Rich

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Automount problems with 11.1

    Are these USB devices. USB devices are not set with mount points in fstab
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Automount problems with 11.1

    Quote Originally Posted by caf4926 View Post
    Are these USB devices. USB devices are not set with mount points in fstab
    Nope, not USB. These are SATA hard drives on a SATA controller.


    Rich

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,709
    Blog Entries
    1

    Default Re: Automount problems with 11.1

    Hi richardrosa. I think the answer may lie with hal's policy settings. Have a look at

    cat /usr/share/PolicyKit/policy/org.freedesktop.hal.storage.policy
    In particular, the 'org.freedesktop..hal.storage.mount-fixed' section, will have

    <allow_active>auth_admin_keep_always</allow_active>
    You can change this to

    <allow_active>yes</allow_active>
    See how that goes.

  5. #5

    Default Re: Automount problems with 11.1

    Quote Originally Posted by deano_ferrari View Post
    Hi richardrosa. I think the answer may lie with hal's policy settings. Have a look at



    In particular, the 'org.freedesktop..hal.storage.mount-fixed' section, will have



    You can change this to



    See how that goes.
    Hi deano_ferrari.

    It sounded logical, but it doesn't look like the changes made
    any difference. Still getting the same pop-ups, and using the
    MOUNT in the pop-up returns an error. I've added the contents
    of this file to this post. Maybe I missed something...


    Rich


    *** copy of updated ..storage.policy:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE policyconfig PUBLIC
    "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
    "http://www.freedesktop.org/standards/PolicyKit/1.0/policyconfig.dtd">

    <!--
    Policy definitions for HAL's drives/media mechanims.

    Copyright (c) 2007 David Zeuthen <david@fubar.dk>

    HAL is licensed to you under your choice of the the Academic Free
    License Version 2.1, or the GNU General Public License version 2. Some
    individual source files may be under the GPL only. See COPYING for
    details.
    -->

    <policyconfig>

    <action id="org.freedesktop.hal.storage.mount-fixed">
    <description>Mount file systems from internal drives.</description>
    <message>System policy prevents mounting internal media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
    </defaults>
    </action>

    <action id="org.freedesktop.hal.storage.mount-removable">
    <description>Mount file systems from removable drives.</description>
    <message>System policy prevents mounting removable media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
    </defaults>
    </action>

    <action id="org.freedesktop.hal.storage.unmount-others">
    <description>Unmount file systems mounted by other users.</description>
    <message>System policy prevents unmounting media mounted by other users</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
    </defaults>
    </action>

    <action id="org.freedesktop.hal.storage.eject">
    <description>Eject removable media.</description>
    <message>System policy prevents ejecting removable media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
    </defaults>
    </action>

    <action id="org.freedesktop.hal.storage.crypto-setup-fixed">
    <description>Set up decryption for encrypted fixed storage devices.</description>
    <message>System policy prevents accessing encrypted fixed media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
    </defaults>
    </action>

    <action id="org.freedesktop.hal.storage.crypto-setup-removable">
    <description>Set up decryption for encrypted removable storage devices.</description>
    <message>System policy prevents accessing encrypted removable media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
    </defaults>
    </action>

    </policyconfig>

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,709
    Blog Entries
    1

    Default Re: Automount problems with 11.1

    Your edit looks ok. Some users have found that they needed to alter <allow_inactive> to

    <allow_inactive>yes</allow_inactive>
    as well. (I'm not sure why though).

    I have a number of externally mounted, SATA drives, each formatted EXT2, with unique labels.
    Re-reading your original post, the above what makes your situation less typical. Your external drives treated as internal by the OS, essentially because of the SATA interface. Normally, /etc/fstab with boot-time or manual mounting is uesd here.

    However, (please correct if I'm here), I'm assuming these are removable, and you would like to have hal automount these for you (as user) when plugged in.

    1) The preferred /etc/fstab approach:
    You could edit the /etc/fstab entries for the SATA volumes, with the 'noauto' option, and give user r/w access as well. Then use the 'mount -a' command (as root) when you have made any drive changes, and require access. Post your /etc/fstab contents if you need help on this.

    2) hal approach (not preferred or recommended):
    The fdi file '/usr/share/hal/fdi/policy/10osvendor/99-storage-policy-fixed-drives.fdi' determines how fixed storage media is treated.

    <deviceinfo version="0.2">
    <device>
    <match key="@block.storage_device:storage.hotpluggable" bool="false">
    <match key="@block.storage_device:storage.removable" bool="false">
    <merge key="volume.ignore" type="bool">true</merge>
    </match>
    </match>
    </device>
    </deviceinfo>
    Change the merge key to:

    <merge key="volume.ignore" type="bool">false</merge>
    Interesting discussion in this thread concerning the hal fdi policy concerning (internal) fixed partitions.

  7. #7

    Default Re: Automount problems with 11.1

    Quote Originally Posted by deano_ferrari View Post
    Your edit looks ok. Some users have found that they needed to alter <allow_inactive> to



    as well. (I'm not sure why though).



    Re-reading your original post, the above what makes your situation less typical. Your external drives treated as internal by the OS, essentially because of the SATA interface. Normally, /etc/fstab with boot-time or manual mounting is uesd here.

    However, (please correct if I'm here), I'm assuming these are removable, and you would like to have hal automount these for you (as user) when plugged in.

    1) The preferred /etc/fstab approach:
    You could edit the /etc/fstab entries for the SATA volumes, with the 'noauto' option, and give user r/w access as well. Then use the 'mount -a' command (as root) when you have made any drive changes, and require access. Post your /etc/fstab contents if you need help on this.

    2) hal approach (not preferred or recommended):
    The fdi file '/usr/share/hal/fdi/policy/10osvendor/99-storage-policy-fixed-drives.fdi' determines how fixed storage media is treated.



    Change the merge key to:



    Interesting discussion in this thread concerning the hal fdi policy concerning (internal) fixed partitions.

    Yes, these are removable SATA drives.

    Option 1 is the procedure used under Suse 11.0. I'd be happy to continue this way if I could just get rid of these !@#$$% pop-ups. Some of these drives have two or three partitions, and I'm forced to clear multiple messages when the drive is brought online. And if I run something like gparted, I get one for every non-mounted partition on the system. This is getting to be a royal pain..

    '/usr/share/hal/fdi/policy/10osvendor/99-storage-policy-fixed-drives.fdi' doesn't appear to exist. I created one using your append, with no difference. I also added the noauto to every disk option in the fstab, Still getting the useless dialogs...

    Sample fstab line:

    LABEL=ARCHIVE-001 /arc/archive-001 ext2 noauto,defaults 0 0


    Thanx for the suggestions.

    Rich

  8. #8

    Default Re: Automount problems with 11.1

    Additional information:

    The changes that you suggested do make ONE difference: I can no longer mount the drives using the "mount -a" command. This is not very useful, as the drives STILL do not get mounted automatically, and the pop-ups just keep on coming..

    Rich

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,709
    Blog Entries
    1

    Default Re: Automount problems with 11.1

    If you have the external SATA drive volume entries in /etc/fstab (the traditional, preferred method), then you will to prevent hal from attempting to mount these at all. So you would need to edit the policy file like this

    <action id="org.freedesktop.hal.storage.mount-fixed">
    <description>Mount file systems from internal drives.</description>
    <message>System policy prevents mounting internal media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>no</allow_active>
    </defaults>
    </action>
    They won't be automounted, but it should be possible to mount as root with 'mount -a', the same as with any other fixed volume. Please post entire /etc/fstab

  10. #10

    Default Re: Automount problems with 11.1

    Quote Originally Posted by deano_ferrari View Post
    If you have the external SATA drive volume entries in /etc/fstab (the traditional, preferred method), then you will to prevent hal from attempting to mount these at all. So you would need to edit the policy file like this



    They won't be automounted, but it should be possible to mount as root with 'mount -a', the same as with any other fixed volume. Please post entire /etc/fstab

    Changed everything to NO in this file but still getting the prompts. Here is entire /etc/fstab:


    /dev/sda2 / ext2 acl,user_xattr 1 1
    /dev/sda6 /home ext2 defaults 1 2
    /dev/sda5 swap swap defaults 0 0
    /dev/sda8 /d-drive vfat uid=rich,users,gid=users,umask=0002,utf8=true 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    ##
    LABEL=ARCHIVE-001 /arc/archive-001 ext2 defaults 0 0
    LABEL=ARCHIVE-002 /arc/archive-002 ext2 defaults 0 0
    LABEL=ARCHIVE-003 /arc/archive-003 ext2 defaults 0 0
    LABEL=ARCHIVE-004 /arc/archive-004 ntfs-3g user,users,gid=users,uid=rich,umask=0002 0 0
    LABEL=ARCHIVE-005 /arc/archive-005 ext2 defaults 0 0
    LABEL=ARCHIVE-006 /arc/archive-006 ext2 defaults 0 0
    LABEL=ARCHIVE-007 /arc/archive-007 ext2 defaults 0 0
    LABEL=ARCHIVE-008 /arc/archive-008 ext2 defaults 0 0
    LABEL=ARCHIVE-009 /arc/archive-009 ext2 defaults 0 0



    Note that only one or two of the ARCHIVE disks are powered on at any given time, and usually not powered on system boot. There are other partitions on sda that are NOT mounted (by design).

    I don't know if it is important, but this is the 64 bit version of SUSE, running on an AMD processor.


    Rich

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •