Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: OpenSuSE 11.1: extreme long boot time

  1. #1

    Default OpenSuSE 11.1: extreme long boot time

    Hi,

    I assembled a new PC (modern Gigabyte motherboard, Intel quadcore, 2 sata disks, 4GB ram) and installed 11.1

    Amazingly the boot time exceeds 2:30 minutes.

    I made a bootchart graph and see kthreadd being rediculously busy.
    Can some smart soul tell me what is going on here?

    Thanks,
    Koos


  2. #2

    Default Re: OpenSuSE 11.1: extreme long boot time

    I can't offer you a solution, but I will suggest that you look at the problem in a different way. You describe
    kthreadd being rediculously bus
    .

    My description would have been that for the first 120 seconds, or so, nothing much happens. kthreadd and init have been started, but there isn't any disk I/O (why not?) and nothing else has been started. Once everything else starts, things proceed at a reasonable pace, but it is this initial period when nothing much is happening that is the problem.

    This would be comprehensible if the system were waiting for, say, lots of disk activity to complete, but it isn't.

    So, why don't init and kthreadd complete faster? And, hence or otherwise, why aren't the other things that actually do the disk I/O starting sooner?

    Have you already modified start-up scripts? In any case, I would suggest that you look at the start-up scripts to see if there is any explanation for this behaviour.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: OpenSuSE 11.1: extreme long boot time

    Don't know if this helps, but I see you're running 32bit openSUSE on a 64bit capable system. Why?
    The boot time is quite normal, it's the waiting for disk IO that's far too long.

    I've met trouble with 32bit install on 64bit systems, knowing there shouldn't be, but still. Hence my suggestion you downloading the 64bit version of 11.1, install it and see if slow booting persists.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: OpenSuSE 11.1: extreme long boot time

    Quote Originally Posted by markone View Post
    Have you already modified start-up scripts? In any case, I would suggest that you look at the start-up scripts to see if there is any explanation for this behaviour.
    It took me a while to find the splash=0 boot param. But it was all revealing. It seems to be a kernel bug. The symptoms are *exactly* the same as this bug
    Small difference is that I have Gigabyte EP45-DS5 and 2 sata disks + 1 sata dvd.

    I'll file a bug report and see what gives.

    Thanks a bunch.
    Koos

  5. #5
    platinum NNTP User

    Default Re: OpenSuSE 11.1: extreme long boot time

    > [image: http://scpol.tweakdsl.nl/public/bootchart.png]

    i believe this is a bios, motherboard, RAM, CPU, disk controller or
    something hardware conflict..

    and, it takes 130 seconds for the bios to figure out what needs to
    happen, and then it does it quite quickly (looks like SUSE is booting
    in about 20 seconds!!)

    i think i'd begin by running memtest over night *or*

    go through the bios set up very very carefully...with the motherboard
    documentation in hand, open, and each item read and understood (using
    a nearby running/connected google to help, if needed)...i'd pay
    particular attention to bios setting dealing with RAID.. *or*

    unplug everything possible (one hard drive, all USB, floppy, CD/DVD
    drive, etc) and see if that helps *or*

    i don't know, maybe:

    have you built a lot systems before?
    if you google with terms including the motherboard maker, model number
    and linux ... do you get loads of problems turning up?

    any doing slow boot? and raid?

    --
    platinum

  6. #6

    Default Re: OpenSuSE 11.1: extreme long boot time

    Quote Originally Posted by Knurpht View Post
    Don't know if this helps, but I see you're running 32bit openSUSE on a 64bit capable system. Why?
    1. To give me more effective memory
    2. I've read the 64 bits kernel doesn't work always well with graphic adapters

    The boot time is quite normal, it's the waiting for disk IO that's far too long.
    Spot on. See my other post
    Thanks for the advice.

    Koos

  7. #7

    Default Re: OpenSuSE 11.1: extreme long boot time

    For those following the thread, the bug is reported here:https://bugzilla.novell.com/show_bug.cgi?id=538777

    These are the problematic boot messages:

    Code:
    SCSI subsystem initialized
    libata version 3.00 loaded.
    ahci 0000:00:1f.2: version 3.0
    ahci 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
    ahci 0000:00:1f.2: AHCI 0001.0200 32 slots 6 ports 3 Gbps 0x3f impl SATA mode
    ahci 0000:00:1f.2: flags: 64bit ncq sntf stag pm led clo pmp pio slum part ems
    ahci 0000:00:1f.2: setting latency timer to 64
    scsi0 : ahci
    scsi1 : ahci
    scsi2 : ahci
    scsi3 : ahci
    scsi4 : ahci
    scsi5 : ahci
    ata1: SATA max UDMA/133 abar m2048@0xea406000 port 0xea406100 irq 218
    ata2: SATA max UDMA/133 abar m2048@0xea406000 port 0xea406180 irq 218
    ata3: SATA max UDMA/133 abar m2048@0xea406000 port 0xea406200 irq 218
    ata4: SATA max UDMA/133 abar m2048@0xea406000 port 0xea406280 irq 218
    ata5: SATA max UDMA/133 abar m2048@0xea406000 port 0xea406300 irq 218
    ata6: SATA max UDMA/133 abar m2048@0xea406000 port 0xea406380 irq 218
    ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata1.00: HPA unlocked: 1465147055 -> 1465149168, native 1465149168
    ata1.00: ATA-7: SAMSUNG HD753LJ, 1AA01118, max UDMA7
    ata1.00: 1465149168 sectors, multi 0: LBA48 NCQ (depth 31/32)
    ata1.00: configured for UDMA/133
    ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata2.00: ATA-7: SAMSUNG HD753LJ, 1AA01118, max UDMA7
    ata2.00: 1465149168 sectors, multi 0: LBA48 NCQ (depth 31/32)
    ata2.00: configured for UDMA/133
    ata3: SATA link down (SStatus 0 SControl 300)
    ata4: SATA link down (SStatus 0 SControl 300)
    ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata5.00: ATAPI: PIONEER DVD-RW  DVR-216D, 1.08, max UDMA/66
    ata5.00: configured for UDMA/66
    ata6: SATA link down (SStatus 0 SControl 300)
    scsi 0:0:0:0: Direct-Access     ATA      SAMSUNG HD753LJ  1AA0 PQ: 0 ANSI: 5
    scsi 1:0:0:0: Direct-Access     ATA      SAMSUNG HD753LJ  1AA0 PQ: 0 ANSI: 5
    scsi 4:0:0:0: CD-ROM            PIONEER  DVD-RW  DVR-216D 1.08 PQ: 0 ANSI: 5
    vendor=8086 device=3a46
    ahci 0000:03:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    ahci 0000:03:00.0: AHCI 0001.0000 32 slots 2 ports 3 Gbps 0x3 impl SATA mode
    ahci 0000:03:00.0: flags: 64bit ncq pm led clo pmp pio slum part
    ahci 0000:03:00.0: setting latency timer to 64
    scsi6 : ahci
    scsi7 : ahci
    ata7: SATA max UDMA/133 abar m8192@0xea100000 port 0xea100100 irq 19
    ata8: SATA max UDMA/133 abar m8192@0xea100000 port 0xea100180 irq 19
    ata7: link is slow to respond, please be patient (ready=0)
    ata7: softreset failed (device not ready)
    ata7: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata7: link online but device misclassified, retrying
    ata7: link is slow to respond, please be patient (ready=0)
    ata7: softreset failed (device not ready)
    ata7: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata7: link online but device misclassified, retrying
    ata7: link is slow to respond, please be patient (ready=0)
    ata7: softreset failed (device not ready)
    ata7: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata7: link online but device misclassified, retrying
    ata7: limiting SATA link speed to 1.5 Gbps
    ata7: softreset failed (device not ready)
    ata7: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
    ata7: link online but device misclassified, device detection might fail
    ata8: link is slow to respond, please be patient (ready=0)
    ata8: softreset failed (device not ready)
    ata8: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata8: link online but device misclassified, retrying
    ata8: link is slow to respond, please be patient (ready=0)
    ata8: softreset failed (device not ready)
    ata8: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata8: link online but device misclassified, retrying
    ata8: link is slow to respond, please be patient (ready=0)
    ata8: softreset failed (device not ready)
    ata8: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata8: link online but device misclassified, retrying
    ata8: limiting SATA link speed to 1.5 Gbps
    ata8: softreset failed (device not ready)
    ata8: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
    ata8: link online but device misclassified, device detection might fail
    pata_jmicron 0000:03:00.1: enabling device (0000 -> 0001)
    vendor=8086 device=3a46
    pata_jmicron 0000:03:00.1: PCI INT B -> GSI 16 (level, low) -> IRQ 16
    pata_jmicron 0000:03:00.1: setting latency timer to 64
    scsi8 : pata_jmicron
    scsi9 : pata_jmicron
    ata9: PATA max UDMA/100 cmd 0xb000 ctl 0xb100 bmdma 0xb400 irq 16
    ata10: PATA max UDMA/100 cmd 0xb200 ctl 0xb300 bmdma 0xb408 irq 16

  8. #8

    Default Re: OpenSuSE 11.1: extreme long boot time

    Quote Originally Posted by platinum
    i believe this is a bios, motherboard, RAM, CPU, disk controller or
    something hardware conflict..
    The only change I made in the BIOS settings is moving the disk interface from native IDE to AHCI. The rest is default. I'll change these and see what gives. Thanks.

    Koos

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: OpenSuSE 11.1: extreme long boot time

    You're running 32bit to use all memory? That's exactly the wrong way around: 32bit can only handle up to 3GB, have more, use the pae kernel. But these limitations have never been there for 64bit.

    About a 64bit kernel and graphics drivers: no more trouble than on 32bit.

    And Koos, I'm serious. Why buy a 64bit system and run 32bit OS? I've been running 64bit for years now, apart from the very first start no trouble at all. And yes, I've handled machines that ran like **** on 32bit, yet very smooth on 64bit.

    I would seriously consider to reinstall and pick the 64bit to get the full out of your machine and OS.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: OpenSuSE 11.1: extreme long boot time

    Quote Originally Posted by koospol View Post
    The only change I made in the BIOS settings is moving the disk interface from native IDE to AHCI. The rest is default. I'll change these and see what gives.
    Did you try plugging them into another SATA hookup? Or unplugging one of your drives and just running one?

    I would usually leave the BIOS at Default. That's good enough unless you're missing features or if you're a tweak freak.

    If these suggestions don't work maybe see if your motherboard manufacturer has a BIOS update. Also make sure you're not running in RAID.
    "To err is human... to really foul up requires the root password."

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •