Results 1 to 3 of 3

Thread: Xrdp problem on dual-head

  1. #1

    Default Xrdp problem on dual-head

    Hi, everybody!

    I have:
    1) Server with stock Opensuse 11.1 installed under Hyper-V(virtual machine). Xrdp from NOMAD repo with default configuration.
    2) Client with dual-head configuration on ATI RADEON(fglrx driver), so I have displays :0.0 and :0.1.

    When I connect from display :0.0, like this:
     DISPLAY=:0.0 rdesktop -u 123 -p 123
    And it works.
    When I connect from display :0.1:
     DISPLAY=:0.1 rdesktop -u 1234 -p 1234
    Here I have a problem. I see only rdesktop windows with log windows inside it. There is no errors, everything ok. Xdmx starts on a server with a display number specified in log window. However I can't see the desktop. I have tried twm,kde, windowmaker but nothing. On :0.0 works fine, on :0.1 don't.
    When I tried to connect to win2003 terminal server from :0.1 in works fine...

    Sorry for my bad English, but I realy need help..
    P.S. Can I redirect comports to Xrdp server from rdesktop?

  2. #2

    Default Re: Xrdp problem on dual-head

    Tried to install Xrdp on non Hyper-V server. All the same...

  3. #3

    Default Re: Xrdp problem on dual-head

    Problem solved by erasing [Xdmx] section from xrdp.ini (or sesman.ini, don't remember )
    Now I'm using X11rdp. It work fine.

    Serial port redirection is still an active question...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts