Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Boot failure

  1. #1
    Join Date
    Sep 2009
    Posts
    46

    Question Boot failure

    Hi,
    I'm new to Opensuse so please forgive my ignorance on Linux matters.
    I had recently installed Opensuse 11.1 which booted fine with windows xp off of IDE HDD. I have just installed Nvidia legacy driver to enable desktop effects which gave a new Opensuse option in boot menu as I think a new kernel was established when legacy Nvidia driver was installed. Windows XP and both Opensuse versions booted fine. I then set the default boot option to the new Opensuse (Nvidia driver) version, however the PC now gives a boot failure as it says-
    "Searching for Boot Record from IDE-0..OK
    Error No operating system"

    I'm not sure if this is a hardware issue as the PC is very old and kind of temperamental. I had also inserted a bluetooth dongle at same time as next boot up not thinking anything was wrong with boot up.

    Could this problem be to do with the boot options or Grub having changed default boot OS?

    I'd like to know if this is familiar to anyone as a software issue. If not I can rule it out and check hardware.
    Many thanks and regards

  2. #2

    Default Re: Boot failure

    First step - remove the dongle, and see if that boots. Some USB devices will play havoc, although that seems very unlikely, as you'd expect it to get past grub.

    Worth noting that on the grub boot menu (if it gets that far?), if you press escape, it'll drop you to text mode. You can then pick a line and press 'e' to edit it, so maybe try playing around with the values (nothing you change here is permanent, it's just for that boot), then press escape again, and 'b' for boot.

    Maybe copy down the lines that appear after you've hit 'e' and post them here, we can see if there are any syntax errors...

    If you can make it boot doing that, you can fix the actual menu.

    If not, it'll be easier to proceed if you have a linux live CD. Do you? If not, can you make one?

  3. #3

    Default Re: Boot failure

    Further to that; if you can get to grub text mode, there's a key to get to the grub command line (might well be 'c'. It should say). Do so, and type

    Code:
    find /boot/grub/stage1
    or possibly

    Code:
    find /boot/grub/menu.lst
    (they should produce the same output - never hurts to try different ways...). Tell us what that says, in comparison to what it says when you hit 'e' for edit (making sure that you scroll along the lines, because some may be wider than the screen) and we may well be in business...

  4. #4
    Join Date
    Sep 2009
    Posts
    46

    Default Re: Boot failure

    Hi,
    Many thanks for your reply.

    I tried to boot without dongle but it stalled again.

    Unfortunately I can't get as far as grub boot menu, I have inserted an image showing how far I can get as follows-


    [IMG]<a href="http://s672.photobucket.com/albums/vv87/UTzn/?action=view&current=DSC00414.jpg" target="_blank"><img src="http://i672.photobucket.com/albums/vv87/UTzn/DSC00414.jpg" border="0" alt="Photobucket"></a>[/IMG]

    and also viewable at http://i672.photobucket.com/albums/v...n/DSC00414.jpg

    I'm not sure if this is a grub issue or a hardware issue when the firmware is mentioned on the screen.

    I have an Opensuse Live CD.

    Any help will be greatly appreciated.
    Thank you.

  5. #5

    Default Re: Boot failure

    Load the Live CD, and open a terminal. Type 'su', (it may ask for a password - if it does you should be able to guess it (root, suse, suselive, linux... something) or google it) being aware that you are now root, and therefore have very few safeguards - don't type anything random to see what it does .

    Type

    Code:
    fdisk -l
    grub
    find /boot/grub/stage1
    quit
    And return the output. Then type 'exit' twice to get out of the terminal, or just close it. How many hard drives does the computer have?

  6. #6
    Join Date
    Sep 2009
    Posts
    46

    Default Re: Boot failure

    Hi,
    Thanks for your reply and help.

    I've done what you requested and this is the information returned-




    linux@linux:~> su
    linux:/home/linux # fdisk -l

    Disk /dev/sda: 30.0 GB, 30020272128 bytes
    255 heads, 63 sectors/track, 3649 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xcc9bcc9b

    Device Boot Start End Blocks Id System
    /dev/sda1 1 1594 12803773+ c W95 FAT32 (LBA)
    /dev/sda2 1595 1603 72292+ 7 HPFS/NTFS
    /dev/sda3 * 1604 3649 16434495 5 Extended
    /dev/sda5 3558 3649 738958+ 82 Linux swap / Solaris
    /dev/sda6 1604 2385 6281352 83 Linux
    /dev/sda7 2386 3557 9414058+ 83 Linux

    Partition table entries are not in disk order
    linux:/home/linux # grub
    Probing devices to guess BIOS drives. This may take a long time.


    GNU GRUB version 0.97 (640K lower / 3072K upper memory)

    [ Minimal BASH-like line editing is supported. For the first word, TAB
    lists possible command completions. Anywhere else TAB lists the possible
    completions of a device/filename. ]
    grub> find /boot/grub/stage1
    find /boot/grub/stage1
    (hd0,5)
    grub> quit
    quit
    linux:/home/linux #



    I have one 30Gb IDE HDD which contains all of above. I did get a warning occasionally when using Yast updater that the hard disk space was running low.

    I think the Linux file system partition is SDA6 and that was at 40%, the personal documents partition of SDA 7 was at 8%, and the SDA2 partition was at 90%. The swap file of SDA2 is 720Mb. SDA1 contains Windows XP.


    Many thanks for your help with this.

  7. #7

    Default Re: Boot failure

    Correction - you have to press return after you've changed something, not escape.

    Quote Originally Posted by Confuseling View Post
    ...
    Worth noting that on the grub boot menu (if it gets that far?), if you press escape, it'll drop you to text mode. You can then pick a line and press 'e' to edit it, so maybe try playing around with the values (nothing you change here is permanent, it's just for that boot), then press escape again, and 'b' for boot.
    ...
    Sorry - ignore that, just trying not to leave a trail of gibberish in my wake.

    Open a terminal in your live CD, and run

    Code:
    su -
    mkdir /mnt/suse
    mount /dev/sda6 /mnt/suse
    cat /mnt/suse/boot/grub/menu.lst
    Paste the output. We can have a look at the contents of your boot menu, although it isn't actually getting that far, it's worth checking.

    Final important question - there's nothing on this system (either on Windows or SUSE) you desperately need to save? If there is, now would be the time to save it - and that's certainly possible. The next step, reinstalling the bootloader, should be safe, but 'should be' is a relative term, especially when computers are involved...

  8. #8
    Join Date
    Sep 2009
    Posts
    46

    Default Re: Boot failure

    Hi,
    I've run terminal and code and this is output-


    linux@linux:~> su
    linux:/home/linux # mkdir /mnt/suse
    linux:/home/linux # mount /dev/sda6 /mnt/suse
    linux:/home/linux # cat /mnt/suse/boot/grub/menu.lst
    # Modified by YaST2. Last modification on Tue Sep 8 21:15:46 BST 2009
    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.29-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27.29-0.1-pae root=/dev/disk/by-id/ata-ST330621A_6EE03028-part6 resume=/dev/disk/by-id/ata-ST330621A_6EE03028-part5 splash=silent showopts vga=0x317
    initrd /boot/initrd-2.6.27.29-0.1-pae

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.29-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27.29-0.1-pae root=/dev/disk/by-id/ata-ST330621A_6EE03028-part6 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
    initrd /boot/initrd-2.6.27.29-0.1-pae

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-ST330621A_6EE03028-part6 resume=/dev/disk/by-id/ata-ST330621A_6EE03028-part5 splash=silentshowopts vga=0x317
    initrd /boot/initrd-2.6.27.7-9-default

    ###Don't change this comment - YaST2 identifier: Original name: windows 1###
    title windows 1
    rootnoverify (hd0,0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: windows 2###
    title windows 2
    rootnoverify (hd0,1)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
    rootnoverify (fd0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-ST330621A_6EE03028-part6 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
    initrd /boot/initrd-2.6.27.7-9-default
    linux:/home/linux #



    After I had installed Nvidia driver I think there was another boot option on the list than the usual. It was using the new option I was able to enable desktop effects and then tried to set this option as default boot item when I seem to have problems. I'm not sure if this helps.

    Fortunately I had cloned my Windows XP partition to a separate HDD not connected to this PC and have a backup. I was just trying Opensuse so I don't have any documents I need in those partitions.

    I much appreciate your help.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Boot failure

    Just for your information: the NVIDIA driver does in no way touch any of your boot configuration files.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Boot failure

    No worries. Don't thank me yet - we haven't fixed anything.

    Well, my guess would be to open your live CD terminal, and do

    Code:
    su -
    grub
    root (hd0,5)
    setup (hd0)
    quit
    That should put a fresh bootloader on the system, and that menu looks like it should work (although it could perhaps use a spring clean - it seems to think you have Windows twice, for example). Reboot, and see what happens...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •