Results 1 to 10 of 10

Thread: Can't edit grub via yast Boot Loader

  1. #1

    Default Can't edit grub via yast Boot Loader

    The settings shown in Yast's Boot Loader are not the same as those in the /boot/* files. I cannot seem to change the "device/by-id" settings.

    Inside the Boot Loader gui program, the /boot/grub/device.map says:

    "(hd0) /dev/disk/by-id/ata-ST525...."
    "(hd1) /dev/sdb"

    but the actual file in /boot/grub/device.map shows:

    "(hdo) /dev/sda"
    "(hd1) /dev/sdb"


    No matter what I do I cannot seem to change the device.map file or any other grub configuration file from YAST.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Can't edit grub via yast Boot Loader

    First: what is the problem? System not booting?

    If realy needed you can edit the file by executing an editor with root privileges:

    [KDE]: kdesu 'kwrite /boot/grub/device.map'
    [GNOME]: gnomesu 'kwrite /boot/grub/device.map'

    The command will ask you for the root password.

    BUT: you have to have good reasons to make manual changes. If everything works, do yourself a favor and leave it like that.
    IF NOT, let Yast's Bootloader Configuration suggest a new config for your system.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,788

    Default Re: Can't edit grub via yast Boot Loader

    Quote Originally Posted by richardgiroux View Post
    The settings shown in Yast's Boot Loader are not the same as those in the /boot/* files. I cannot seem to change the "device/by-id" settings.

    Inside the Boot Loader gui program, the /boot/grub/device.map says:

    "(hd0) /dev/disk/by-id/ata-ST525...."
    "(hd1) /dev/sdb"

    but the actual file in /boot/grub/device.map shows:

    "(hdo) /dev/sda"
    "(hd1) /dev/sdb"


    No matter what I do I cannot seem to change the device.map file or any other grub configuration file from YAST.
    First I support Knurpht, do not change when it works or if you hve another very good reason (and the knowledge).

    Have you looked what /dev/disk/by-id/ata-ST525.... realy is? It is a symbolic link to /dev/sda? and thus the circle is closed.
    Henk van Velden

  4. #4

    Default Re: Can't edit grub via yast Boot Loader

    Thanks guys for your comments.

    The Grub issue has come up because I am trying to build a new base image for deployment at my work.(I use Clonezilla for imaging.) Right now I have about 15 computers running SLED9 and another 30 or so runing OpenSUSE 10.1. In both of those distributions, GRUB is configured to use the "dev/sda" format which allows for imaging. The "/device/by-id" gives problems when imaging so that is the reason for trying to change the Grub configuration. Both Sled9 and 10.1 can easily be adjusted using the Boot Loader tool so I'm stumped here. I have tried changing the Grub config and fstab setting during installation but no luck. Clearly OpenSUSE 11.1 and SLED11 have a different default configuration. The Boot Loader is getting is information and writing that to the grub config files.

    I'm open to any suggestions.

  5. #5

    Default Re: Can't edit grub via yast Boot Loader

    Just to clarify - you've tried editing them directly as text files after installation? Presumably the GUI can say what it wants, if the actual config file has the right thing in.

  6. #6

    Default Re: Can't edit grub via yast Boot Loader

    During installation, you can specify how you want Suse to mount the different partitions. I thought this would also control the Grub configuration since Grub mounts the boot partition first. I didn't seem to work for me. Still, I can't figure out where the Boot Loader tool is getting its information.

    I've buggered up the Grub configuration so that it won't boot directly so I'm using the Grub Rescue disk to boot. I'm not concerned about that since I can rebuild if necessary or manually edit Grub (when I learn how to do that) if I have to.

  7. #7

    Default Re: Can't edit grub via yast Boot Loader

    I think I found it. In the Sysconfig Editor, there is a section under Yast2 called "DEVICE_NAMES" that was set to "id". When I changed it to "device", the Boot Loader tool displayed the proper settings.

    Grub is still not working properly but at least I can take a crack at fixing it now.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Can't edit grub via yast Boot Loader

    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Can't edit grub via yast Boot Loader

    Thanks, that page was very useful.

  10. #10

    Default Re: Can't edit grub via yast Boot Loader

    I haven't read much of it yet (and it does seem to have some inaccuracies in), but I've found this one useful too.

    http://www.troubleshooters.com/linux/grub/index.htm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •