Try renaming your ~/.kde4 folder, perhaps?

It's not the most elegant solution, and it involves setting up your desktop again, but it normally works when everything goes a bit haywire.