Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: conflict upon installing mplayer

  1. #1

    Default conflict upon installing mplayer

    i wanted to have a wma file player and was installing mplayer from yast. I get the following conflicts while doing so.



    #### YaST2 conflicts list - generated 2009-09-08 19:21:55 ####

    nothing provides libdirectfb-0.9.so.25 needed by MPlayer-1.0rc2_r27637-3.pm.3.i586

    [ ] do not install MPlayer-1.0rc2_r27637-3.pm.3.i586



    #### YaST2 conflicts list END ###

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: conflict upon installing mplayer

    Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Not too sure where that MPlayer is from. Follow the guide above - Carefully
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: conflict upon installing mplayer

    Quote Originally Posted by xizzling View Post
    #### YaST2 conflicts list - generated 2009-09-08 19:21:55 ####
    nothing provides libdirectfb-0.9.so.25 needed by MPlayer-1.0rc2_r27637-3.pm.3.i586
    IMHO this has happend because you did not setup OSS, Non-OSS, and Update repositories, or because you added more repositories in addtion to just those and Packman.

    You really must, unless you really know what you are doing, stick with just 4 repositories, which is OSS, Non-OSS, Update, and Packman. I know, .. I know, ... I'll get flamed for my continued pushing of that over and over, ... but I get fatigued at typing the same recommendation over and over ... < sigh >

    libdirectfb comes with DirectFB which is in the OSS repository. But the are a bunch of other DirectFB versions kicking around, and if one installs those, there is a good chance it will cause a problem with the Packman packaged mplayer, as that mplayer version expects the OSS repository packaged version of DirectFB.

    So please, add the OSS repository and add install DirectFB from OSS. And if you have added other repositories than just OSS, Non-OSS, Update and Packman, then remove them. If you do not know enough to recognize the errors from having too many repositories, then you should not be adding them. ... and I am very suspicious this is the case.

  4. #4

    Default Re: conflict upon installing mplayer

    Thanks for the inputs, i am not very familiar with rpms at all, and hence you might want to tolerate my naiveness !
    HTML Code:
    So please, add the OSS repository and add install DirectFB from OSS. And if you have added other repositories than just OSS, Non-OSS, Update and Packman, then remove them. If you do not know enough to recognize the errors from having too many repositories, then you should not be adding them. ... and I am very suspicious this is the case.
    My yast2 package installer tells me under filter 'repositries' that i have the following":
    -r
    11.0
    11.0 (again?)
    @system
    Packman-RPMs
    Updates for 11.0
    opensuse -11.0-Non-Oss
    opensuse -11.0-Oss
    opensuse-DVD 11.0
    opensuse_11.0
    opensuse_11.0


    Now kindly let me know again what should i remove and how??

    XIzz

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: conflict upon installing mplayer

    Please open a terminal and do this and post result:

    Code:
    zypper lr -d
    drop the -d if it doesn't work in 11.0
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: conflict upon installing mplayer

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI
    ---+-----------------------+-----------------------+---------+---------+----------+--------+--------------------------------------------------------------------------
    1 | 11.0 | 11.0 | Yes | Yes | 99 | rpm-md | Index of /suse/11.0
    2 | repo-debug | openSUSE-11.0-Debug | No | No | 120 | NONE | Index of /distribution/11.0/repo/debug
    3 | -r | -r | Yes | No | 99 | rpm-md | Index of /repositories/multimedia:/libs/openSUSE_11.0
    4 | repo-oss | openSUSE-11.0-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/oss
    5 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes | 20 | rpm-md | Index of /update/11.0
    6 | openSUSE_11.0 | openSUSE_11.0 | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/anubisg1/openSUSE_11.0
    7 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/non-oss
    8 | openSUSE_11.0_1 | openSUSE_11.0 | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.0
    9 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0
    10 | 11.0_1 | 11.0 | Yes | Yes | 99 | rpm-md | Index of /suse/11.0
    11 | Packman-RPMs | Packman-RPMs | Yes | Yes | 99 | rpm-md | Index of /suse/10.2

  7. #7

    Default Re: conflict upon installing mplayer

    Code:
    11 | Packman-RPMs | Packman-RPMs | Yes | Yes | 99 | rpm-md | Index of /suse/10.2

  8. #8
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: conflict upon installing mplayer

    Also remove repo 9 from your list. No point in keeping the DVD if you have all repos set up

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: conflict upon installing mplayer

    delete ......

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: conflict upon installing mplayer

    ........ delete .....

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •