Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: No sound - asus x5dij

  1. #1
    Join Date
    Aug 2009
    Location
    V�rmland, Sweden
    Posts
    41

    Question No sound - asus x5dij

    I can not get the sound to work on my 64-bit laptop.

    I have tried the self tests:
    speaker-test -Dplug:front -c2 -l5 -twav
    speaker-test -c2 -l5 -twav
    and
    aplay -vv somefile.wav
    found in
    No sound running OS 11.1 x64 - openSUSE Forums

    My alsa info can be found at:
    http://www.alsa-project.org/db/?f=98...005b4c4ac02a09

    Additional info:
    freefox@linux-q0rr:~> rpm -qa | grep alsa
    alsa-1.0.18-8.12.1
    alsa-oss-32bit-1.0.17-1.37
    alsa-utils-1.0.18-6.4
    alsa-plugins-1.0.18-6.13
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43

    freefox@linux-q0rr:~> rpm -qa | grep pulse
    pulseaudio-module-gconf-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    pulseaudio-lang-0.9.14-2.2.1
    libpulse0-32bit-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-bluetooth-0.9.14-2.2.1

    freefox@linux-q0rr:~> rpm -q libasound2
    libasound2-1.0.18-8.12.1

    freefox@linux-q0rr:~> uname -a
    Linux linux-q0rr 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

    freefox@linux-q0rr:~> cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.0BStUO5UoL0:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    All ideas, or help is appreciated.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound - asus x5dij

    Quote Originally Posted by freefox View Post
    I can not get the sound to work on my 64-bit laptop.

    My alsa info can be found at:
    http://www.alsa-project.org/db/?f=98...005b4c4ac02a09
    Thankyou for that output. The configuration from the various commands you run look nominal and correct.

    In the diagnositic script, I note confirmation of a bit-bit openSUSE-11.1 on the latest SuSE-GmbH packaged 2.6.27.29 default kernel on your Asus x5JIJ with a VT1708S hardware audio codec.

    The first thing I note is your mixer settings (either kmix in kde or alsamixer in gnome) are blocking your sound. You may have more problems than those, but you first must clear up those problems.

    Specifically:
    !!Amixer output
    !!-------------
    !!-------Mixer controls for card 0 [Intel]
    Card hw:0 'Intel'/'HDA Intel at 0xfdef4000 irq 22'
    Mixer name : 'VIA VIA VT1708S'
    Simple mixer control 'Master Front',0
    Front Left: Playback 0 [0%] [-34.50dB] [on]
    Front Right: Playback 0 [0%] [-34.50dB] [on]
    I recommend you move PC volume up to 95% while testing. You can lower the volume level later.

    But having typed that, I then when to the alsa web site and did a search on your PC's VT1708S hardware audio codec:
    Search results for VT1708S - AlsaProject

    I note some important updates in 1.0.18 of alsa and 1.0.21 of alsa, where your alsa version is a 1.0.17/1.0.18 mix.

    Hence if moving the volume settings up higher for the Master volume control do not help, you should then try updating your alsa version. You can do that for your kernel version by following the guidance here to update your alsa user space: Alsa-update - openSUSE

    Note one must send six zypper commands from a terminal with root permissions with your PC connected to the internet. The six commands to send in sequence in your case are:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa alsa-docs libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimedia
    then restart your PC to unload the old alsa kernel modules and load the new alsa kernel module and then test your sound. Be certain to move up your mixer levels.

    Now if the user space updates do not work, try the daily snapshot updates as documented here: Alsa-update-snapshot - openSUSE

    In your case that means sending the following six zypper commands:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/snapshot/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimedia
    Now its possible you will be told on the 5th command that the app is already installed. Thats ok, send the command anyway, and send the 6th command. Again, restart your PC, test your sound (being certain to move your mixer controls up to a high 95% setting).

    Good luck ! Please let us know how it works out.

  3. #3
    Join Date
    Aug 2009
    Location
    V�rmland, Sweden
    Posts
    41

    Question Re: No sound - asus x5dij

    I try to find where to adjust the volume for "Simple mixer control 'Master Front',0"
    But I just can't find it.

    I have verified that Control center->system->sound->entities are set to alsa.
    After that I have adjusten one volume control at a time and compared the output from the alsa-info.txt.files to determine what is changed. But nothing changes the 'Master Front' volume.

    Volume control on panel:
    Simple mixer control 'Front',0

    Dubble clicking gives more controls in the window named 'Volume control':
    I have choosen 'show all' in the drop down list.

    Tab 'uppspelning' ('play' in direct translation from swedish)
    System sound, Mono - changes has no affect on alsa-info.txt output.

    Tab 'utgngsenheter' ('output units')
    HDA Intel - VT1708S Analog - Simple mixer control 'PCM',0

    Tab 'ingngsenheter' ('input units')
    HDA Intel - VT1708S Analog - Simple mixer control 'Capture',0
    Monitor of HDA Intel - VT1708S Analog - changes has no affect on alsa-info.txt output.

    Tab 'inspelning' ('recording')
    Shows no entities to control. Nothing.

    I uploaded the latest test if it can be of any use.
    http://www.alsa-project.org/db/?f=f6...c8b86c1f115fa9

    Please give me a hint.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound - asus x5dij

    Quote Originally Posted by freefox View Post
    I try to find where to adjust the volume for "Simple mixer control 'Master Front',0"
    But I just can't find it
    .....
    Please give me a hint.
    ... I would , if you would give me a hint first. ... What desktop are you using? KDE3 ? KDE4 ? Gnome ? XFCE ? LXDE ? FVWM ? Enlightenment ?

    That makes a difference.

    KDE and Gnome are more popular and if you are using KDE4 note that you can add additional controls via a channel menu item in the kmix.

    If you are using gnome, note that you can install alsamixergui to obtain gui control over your alsamixer.

    But it would be useful it you let us know what desktop software , so that I don't have to spend a lot of time trying to second guess a problem for each different desktop, especially given their are limits to my experience and I do not know each desktop as well as others (and hence I won't reply/waste-your-time giving answers to the wrong desktop).

  5. #5
    Join Date
    Aug 2009
    Location
    V�rmland, Sweden
    Posts
    41

    Default Re: No sound - asus x5dij

    Sorry, I'm using Gnome.

  6. #6
    Join Date
    Aug 2009
    Location
    V�rmland, Sweden
    Posts
    41

    Default Re: No sound - asus x5dij

    And I must confess that I have not upgraded alsa software with zypper as you suggested.
    I have check with yast, online update, that there is nothing new there.
    Can I use yast to get the latest from alsa?
    I'm afraid that using zypper will mess up for yast, or am I wrong about that?

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound - asus x5dij

    Quote Originally Posted by freefox View Post
    Sorry, I'm using Gnome.
    OK, I am a KDE user and I do not know much about gnome.

    Typically one uses the application "alsamixer" in gnome, for such controls. There is also a fancier gui for alsamixer, called "alsamixergui" that one can install. You can find it in the OSS directory (or on your installation DVD). Webpin is a good place to look for such apps: Webpin

    [its a bit painful having to retype all of this, as links providing some of this information is in the stickie: NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums plus google gives a wealth of information ... but I have to assume you either did not see the stickie, or did not investigate all the links contained therein thoroughly - .... which is an understandable problem with Linux ... there is so much information , its hard to know where to go to start]

    Note you can also control the mixer via direct amixer commands. There is guidance here: Amixer - ALSA wiki

    So for example, to see what commands are available, you type:
    • scontrols #show all mixer simple controls
    • scontents #showcontents of all mixer simple controls (default command)
    and then once you know the command controls/conents, you can type:
    sset sID P # modifying as appropropriate to set contents for one mixer simple control.

    Having typed that, I find amixer commands a pain, and I find it much easier to just use the mixer gui.

  8. #8
    Join Date
    Aug 2009
    Location
    V�rmland, Sweden
    Posts
    41

    Unhappy Re: No sound - asus x5dij

    Now I have installed the suggested software, using yast.
    There was a conflict about alsa-driver-kmp-default and the kernel-...something which choosed to ignore. Probably not a good thing to do.

    alsamixergui shows two controls.
    (www.locke.se/alsamixergui.jpg)

    Master and Capture
    But none of them have any affect on the Master Front volume!?
    Master adjusts Simple mixer control 'PCM',0 and
    Capture adjusts Simple mixer control 'Capture',0

    Now I'm lost. Should I give it up, or should I go for the latest kernel too? Or what is the next step?

  9. #9
    Join Date
    Aug 2009
    Location
    V�rmland, Sweden
    Posts
    41

    Smile Re: No sound - asus x5dij

    Now it works!
    I'm not sure of what was wrong, but I looked over the installed packages ones more. I also made changes in the control-center -> sound and ensured that things looked correct, pointing out HDA Intel VT1708S Analog(ALSA). I choosed plain ALSA before because the tests in that window fails with the text "audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Kunde inte ppna ljudenheten fr uppspelning. (that is: Could not open the sound unit for playback).

    And a reboot. Thanks for your support.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound - asus x5dij

    Quote Originally Posted by freefox View Post
    Now it works!.....
    And a reboot. Thanks for your support.
    Glad its working now. Your timing is good. I'm now on vacation, and would find it difficult to provide any good technical support given the limited internet connection I have now.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •