Results 1 to 8 of 8

Thread: Thanks Everyone

  1. #1
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    146

    Default Thanks Everyone

    Hi Everyone,

    I just would like to say thanks to all of you who posted on helping me out with DVD playback. I eventually got DVD's playing after installing VLC player with the libdvdcss codec. Many thanks.

    I just have one question? VLC does not always play a DVD. I have one DVD drive which is on /dev/sr0. When I play the DVD, it sometimes play and sometimes doesnt. It costs me to change settings in VLC player to /dev/sr0 and /dev/sr1 and back again. I also sometimes need to view the directory listing in dolphin and then open up VLC to play the DVD. I also change the capture mode setting from "Video for Linux 2" which is the default to "Video for Linux" and then back again. Then sometimes I can get a DVD to play. This is very intermittend and I am not sure why?

    I have 2 machines running openSUSE 11.1 and both is doing the same thing.

    Any possible suggestions?

    Shouldnt this be working each time?

    Many thanks

    Henk

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Thanks Everyone

    Sometimes plays
    Sometimes doesn't

    Could do with knowing How exactly it doesn't play.

    Eg; I see a picture but it's all garbled
    or: I hear sound but the screen is black.................
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    146

    Default Re: Thanks Everyone

    Mostly i get the following error: VLC is unable to open the MRL 'dvd:///dev/sr0'. Check log for details.

    When I want to play a DVD I do the following:
    1. I open VLC player.
    2. I click on Media and select "Open Disc"
    3 I See if DVD option is enabled.
    4. I click on play.

    Thenk i get the error.

    Thanks

  4. #4

    Default Re: Thanks Everyone

    "I get an Error" is not helpful.

    Errors get helpful when being _quoted_ 1:1 (i.e. from console output).

    If the DVD contains some crappy, proprietary copy protection, then forget it (and stop buying that stuff from now on).

    I also change the capture mode setting from "Video for Linux 2" which is the default to "Video for Linux" and then back again. Then sometimes I can get a DVD to play.
    Very unlikely as this is the option for setting (web)cams as input devices and has nothing to do with DVD.

  5. #5
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: Thanks Everyone

    libdvdcss, which VLC uses, does not support decrypting most of the newer DVD titles with enhanced protection. So you'll have to strip it off using a Windows program (like DVD Decryptor) and then play in in Linux

  6. #6
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    146

    Default Re: Thanks Everyone

    I have the problem using the same DVD. Sometimes it plays it, somtimes it doesnt. Weird. It is an original Star Wars Return of the Jedi DVD.

    Thanks

  7. #7

    Default Re: Thanks Everyone

    Then the most likely reason is a damaged medium.

    Trying other player (mplayer, xine ...) and other OSes will give more ideas of what could be wrong.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Thanks Everyone

    Quote Originally Posted by microchip8 View Post
    libdvdcss, which VLC uses, does not support decrypting most of the newer DVD titles with enhanced protection. So you'll have to strip it off using a Windows program (like DVD Decryptor) and then play in in Linux
    I'm in agreement with micro here.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •