Results 1 to 6 of 6

Thread: Desktop Effects Problem

  1. #1

    Default Desktop Effects Problem

    I am getting an error when I try to enable desktop effects.

    "Desktop effects are not supported on your current hardware / configuration."

    I am not too sure what what I should do?
    I have the nvidia dirvers?

    Any ideas?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Desktop Effects Problem

    You have the drivers but you don't tell us any information. What Graphics card do you have and how did you install the driver?

    Open a terminal and do:

    Code:
    cat /etc/X11/xorg.conf
    post result
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Desktop Effects Problem

    I installed the drivers from NVIDIA - openSUSE. The one click install.

    I have a Geforce 7600GS.

    Code:
    koz@linux-vyw9:~> cat /etc/X11/xorg.conf
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-09-07T04:31:33+1200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "12"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Logitech USB Receiver"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      DisplaySize  340 270
      HorizSync    31-64
      Identifier   "Monitor[0]"
      ModelName    "1280X1024@60HZ"
      Option       "DPMS"
      Option       "PreferredMode" "1280x1024"
      VendorName   "--> VESA"
      VertRefresh  50-60
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline 	"1280x1024" 102.62 1280 1312 1472 1632 1024 1028 1032 1048 -HSync -VSync 
    EndSection
    
    
    Section "Device"
      BoardName    "GeForce 7600 GS"
      Driver       "vesa"
      Identifier   "Device[0]"
      VendorName   "NVIDIA"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 16
      SubSection "Display"
        Depth      15
        Modes      "1280x1024" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1280x1024" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1280x1024" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1280x1024" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    And:

    Code:
     rpm -qa | grep nvidia
    nvidia-gfxG02-kmp-pae-185.18.36_2.6.27.29_0.1-6.1
    x11-video-nvidiaG02-185.18.36-7.1
    Edit: I am using GNOME if it makes a difference.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Desktop Effects Problem

    see this bit and the part I marked Bold

    Section "Monitor"
    DisplaySize 340 270
    HorizSync 31-64
    Identifier "Monitor[0]"
    ModelName "1280X1024@60HZ"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "--> VESA"
    VertRefresh 50-60
    UseModes "Modes[0]"
    EndSection

    You need to Open Yast Hardware Graphics and Monitor and setup your monitor and check the 3D box
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Desktop Effects Problem

    As soon as I open the Hardware Graphics and Monitor from the Control Center I get an error:
    Code:
    Invalid Colo/Resolution combination:
    The selected resolution and/or color settings are not supported by graphics cards framebuffer
    This happens every time I change any settings at all. Even to the current ones?

    I am sure what to do about the "-->VESA"?
    My Monitor's model isn't in here. And the only other option that seems appropriate is "--> LCD"?

    Any ideas at all?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Desktop Effects Problem

    That's it
    -->LCD and your resolution
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •