Results 1 to 2 of 2

Thread: [KDE] Can't login (blank desktop) after upgrade to KDE 4.3.1

  1. #1
    Join Date
    Aug 2008

    Default [KDE] Can't login (blank desktop) after upgrade to KDE 4.3.1

    I just did an upgrade to KDE 4.3.1 (openSUSE 11.1, 32 bit). However, the lower panel 'broke' after I tried to add a widget/plasmoid to it.

    So, I followed the instructions at the KDE-Upgrade link to try & get back to a working KDE 4.3.1 desktop:

    If your desktop layout is broken after the upgrade you can reset it by running this command in Konsole:
    kquitapp plasma-desktop && rm ~/.kde4/share/config/plasma-desktop* && plasma-desktop &
    Now, on logging in to KDE 4, there is a blank screen, though the KDE4 Runner (fast application launcher, that is got by Alt-F2) comes up on Alt-F2.

    How to get back to a working KDE 4.3.1 desktop ?

    Linux User 483705 @

  2. #2
    Join Date
    Jun 2008
    Groningen, Netherlands
    Blog Entries

    Default Re: [KDE] Can't login (blank desktop) after upgrade to KDE 4

    The command you're invoking does NOT remove all plasma settings, and that's what you're trying to do. I know this worked in 4.1 but nowadays it's not enough.
    To start with a nice clean standard KDE4 desktop:

    At graphic login screen hit Ctrl-Alt-F1
    Login with username and password
    type: rm ~/.kde4/share/config/plasma* && exit
    Hit Ctrl-Alt-F7 to return to graphic login screen, login with username and password, and you will see a clean desktop.

    The command you used still leaves some plasma*files, making your desktop look the way it does.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts