Results 1 to 3 of 3

Thread: Little Complicated setup - Grub Help required

  1. #1
    rbalaaji NNTP User

    Default Little Complicated setup - Grub Help required

    Hi All,

    I am sorry. My post will be long as I have to define my problem in total.

    My Desktop: Intel Core2 Duo, 300GB HDD, 1GB Ram.
    My Aim : To multiboot all versions of Windows, Open Suse 11.1, Open Solaris and some other linux distro.

    Used tools: Acronis Disk Director Suite 10 with Acronis OS selector and Paragon Hard Disk Manager 2009 - Pro.

    Before I ask your expertise, Let me explain what I did.

    (0) Backed up important Data in DVD's
    (1) Created partitions one by one and not all partitions at a stretch. Created FAT16 partition as 1st primary. Installed PC-DOS7.1 and Windows 3.11
    (2) Hide the FAT16 partition and made it as inactive.
    (3) Created FAT32 partition as 2nd primary. Installed Windows ME. Under Windows ME acronis SW was installed and OS selector was activated.
    Onto the same FAT32 partition, installed Windows 98SE and Windows 2000. I used Acronis because I can install more windows versions onto the same partition. Acronis has built in protection feature which isolates the OS files during booting of different OS's under the same partition.
    (4)Till now all 5 OS's are working.
    (5) Deactivated Acronis OS Selector.( Acronis Disk Director Suite is having some issues with Windows 7 and Windows 2008 server).
    (5)Created 3rd primary partition for Open Solaris. installed and it is working fine.
    (6)Created an Extended partition for the balance HDD space.Now the trickiest part starts.
    (7)The status of Partition is as follows at this moment.
    FAT16 is hidden and inactive. FAT32 is active and not hidden.
    Why the status of partition is like this?
    Because Windows versions require atleast one primary partition to update its boot loader files into the primary partition during installation.
    (8)I installed Windows XP, Windows 2003 server, Windows Vista, Windows 2008 server, Windows 7 RC one by one. The boot loader files
    (ntldr, ntdetect.com of XP and boot and bootmgr of vista were copied to FAT32 active primary partition as expected). After every Windows installation MBR was updated as expected.
    After Windows XP and 2003 I had an ntldr based MBR. When I installed Vista, the MBR menu contained Vista option as well as "Earlier version of Windows" option. During booting if I choose this I will get the sub menu (ntldr MBR menu) from where I can boot into XP or 2003.
    After all the above steps, I activated acronis OS selector and am able to boot into each OS with no problems.
    (9)I created another logical partition under extended and installed OpenSUSE 11.1 and MBR was updated with an entry pointing to extended partion for booting other Windows versions.
    The entry created by OpenSuse is (hd0,3). This corresponds not to any primary or logical partition but to the extended partition address space. If I select this no OS is booted but Vista bootloader menu is displayed.
    This has Vista, 2008, Win7 options. This also has an entry of "Earlier versions of Windows" which will open another sub menu through which I can boot into XP or 2003.
    (10)Again I have activated acronis OS selector. Now I am able to boot into all installed OS's viz.. all windows versions, open solaris and open SUSE.
    (11) If everything worked fine, why I am disturbing you?

    My requirement is different.
    With the present arrangement, If I boot into vista or any other OS, I am seeing all partitions ie 10 or 11 of them under my computer.
    I want to have the following arrangement.
    For every OS, I wish to have 2 entries in Grub so that one entry will boot into OS with all partitions and another entry will boot into the OS with selected partitions only (I want to hide other partitions during booting using grub).
    This is where the problem started.
    Lets take Vista.
    I am able to boot into vista with no problems.
    But If I add an entry to menu.lst pointing to the corresponding partition, I get an error "Error 15: File not found". Grub actually works fine because my vista partition does not have the boot and bootmgr. these files are under FAT32 primary partition.
    I tried to copy these files from FAT32 primary partition to the corresponding vista partition but Grub ends with the same error?
    Is there any workaround to achieve this?
    either using grub features or by copying proper files to Vista partition.

    Thanks first of all for reading this full post.
    Great if someone can throw some light.
    If you require further info I will share it.

    For better understanding I am posting my partition details.

    (1)hd0,0 Primary - FAT16 (Contains PC-DOS 7.11 and Win311)
    (2)hd0,1 Primary - FAT32 (Contains Windows ME,98SE and 2000 using acronis SW)
    (3)hd0,2 Primary - ZFS (Contains Open Solaris)
    (4)hd0,3 Extended
    (5)hd0,4 Logical - XP
    (6)hd0,5 Logical - 2003
    (7)hd0,6 Logical - 2008
    (8)hd0,7 Logical - Windows7
    (9)hd0,8 Logical - Vista
    (10)hd0,9 Logical - Open Suse 11.1
    (11)hd0,10 Unformatted empty space

    Thanks
    R Balaji
    India.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Little Complicated setup - Grub Help required

    Instead of giving you a straight answer, I'd rather state that I would never to it this way. IMHO you are creating a very complex situation that will always be hard to maintain. These days we have VirtualBox available; that way you would be able to run the other OS's on your openSUSE desktop, in a window or full screen.

    AFAICS from your setup, you will meet an ongoing line of problems of OS's making changes to each other's bootloaders etc.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Dec 2008
    Location
    Idaho
    Posts
    204

    Default Re: Little Complicated setup - Grub Help required

    I also would never setup like you have it. Problem could be the Vista partition likely does not have Vista's boot code in the Volume Boot Record. I have never used Vista so can only give XP's method. Boot into recovery console ,run 'fixboot' with the hdd/partition switch, I'm sure Vista is a different method.

    You might want to look at boot/partition manager 'plop'. I have 8 different installs of Windows/linux all on different primary partitions. It does not overcome the limit of 4 entries in the MBR, but keeps it own partition table and you can select up to the 4 MBR entries all, other partitions will appear as non partitioned space. I do not recommend plop to any one who does not completely understand the MBR and partitions as they will end up in trouble.
    PLoP - Bootmanager - Free Boot Manager, builtin usb driver, native usb, boot different operating systems, cdrom, usb, freeware, option rom bios

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •