Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Intel Pro Wireless 2200 on Acernote 290

  1. #1
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Intel Pro Wireless 2200 on Acernote 290

    My wireless connection is recognised but won't connect or scan available networks.
    Looking at the boot message log, the ipw2200 driver module is loaded but there is a message that the radio kill connection is set to ON.
    How do I set this to off?
    Using opensuse 11.1 and gnome.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    That message is set by the radio disable switch. You may need to issue
    the command

    Code:
    sudo /sbin/modprobe -v acer-wmi
    This module is used to activate the various control panel options.

  3. #3
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    Thanks, will give it a try in the morning (00:27 here) and not at the notebook right now.

  4. #4
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    When I ran:
    sudo /sbin/modprobe -v acer-wmi
    I get the message that the module is not found.
    Is there any other way of enabling the rfkill so that it sets the wireless to ON?

  5. #5

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    Quote Originally Posted by whych View Post
    When I ran:
    sudo /sbin/modprobe -v acer-wmi
    I get the message that the module is not found.
    I bet there was another message (assuming the command was typed correctly).

  6. #6
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    If I have a sift through the boot messages, there is an entry to the effect that no wmi is found when it tries to start acer-wmi.
    This is different to the message when I run/sbin/modprobe/... which just says acer-wmi is not found.
    The wired network is not up by the way to produce any conflict.

  7. #7

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    And again, I bet the message is not that acer-wmi is not found as it is enabled by default on any openSUSE standard kernels since 11.0 (no matter if i586 or x86_64).

    As it seems you are reluctant to just cite the message (working for CIA/FBI and not allowed to quote terminal output?) I suspect, I will do it for you:

    Code:
    modprobe -v acer-wmi
    insmod /lib/modules/2.6.27.29-0.1-default/kernel/drivers/acpi/wmi.ko
    insmod /lib/modules/2.6.27.29-0.1-default/kernel/drivers/misc/acer-wmi.ko
    FATAL: Error inserting acer_wmi (/lib/modules/2.6.27.29-0.1-default/kernel/drivers/misc/acer-wmi.ko): No such device
    
    which is something completely different than "the module is not found".

    The module is found but your device (BIOS that is) is not compatible with acer-wmi.

    You will need one of the many other "software switches" like acerhk, fsam7440, fsam7400 or wistron_btns (to name just a few candidates).

  8. #8
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    Not reluctant to post the full message, but I am replying from memory from a different computer each time.
    What you have posted seems to ring a bell as being the message.
    Do you know if the later bios versions on the acer site fix this problem or should I go with one of your other suggestions?

  9. #9

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    Quote Originally Posted by whych View Post
    Do you know if the later bios versions on the acer site fix this problem
    No, I don't and I also doubt it.

  10. #10
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Intel Pro Wireless 2200 on Acernote 290

    Thanks Akoellh, I'll try one of the other options and report back.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •