Results 1 to 4 of 4

Thread: Unable to Install cisco_vpn_client-4.8-5

  1. #1

    Default Unable to Install cisco_vpn_client-4.8-5

    Hello everyone

    I am a brand new openSUSE 11.1 rookie as of tonight.

    I am relatively a linux rookie as well as I've only beenworking with Linux for about 6 months, and that was on Red Hat variants.

    I came over to openSUSE 11.1 as I saw that it configured Pidgin very easily. My employer requires us to use Pidgin and I could never get it configured on their version of RHEL.

    So I downloaded and installed openSUSE and voila, pidgin went right in no problems.

    Sweeeeeeeeeeeeeeeeeet!!!

    Now my problem is the cisco vpn client I have to use: 4.8.5.

    i downloaded the rpm from my employers website and tried running yast and it gave me the following:

    rpm -ivh gds_cisco_vpn_client-4.8-5.EL5.i386.rpm
    error: Failed dependencies:
    gcc is needed by gds_cisco_vpn_client-4.8-5.EL5.i386
    kernel-devel is needed by gds_cisco_vpn_client-4.8-5.EL5.i386

    I have the the following installed:

    rpm -qa make kernel-source gcc*
    gcc43-gij-4.3.3_20081022-9.2
    make-3.81-128.9
    gcc-gij-4.3-34.168
    gcc43-4.3.3_20081022-9.5

    If someone could give me a detailed guide on resolving this I'd appreciate it immensely.

    Thanks in advance.

    jd

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,453

    Default Re: Unable to Install cisco_vpn_client-4.8-5

    Go to Yast>Software>Software Management and search for gcc; change the search to Patterns and look for kernel-devel.

  3. #3

    Default Re: Unable to Install cisco_vpn_client-4.8-5

    Never _ever_ install packages for other distributions on openSUSE (this also applies to _any_ other distro), you are calling for trouble.

    This package is for CentOS and calls for requirements which are available for openSUSE but with other names.

    Ask your employer to provide an openSUSE compatible package or at least a tarball with that thing and install it from scratch (read the README or INSTALL file).

    As this client is proprietary it can not be provided by the standard openSUSE repos, if you want a free alternative, which has a lot less issues than that proprietary cisco **** (and unfortunately not all of its features yet, but in 99% of all cases it will suit your needs), use vpnc.

    I also suspect that even without caring about the warnings about missing dependencies or using the tarball without additional patches, you will not be able to compile the kernel module needed for the cisco vpnclient, CentOS 5.X uses kernel 2.6.18, openSUSE has 2.6.27.

  4. #4

    Default Re: Unable to Install cisco_vpn_client-4.8-5

    Hello,

    I tried using Kvpnc as suggested. I imported the .pcf file of the connection I use with my company, but when I try to connect, I get the message:

    info: Gateway hostname (xx-xxx.xxx.com) resolved to "xxx.xx.xxx.xxx".
    info: Trying to connect to server "xx-xxx.xxx.com" (xxx.xx.xxx.xxx) with user "jdlandry" and IPSec ID "xxx-xxxxx-xxx"...
    error: No response from VPN server

    Naturally I've removed the connection pieces.

    I can ping the IP address and get responses from the server.

    I've spent two days trying to locate something to indicate what could be the problem. the connection works good on my company laptop in XP, so it has to be a config thing.

    Need some help please.

    Thanks in advance.

    JD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •