Results 1 to 5 of 5

Thread: No Sound

  1. #1

    Default No Sound

    My computer was running very slowly so I restarted, when I restarted I have no sound....what do I do?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No Sound

    Quote Originally Posted by MattDobson View Post
    My computer was running very slowly so I restarted, when I restarted I have no sound....what do I do?
    The general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide:
    SDB:AudioTroubleshooting - openSUSE

    Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot.

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

  3. #3

    Default Re: No Sound

    Awesome help so far, ok this is what I have:

    rpm -qa | grep alsa
    alsa-utils-1.0.18-6.4
    alsa-plugins-1.0.18-6.12
    alsa-1.0.18-8.12.1
    alsa-plugins-pulse-1.0.18-6.12
    alsa-oss-1.0.17-1.37


    rpm -qa | grep pulse
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    libxine1-pulse-1.1.16.3-2.pm.5.1
    libpulse0-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.12
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    vlc-aout-pulse-1.0.1-2.7
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1

    rpm -q libasound2
    libasound2-1.0.18-8.12.1


    uname -a
    Linux linux-es8h 2.6.27.29-0.1-pae #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux

    cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel
    # u1Nb.rW8H+MD5+Z1:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

    As far as using "/usr/sbin/alsa-info.sh" nothing happens the blue screen comes up with "yes" or "no" I select yes and the coursor jumps to the middle on the konsole screen and sits there for about 5 or so minutes.

  4. #4

    Default Re: No Sound

    Ok weird I tried the test again and the womans voice came out of the speakers, but no sound out of my media player. (I tried using Songbird this time)

  5. #5

    Default Re: No Sound

    Ok on a whim I un-installed Amarok and restarted....and I am back on again with sound.

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •