Results 1 to 5 of 5

Thread: rm /usr/ folders

  1. #1
    Join Date
    Nov 2008
    Location
    norway
    Posts
    28

    Default rm /usr/ folders

    Managed to run rm -r /usr/* now im only in command line.

    some /usr/bin /usr/sbin files was deleted.

    My only media is opensuse live disk and internett.

    I want to repair this mess.
    opensuse install 19.11.2008 - still running

  2. #2

    Default Re: rm /usr/ folders

    The proper answer is load a backup if it is that much of concern of course you'll have one but as I suspect you don't...

    I can't give a specific answer but to start with you need to be looking at commands based around the rpm database i.e Using RPM to Verify Installed Packages

    Good Luck
    Perhaps if you suceed post back the solution as it may help someone else.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: rm /usr/ folders

    On Fri, 04 Sep 2009 20:46:02 +0000, ros2468 wrote:

    > I want to repair this mess.


    I'd be inclined to boot a rescue system or do a non-destructive
    reinstall. You should be able to preserve the existing /home structure
    if it's a separate partition.

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  4. #4
    platinum NNTP User

    Default Re: rm /usr/ folders

    > I want to repair this mess.

    reinstall from your backup, or:

    i do not know if the live CD has a "Repair Installed System" on either
    of these install steps, if it does you can TRY it, it won't make it
    worse than it is

    http://en.opensuse.org/INSTALL_Local#Installation
    http://en.opensuse.org/INSTALL_Local...tallation_Mode

    --
    platinum

  5. #5
    Join Date
    Nov 2008
    Location
    norway
    Posts
    28

    Default Re: rm /usr/ folders

    Mounted live cd and did some repairs using rpm -V, now running normal runlevel.
    opensuse install 19.11.2008 - still running

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •