Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Compiz in KDE 4.1, will it work?

  1. #11
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz in KDE 4.1, will it work?

    Quote Originally Posted by mirage4d View Post
    I toyed around with upgrading KDE to 4.2 and/or Compiz to Compiz-Fusion via one-click. YaST spat out a ton of scary red for dependencies in both cases
    I forgot to address this. With the newer KDE's (4.2.x, 4.3.x) the names have changed. So things like Kde4-Amarok are now just Amarok. So red dependency changes like that are expected when upgrading. We have a how-to section here and there are some really nice ones in the unreviewed how-to section. Caf has a tutorial for upgrading to 4.2 and 4.3 (the package name changes is explained there), but first I'll give you some beginner stuff (just to make sure you have all the repository handling down as repository priority and handling can either make or break a system, things like setting the upgrade repository to priority 99 instead of 20):

    Repository Management - openSUSE Forums

    And then once you have that down here's the how-to for upgrading to KDE 4.2.x

    KDE4.2.* (How To Add) Guide. - openSUSE Forums

    There's also one for upgrading to the current 4.3.x, which is what I'm using, but as you're just dipping your toes into openSUSE, it'd be better for you to get comfortable with what you're doing first. If and when you get to that point, just go to the unreviewed how-to's and find the one labeled KDE4.3. *Upgrade - Howto

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  2. #12

    Default Re: Compiz in KDE 4.1, will it work?

    Yeah I'm on KDE 4.1.3 right now as that was included in the OpenSUSE .iso I used. The install is fully patched; strange that the 1-click for 4.2 threw all those dependency errors, but alas the penguin can be a finicky beast.

    As you say it may make the most sense to stay put for now, at least until 4.3 is stable. Is there any substantial benefit to upgrading to 4.2?

  3. #13
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz in KDE 4.1, will it work?

    Well, depending on your hardware you may have different results, but I've been using 4.3 since it came out and it's been nothing but stable. As I said though, you have to be comfortable with what you're doing or follow caf's guides or else you'll find yourself in an unwanted situation such as a nonworking system. It would be better just to stick to 4.1.3 for now and get to know the system a bit more. Then I would HIGHLY RECOMMEND upgrading to either 4.2.x or 4.3.x as both of these have a lot of stability and feature improvements over 4.1.x.

    This is just my opinion based on my experience. I'm sure you can google and find lots of posts to the contrary, but if you know what you're doing or utilize help (which is what these forums are for) then you shouldn't have any problems.

    That being said, there are some things that can't be accounted for until they're fixed by the KDE Devs, such as a separate activity for each workspace adds an extra activity when you use it.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #14

    Default Re: Compiz in KDE 4.1, will it work?

    A final update...

    Followed the instructions you posted above re: repository management and upgrading to KDE 4.2 - worked flawlessly.

    Thanks again!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •