Results 1 to 7 of 7

Thread: [?rpm]last build google-chrome-unstable 4.0.206

  1. #1
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default [?rpm]last build google-chrome-unstable 4.0.206

    hi all
    how can I repack google-chrome-ustable 4.0.206x from google's site to use
    with opensuse 11.1 x86-64

    so as allways I use official .deb package than convert it to rpm
    Code:
    sudo alien -r google-chrome-unstable*.deb
    so I got an rpm and put in in my local repo
    and try to installit with zypper
    Code:
    ~> LANG=en_EN.utf8 sudo zypper update google-chrome-unstable
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libnspr4.so.0d()(64bit) needed by google-chrome-
    unstable-4.0.206.0-1.x86_64
    Solution 1: do not ask to install a solvable providing google-chrome-
    unstable > 4.0.203.2-1
    
    Choose the above solution using '1' or cancel using 'c' [1/C]:
    nothing provides libnspr4.so.0d()(64bit) needed
    the same problem I have with 4.0.203 build but i got rpm from Ben Kevan’s
    Blog http://tr.im/y8L2
    and it was solved there but with all respect there was no info how he do
    this.
    so I start this topic with faith to understand opensuse rpm basics on the
    example of google-chrome-unstable
    I read wiki about opensuse rpm building, but there is many things that did
    not clear to me
    so from what should i start, to make my own package.

    --
    WBR

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,590
    Blog Entries
    14

    Default Re: [?rpm]last build google-chrome-unstable 4.0.206

    You need to have 'mozilla-nspr-devel' installed. Having done that the 'alien' command should work.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,590
    Blog Entries
    14

    Default Re: [?rpm]last build google-chrome-unstable 4.0.206

    Tried the latest unstable. Got it to compile after discovering that there should be no spaces is the path to the ....deb. After moving it to /home/MYUSERNAME/Devel an rpm was generated, but it won't install due to dependency failures:
    Failed dependencies:
    libnspr4.so.0d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.10)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.11.1)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.11)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.12)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.2)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.3)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.4)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.5)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.6)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnss3.so.1d(NSS_3.9)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnssutil3.so.1d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libnssutil3.so.1d(NSSUTIL_3.12)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libplc4.so.0d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libplds4.so.0d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libsmime3.so.1d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libssl3.so.1d()(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libssl3.so.1d(NSS_3.2)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64
    libssl3.so.1d(NSS_3.4)(64bit) is needed by google-chrome-unstable-4.0.206.0-1.x86_64

    The 204 version generated an rpm and it installed fine. So the dev's at GoogleChrome must have used the mozilla libs from svn or git. I'm running Factory so packages should be pretty much up to date. Also notice the 'd' at the end of the ...so.0d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,335
    Blog Entries
    15

    Default Re: [?rpm]last build google-chrome-unstable 4.0.206

    Quote Originally Posted by didencool
    hi all
    how can I repack google-chrome-ustable 4.0.206x from google's site to
    use with opensuse 11.1 x86-64

    so as allways I use official .deb package than convert it to rpm
    Code:
    sudo alien -r google-chrome-unstable*.deb
    so I got an rpm and put in in my local repo
    and try to installit with zypper
    Code:
    ~> LANG=en_EN.utf8 sudo zypper update google-chrome-unstable
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libnspr4.so.0d()(64bit) needed by
    google-chrome- unstable-4.0.206.0-1.x86_64
    Solution 1: do not ask to install a solvable providing google-chrome-
    unstable > 4.0.203.2-1
    
    Choose the above solution using '1' or cancel using 'c' [1/C]:
    nothing provides libnspr4.so.0d()(64bit) needed
    the same problem I have with 4.0.203 build but i got rpm from Ben
    Kevan’s Blog http://tr.im/y8L2
    and it was solved there but with all respect there was no info how he
    do this.
    so I start this topic with faith to understand opensuse rpm basics on
    the example of google-chrome-unstable
    I read wiki about opensuse rpm building, but there is many things that
    did not clear to me
    so from what should i start, to make my own package.
    Hi
    Your already behind the eight ball, there are three of us that have
    packaged it up now....
    See;
    <http://forums.opensuse.org/applications/420491-64-bit-chromium-anyone.html>
    and
    <http://forums.opensuse.org/opensuse-build-service-obs/420486-building-chromium-how-pack-into-rpm.html>

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 14:52, 2 users, load average: 0.10, 0.07, 0.01
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  5. #5

    Default Re: [?rpm]last build google-chrome-unstable 4.0.206

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    I pulled 'chromium-browser' from the OpenSUSE repos Saturday or so as I
    recall, and that is 4.0.207. So far working like a charm.

    Good luck.





    Knurpht wrote:
    > Tried the latest unstable. Got it to compile after discovering that
    > there should be no spaces is the path to the ....deb. After moving it to
    > /home/MYUSERNAME/Devel an rpm was generated, but it won't install due to
    > dependency failures:
    > Failed dependencies:
    >
    > libnspr4.so.0d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.10)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.11.1)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.11)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.12)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.2)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.3)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.4)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.5)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.6)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnss3.so.1d(NSS_3.9)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnssutil3.so.1d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libnssutil3.so.1d(NSSUTIL_3.12)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libplc4.so.0d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libplds4.so.0d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libsmime3.so.1d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libssl3.so.1d()(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libssl3.so.1d(NSS_3.2)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    > libssl3.so.1d(NSS_3.4)(64bit) is needed by
    > google-chrome-unstable-4.0.206.0-1.x86_64
    >
    > The 204 version generated an rpm and it installed fine. So the dev's at
    > GoogleChrome must have used the mozilla libs from svn or git. I'm
    > running Factory so packages should be pretty much up to date. Also
    > notice the 'd' at the end of the ...so.0*d*
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKpl5jAAoJEF+XTK08PnB5amYP/0yavP40lwir3NfK2OEjJlCf
    BNVwQBQNf6RC1KR2tuTk3gK9M/0339fMnXYxCuTCA//Q5qmrUBagROtKY0Cj5ttX
    3KQsYZkdqCQRzUIyc28VOGRlX9bbo5HhYeQCeyGc9X6W2pz7NIHqDaW5T9PKppX2
    snPbFZm41O5dMbsSJeyssr7J/+m8kEzmMbLkBGWBJNmXgGn+gQCh9fZLkL0PTcD1
    ec9w1EZBCCoKIpEeEND5poqyCdWqmiwyM47yswXiucAZf+mNjASU9fJTmDT/UmzT
    EH7NUiVg8Y5EAwoGLj88TxT/o8o7H701YSuhx0Df8S1MpIOyWX+uzOHUGgqJbYVX
    YClnq5pnnOnwjEpyv2HJx7pfJvwgopFMCQWYTlfV7xSKSVMkLqQTMsSsFvjYIpFW
    GZC7FFDuDWbYWTuYd4LmKZDx6X74OYSOgWlypJbfkSj3/LsM5GG73Eb3KtyKn5Q2
    5QgX56mg0E9/MkpfBBEohojU6oNG8C6XzY8RqjaDWKyYDzoHTtQB4aIAx6pxLSJK
    Do1WUlSBqWqB13j288YQdOWpJPJOHk7t+fxI81VW9WYlATYwkFSU5FpVydlMdTwV
    DYxDsb19rUAIb6pdOSw+W7cmiNMLciAYdyYX74PNtTnGZFuLEcLjq3+ulXDbgt2D
    jPsU3C2KUAIbgQtgZEOG
    =7KJ/
    -----END PGP SIGNATURE-----

  6. #6
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default Re: [?rpm]last build google-chrome-unstable 4.0.206

    ab@novell.com wrote:

    > I pulled 'chromium-browser' from the OpenSUSE repos Saturday or so as I
    > recall, and that is 4.0.207. So far working like a charm.
    Malcolm wrote:

    > there are three of us that have
    > packaged it up now....
    > See;
    > <http://forums.opensuse.org/applicati...-bit-chromium-

    anyone.html>
    > and
    > <http://forums.opensuse.org/opensuse-...0486-building-

    chromium-how-pack-into-rpm.html>
    thank you alot
    but can you explain to me what a difference between google-chrome and
    chromium browser?
    I have experienced from start that google-chrome was much more stable with
    4.0.203 then chromium 4.0.207... i have one crash from start but i have
    never crash all chrome. I have also problems with flash on you tube it
    crashed in very different ways when i close|open another tab etc something
    bad with
    it is really cool that chromium can import my stuff from firefox but not
    from chrome (for now I have more recent @chrome)???
    chromium do not hides in system tray when chrome does
    and last I have problem with enocding in one local search engine (I have
    same problem in ff) but chrome is works perfect with it...

    so the question is the same? how to make rpm of google-chrome not chromium
    --
    WBR

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,335
    Blog Entries
    15

    Default Re: [?rpm]last build google-chrome-unstable 4.0.206

    Quote Originally Posted by didencool
    ab@novell.com wrote:

    > I pulled 'chromium-browser' from the OpenSUSE repos Saturday or so as
    > I recall, and that is 4.0.207. So far working like a charm.
    Malcolm wrote:

    > there are three of us that have
    > packaged it up now....
    > See;
    > <http://forums.opensuse.org/applicati...-bit-chromium-

    anyone.html>
    > and
    > <http://forums.opensuse.org/opensuse-...0486-building-

    chromium-how-pack-into-rpm.html>
    thank you alot
    but can you explain to me what a difference between google-chrome and
    chromium browser?
    I have experienced from start that google-chrome was much more stable
    with 4.0.203 then chromium 4.0.207... i have one crash from start but i
    have never crash all chrome. I have also problems with flash on you
    tube it crashed in very different ways when i close|open another tab
    etc something bad with
    it is really cool that chromium can import my stuff from firefox but
    not from chrome (for now I have more recent @chrome)???
    chromium do not hides in system tray when chrome does
    and last I have problem with enocding in one local search engine (I
    have same problem in ff) but chrome is works perfect with it...

    so the question is the same? how to make rpm of google-chrome not
    chromium
    Hi
    I'm running and don't have any problems;
    Code:
    Chromium	4.0.207.0 (Developer Build 25606)
    WebKit	532.0
    V8	1.3.9
    User Agent	Mozilla/5.0 (X11; U; Linux x86_64; en-US)
    AppleWebKit/532.0 (KHTML, like Gecko) Chrome/4.0.207.0 Safari/532.0
    If you ask user dbuck in the OBS forum to post his rpm spec file and
    ask him what to change for enabling ffmpeg Then download the
    snapshot you want and build your own rpm....

    Google Chrome is built with open source code from Chromium which AFAIK
    is just the build environment to build googe-chrome(the windows
    name)/chromium-browser.

    http://dev.chromium.org/

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 19:44, 2 users, load average: 0.03, 0.07, 0.13
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •