Results 1 to 2 of 2

Thread: netbios yast name resolution problem, smb printing - OS 11.1

  1. #1
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    52

    Default netbios yast name resolution problem, smb printing - OS 11.1

    I discovered a problem with the Yast "Add a new printer configuration" "Connection Wizard" when configuring a connection to a SMB printer share.

    When you try to "Test Connection" yast tries to resolve the NetBios Host name with a DNS query (checked it with wireshark). Unless you configured a DNS yast will not resolve the host name and thus will not be able to set up a connection. It prompts a weird error "ping: unknown host".

    Shouldn't it do a SMB name resolution broadcast or try to resolve the name with a wins name server?

    If you ignore this failed test yast does however configure the printer correctly. You can also configure the printer through the cups web interface http://localhost:631/.

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: netbios yast name resolution problem, smb printing - OS

    Glad you got it working. For other users who can't get it working, there is a full tutorial here: Samba Printer Sharing: openSUSE Print Server for Linux & Windows Clients
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •