Results 1 to 2 of 2

Thread: udev DEVICE="/proc/bus/usb/..." instead of "/dev/bus/usb/...

  1. #1
    plusmensch NNTP User

    Default udev DEVICE="/proc/bus/usb/..." instead of "/dev/bus/usb/...

    Hi,

    I try to run a MidiSport 2x2 USB interface with OpenSuse 11.1 with a current kernel. This worked a few month before in a similar setup. Now the firmware upload to the device does not work any more.
    The problem: when udev calls the firmware loader (fxload) it sets "DEVICE" to "/proc/bus/usb/..." instead of "/dev/bus/usb/..." as needed.
    Die udev rule looks like that:
    ACTION=="add", SUBSYSTEM=="usb", DEVPATH=="/*.0", ENV{PRODUCT}=="763/1010/*", RUN+="/sbin/fxload -s /usr/local/share/usb/maudio/MidiSportLoader.ihx -I /usr/local/share/usb/maudio/MidiSport1x1.ihx"
    Is this a known issue?
    Since when is "/proc/bus/usb/..." deprecated?
    How do I make udev to pass the right path in "DEVICE" by default without setting it in a rule explicitly?

    Thanks,

    pm

  2. #2
    plusmensch NNTP User

    Default Re: udev DEVICE="/proc/bus/usb/..." instead of "/dev/bus/usb

    OK, meanwhile I found out that DEVICE is also deprecated and DEVNAME should be used in udev rules instead. I added -D $env{DEVNAME} to the udev rule to make fxload address the right usb device file. Unfortunately DEVNAME is not defined when executing the usb-add rule.
    Still puzzled.

    pm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •