Hi!
I'm running openSUSE 11.1 with KDE 4.2 on a virtual machine, trhough Virtualbox. I had some trouble enabling desktop effects on this virtual machine, so I'm writing to tell everyone interested how I've sorted all out.
You need to edit xorg.conf file. In order to do that, open a console window and type "kdesu kate /etc/X11/xorg.conf". This will open Kate editor in super user mode. Now search for the "Extensions" section and, once found it, paste the following, between "Section" and "EndSection": "Option "Composite" "2"".
Now you should be able to enable desktop effects from desktop configuration. Once you restart your virtual machine, everything should be ok.