Results 1 to 6 of 6

Thread: problem installing agg-2.5

  1. #1

    Default problem installing agg-2.5

    Hi all!

    I am trying to install the agg library (Anti-Grain Geometry - Download), but when i tipe make (after configuring) it gives the following error:

    Code:
    make[3]: Entering directory `/usr/local/src/agg-2.5/src/platform/X11'
    /bin/sh ../../../libtool --tag=CXX   --mode=link g++ -I../../../include -I -g -O2 -version-info 2:4:0  -L  -o libaggplatformX11.la -rpath /usr/local/lib libaggplatformX11_la-agg_platform_support.lo -lX11 
    libtool: link: require no space between `-L' and `-o'
    make[3]: *** [libaggplatformX11.la] Error 1
    make[3]: Leaving directory `/usr/local/src/agg-2.5/src/platform/X11'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/usr/local/src/agg-2.5/src/platform'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/local/src/agg-2.5/src'
    make: *** [all-recursive] Error 1
    This seems to be a bug reported in other distributions (Bug#534041: agg: FTBFS: libtool error - linux.debian.bugs.rc | Google Groups, Nabble - Anti-Grain Geometry - [PROBLEM] Cannot build agg-2.5 under gentoo)
    What can I do?

  2. #2

    Default Re: problem installing agg-2.5

    Sorry i don't know if this is the correct forum to post. If no, can someone move it to the appropriate one? tnx

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: problem installing agg-2.5

    Quote Originally Posted by carl-alv
    Hi all!

    I am trying to install the agg library ('Anti-Grain Geometry -
    Download' (http://www.antigrain.com/download/index.html)), but when i
    tipe make (after configuring) it gives the following error:


    Code:
    --------------------
    make[3]: Entering directory
    `/usr/local/src/agg-2.5/src/platform/X11' /bin/sh ../../../libtool
    --tag=CXX --mode=link g++ -I../../../include -I -g -O2 -version-info
    2:4:0 -L -o libaggplatformX11.la -rpath /usr/local/lib
    libaggplatformX11_la-agg_platform_support.lo -lX11 libtool: link:
    require no space between `-L' and `-o' make[3]: ***
    [libaggplatformX11.la] Error 1 make[3]: Leaving directory
    `/usr/local/src/agg-2.5/src/platform/X11' make[2]: *** [all-recursive]
    Error 1 make[2]: Leaving directory
    `/usr/local/src/agg-2.5/src/platform' make[1]: *** [all-recursive]
    Error 1 make[1]: Leaving directory `/usr/local/src/agg-2.5/src' make:
    *** [all-recursive] Error 1 --------------------


    This seems to be a bug reported in other distributions ('Bug#534041:
    agg: FTBFS: libtool error - linux.debian.bugs.rc | Google Groups'
    (http://tinyurl.com/njuyf3), 'Nabble - Anti-Grain Geometry - [PROBLEM]
    Cannot build agg-2.5 under gentoo' (http://tinyurl.com/m3d26d))
    What can I do?
    Hi
    Which release of openSUSE are you using? In 11.1 agg-2.5 is in the
    standard install?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 4 days 0:06, 2 users, load average: 0.08, 0.14, 0.09
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  4. #4

    Default Re: problem installing agg-2.5

    I'm using 11.1, but it does not seem to be installed as the application i am trying to install (desmune) says it does not find it:

    Code:
    configure: error: Antigrain library is required to build desmume
    and i cand find it with yast either

  5. #5

    Default Re: problem installing agg-2.5

    Hi, I just found it in the software manager. Sry (I must be dumb, I could swear it wasnt there before but....). Thank you for your answer.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: problem installing agg-2.5

    Quote Originally Posted by carl-alv
    I'm using 11.1, but it does not seem to be installed as the application
    i am trying to install (desmune) says it does not find it:


    Code:
    --------------------
    configure: error: Antigrain library is required to build desmume
    --------------------


    and i cand find it with yast either
    Hi
    Have a look here for both then
    http://software.opensuse.org/search?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 4 days 0:21, 2 users, load average: 0.05, 0.09, 0.09
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •