Results 1 to 4 of 4

Thread: Older version of library needed but i have newer one

  1. #1
    Join Date
    Jul 2008
    Location
    India
    Posts
    182

    Default Older version of library needed but i have newer one

    Hi,

    I am trying to install the rpm of a package called octave, version 3.2. It needs the libs of a software hdf5-1.6.7. Now i have separately compiled a later version hdf5-1.6.9 and installed it in /usr/local/hdf_5-1.6.9. Is there a method for me to attempt to try to make the octave rpm use the libs of my compiled hdf5 and thereby get it installed? I would like to refrain from installing hdf5-1.6.7.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Older version of library needed but i have newer one

    Quote Originally Posted by samrat rao
    Hi,

    I am trying to install the rpm of a package called octave, version
    3.2. It needs the libs of a software hdf5-1.6.7. Now i have separately
    compiled a later version hdf5-1.6.9 and installed it in
    /usr/local/hdf_5-1.6.9. Is there a method for me to attempt to try to
    make the octave rpm use the libs of my compiled hdf5 and thereby get it
    installed? I would like to refrain from installing hdf5-1.6.7.

    Thanks.
    Hi
    You need to (as root user) add a file in the /etc/ld.so.conf.d directory
    called say hdf.conf and in that file put the full path to your library
    eg
    /usr/local/hdf_5-1.6.9/lib

    Then run the command ldconfig

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 11:36, 2 users, load average: 0.14, 0.08, 0.08
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  3. #3
    Join Date
    Jul 2008
    Location
    India
    Posts
    182

    Default Re: Older version of library needed but i have newer one

    Hi Malcolm,

    Thanks, i did what you said & octave got installed. Actually i had made a separate usr.conf file in /etc/ld.so.conf.d for adding libs of some compiled packages. I also ran ldconfig a few times before. But this had completely slipped from my mind. Thanks again.

    Btw, is there a thanks button in this forum?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Older version of library needed but i have newer one

    Quote Originally Posted by samrat rao
    Hi Malcolm,

    Thanks, i did what you said & octave got installed. Actually i had
    made a separate usr.conf file in /etc/ld.so.conf.d for adding libs of
    some compiled packages. I also ran ldconfig a few times before. But this
    had completely slipped from my mind. Thanks again.

    Btw, is there a thanks button in this forum?
    Hi
    Glad you have it installed Hmm there is a rep button

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 14:35, 2 users, load average: 0.23, 0.08, 0.09
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •