Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: phpmyadmin

  1. #1

    Default phpmyadmin

    Hi,
    i have installed phpmyadmin from repository and when i try to connect i get the message:

    Access denied
    error 403

    i don't know what to do

    thanks for your help

    Thierry

  2. #2

    Default Re: phpmyadmin

    is it a problem with a non loaded apache module?

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: phpmyadmin

    Should work out of the box if you got the package from software.opensuse.org. Check that you have the right package:

    rpm -q phpMyAdmin

    Check that you are using the right URL:

    http://localhost/phpMyAdmin

    Show us the full error message. Also look in /var/log/apache2/error_log for any clues.

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: phpmyadmin

    I haven't tried phpmyadmin. but i think its related to your mysql conf, mean username/password.

    You can use, works far better than phpmyadmin:
    Mysql Query Browser
    Mysql Administrator

    You can search it in software management:
    mysql-query-browser
    mysql-administrator

    It's a front end tools for MySQL, and works better than other softwares.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  5. #5

    Default Re: phpmyadmin

    hello
    rpm -q phpMyAdmin : phpMyAdmin-3.2.0-1.1
    the message is : you don't have access to this directory; either there is no index.html either the directory is protected

    thanks for your help

    Thierry

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: phpmyadmin

    Did you install these packages?

    apache2-mod_php5-5.2.9-0.1.1
    php5-5.2.9-0.1.1
    php5-zlib-5.2.9-0.1.1
    php5-mbstring-5.2.9-0.1.1
    php5-mysql-5.2.9-0.1.1

    and probably more needed. You also need to enable php5 in /etc/sysconfig/apache2, variable APACHE_MODULES, you should add php5 to that string and restart apache.

  7. #7

    Default Re: phpmyadmin

    hello
    i had all these packages installed and i add php5 to MODUELS in sysconfig .I restarted apache but it does'nt work!!

    what can i do?

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: phpmyadmin

    First test a simple PHP script to make sure that system works. Put this in /srv/www/htdocs/phpinfo.php:

    <?php
    phpinfo();
    ?>

    Then go to http://localhost/phpinfo.php. If you don't get a page telling you all about PHP, your PHP setup isn't working.

  9. #9

    Default Re: phpmyadmin

    hi,
    i tried your test and it does'nt work!!
    Thanks

    Thierry

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,473
    Blog Entries
    14

    Default Re: phpmyadmin

    AFAICS you don't have apache running. Start Yast - System - Runlevel editor, and make sure apache starts at boot.
    Then in Yast - Network Services - HTTP configuration check the settings.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •