Results 1 to 7 of 7

Thread: PC-Speaker is hurting my ears :-(

  1. #1
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    386

    Default PC-Speaker is hurting my ears :-(

    Hi!
    Some error-sounds is played trough PC-Speaker and not trough normal sound-device. ASLA-setup have separate volumes for ALSA-sounds and PC-speakers. But the error-sound in PC-speaker is horrible and hurt my ears.

    Not many applications play sound trough PC-speaker, but IBM Lotus Notes Client do this everytime i receive new message!

    Earlier i could turn down the volume, but now it doesnt matter is a Mute PC-speakers the sound is still at maximum. I think this happens after KDE4.2

    How do i fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,509
    Blog Entries
    14

    Default Re: PC-Speaker is hurting my ears :-(

    Try this in a terminal:

    su -c 'rmmod pcspkr'

    After that start Notes and report back what happens. If sounds via PC speaker stop after the command, you can add "blacklist pcspkr" to the file /etc/modprobe.d/50-blacklist.conf

    Please get back to us with results
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    386

    Default Re: PC-Speaker is hurting my ears :-(

    Hi!
    Nope it didn't work! It comes a high frequence-sound that make me jump in the chair.
    Its like a powerful sound-pulse at 8000Hz.

    Its very annoying!

    What else can i do?

    RS

    Quote Originally Posted by Knurpht View Post
    Try this in a terminal:

    su -c 'rmmod pcspkr'

    After that start Notes and report back what happens. If sounds via PC speaker stop after the command, you can add "blacklist pcspkr" to the file /etc/modprobe.d/50-blacklist.conf

    Please get back to us with results

  4. #4
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: PC-Speaker is hurting my ears :-(

    On Mon, 2009-08-31 at 13:06 +0000, ronnys wrote:
    > Hi!
    > Nope it didn't work! It comes a high frequence-sound that make me jump
    > in the chair.
    > Its like a powerful sound-pulse at 8000Hz.
    >
    > Its very annoying!
    >
    > What else can i do?


    I hope you rebooted after doing the recommendation below.

    It's possible that you're experiencing feedback since the speaker
    can also be a mic. So... you can try bringing up a mixer and killing
    the mic input (zero it or disable it).

    The info below is the usual answer to get rid of the PC speaker.

    >
    > RS
    >
    > Knurpht;2033621 Wrote:
    > > Try this in a terminal:
    > >
    > > su -c 'rmmod pcspkr'
    > >
    > > After that start Notes and report back what happens. If sounds via PC
    > > speaker stop after the command, you can add "blacklist pcspkr" to the
    > > file /etc/modprobe.d/50-blacklist.conf
    > >
    > > Please get back to us with results

    >
    >



  5. #5
    Join Date
    Sep 2008
    Location
    Rostov-on-Don, Russia
    Posts
    25

    Default Re: PC-Speaker is hurting my ears :-(

    Try this:
    Code:
    xset b off
    KDE 4.11 | openSUSE 12.3 (x86_64)

  6. #6
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    386

    Default Re: PC-Speaker is hurting my ears :-(

    Now i havent heard any more painfull sounds, so it seems to work.
    What does this command do?

    RS

    Quote Originally Posted by Kostik-N View Post
    Try this:
    Code:
    xset b off

  7. #7
    Join Date
    Sep 2008
    Location
    Rostov-on-Don, Russia
    Posts
    25

    Default Re: PC-Speaker is hurting my ears :-(

    Quote Originally Posted by ronnys View Post
    Now i havent heard any more painfull sounds, so it seems to work.
    What does this command do?

    RS
    xset command customizes your X-Windows environment.
    b off - turns the bell off

    P.S. man xset
    KDE 4.11 | openSUSE 12.3 (x86_64)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •