Results 1 to 4 of 4

Thread: Remote control of mouse lircmd

  1. #1

    Default Remote control of mouse lircmd

    Would like to navigate Firefox from the TV couch using an Hauppauge remote control. The TV is a clone of the PC monitor screen in another room and has wired connections (S-video, 2 audio and IR). Works fine with the lirc commands, but it does get tedious to tab down on a web page with say 50 links. For this I use an Rf mouse transmitting through the wall, but I would prefer to use the IR remote controller. Should be possible with lircmd, but I cannot do it. Help!

    The lircmd deamon starts ok but there is no action. Have lircmd.conf and xorg.conf entries exactly (except Device "evdev" in Xorg.conf) as per the lircmd documentation. Get the following message in Xorg.0.log:

    (**) Option "SendCoreEvents"
    (**) LIRC-Mouse: always reports core events
    (**) LIRC-Mouse: Device: "/dev/lircm"
    (EE) ioctl EVIOCGNAME failed: Invalid argument
    (II) UnloadModule: "evdev"
    (EE) PreInit returned NULL for "LIRC-Mouse"

    What to do??

  2. #2

    Default Re: Remote control of mouse lircmd

    Learnd form here HAL - how reconfigure? - FedoraForum.org the correct way with HAL, creating a file /etc/hal/fdi/policy/30user/10-lirc_mouse.fdi.

    So Xorg.0.log looks good, the lircmd deamon is working and /dev/lircm is there, but the LIRC-Mouse is still not working.

    Could someone suggest a script to create an event for this?

  3. #3

    Default Re: Remote control of mouse lircmd

    Correction, the above applies to my partitions with Mandriva and Fedore respectively.

    With the SuSE partition I have the additional problem of /dev/lircm not being there.

    How to create /dev/lircm in SuSE? Help

  4. #4

    Default Re: Remote control of mouse lircmd

    Have /dev/lircd but not /dev/lircm
    In /var/run/lirc I found lircd (called socket) and lircm (called pipe).

    What is a "pipe"? Tried to create a symbolic link to lircm in /dev but couldnot.

    Believe that here is a reason for the lirc_mouse not to function.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •