Results 1 to 6 of 6

Thread: more silly questions....

  1. #1
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default more silly questions....

    I tried to do the ol' ./configure make install tango this morning, and ./configure returned this error:
    Code:
    configure: WARNING: libjpeg not found. disable JPEG support.
    checking for perl... /usr/bin/perl
    checking for Qt... configure: error: Qt (>= Qt 3.2 and < 4.0) (headers and libraries) not found. Please check your installation!
    For more details about this problem, look at the end of config.log.
    Here it is in full:
    pastebin - collaborative debugging tool


    Here is the end of config.log:
    Code:
    ibdir='${exec_prefix}/lib'
    libexecdir='${exec_prefix}/libexec'
    localedir='${datarootdir}/locale'
    localstatedir='${prefix}/var'
    mandir='${datarootdir}/man'
    mkdir_p='mkdir -p --'
    oldincludedir='/usr/include'
    pdfdir='${docdir}'
    prefix='/opt/kde3'
    program_transform_name='s,x,x,'
    psdir='${docdir}'
    qt_includes=''
    qt_libraries=''
    sbindir='${exec_prefix}/sbin'
    sharedstatedir='${prefix}/com'
    sysconfdir='${prefix}/etc'
    target='i686-pc-linux-gnu'
    target_alias=''
    target_cpu='i686'
    target_os='linux-gnu'
    target_vendor='pc'
    unsermake_enable_pch_FALSE=''
    unsermake_enable_pch_TRUE='#'
    x_includes='.'
    x_libraries='/usr/lib'
    xdg_appsdir=''
    xdg_directorydir=''
    xdg_menudir=''
    
    ## ----------- ##
    ## confdefs.h. ##

    I fired up YAST and I have libjpeg, and all qt that look relevant. Where do I go from here?

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: more silly questions....

    Why are you trying to build everything from source? There shouldn't be any need for it. If I go to software.opensuse.org/search I get this on a search for tango:

    0 collections and 30 binaries from 15 source packages

    Yet, if you want to do it this way, you should know, that if 'configure' says you need libjpeg, you cannot use the compiled libraries, you need the development package: libjpeg-devel

    But, if I were you, I first would learn more about this matter, and install only precompiled packages through the appropriate channels.

    This way, you're going from one question to the next.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: more silly questions....

    TY Mr Knurpht!,

    Why are you trying to build everything from source? There shouldn't be any need for it. If I go to software.opensuse.org/search I get this on a search for tango:
    I am not trying to build everything, I AM trying to learn how to, so that I can if I need to.

    (The app is not called "Tango" BTW, that was just my little joke that linux likes to lead us a merry dance.)

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: more silly questions....

    Understood. So, I did not type the rest of the post for nothing

    It's always in the -devel files, the needed stuff for compiling.

    Don't hesitate to ask more questions. Questions are never stupid, answers can be.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Wink Re: more silly questions....

    Understood. So, I did not type the rest of the post for nothing
    Absolutely not!
    It's always in the -devel files, the needed stuff for compiling.
    TY and understood....




    Thanks again, Knurpht, with the hints in your first reply, I Yasted some -devel pkgs, and after a couple of hurdles and hiccups, and more googling, I got the app to install. I haven't a clue what to do with it now it is there, but I feel quite chuffed anyway!

    Don't hesitate to ask more questions. Questions are never stupid, answers can be.
    I love Linux people..........

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  6. #6
    Join Date
    Aug 2009
    Location
    Walnut, MS, USA
    Posts
    64

    Default Re: more silly questions....

    Quote Originally Posted by wakou View Post
    I tried to do the ol' ./configure make install tango this morning, and ./configure returned this error:
    Code:
    configure: WARNING: libjpeg not found. disable JPEG support.
    checking for perl... /usr/bin/perl
    checking for Qt... configure: error: Qt (>= Qt 3.2 and < 4.0) (headers and libraries) not found. Please check your installation!
    For more details about this problem, look at the end of config.log.
    Here it is in full:
    pastebin - collaborative debugging tool


    Here is the end of config.log:
    Code:
    ibdir='${exec_prefix}/lib'
    libexecdir='${exec_prefix}/libexec'
    localedir='${datarootdir}/locale'
    localstatedir='${prefix}/var'
    mandir='${datarootdir}/man'
    mkdir_p='mkdir -p --'
    oldincludedir='/usr/include'
    pdfdir='${docdir}'
    prefix='/opt/kde3'
    program_transform_name='s,x,x,'
    psdir='${docdir}'
    qt_includes=''
    qt_libraries=''
    sbindir='${exec_prefix}/sbin'
    sharedstatedir='${prefix}/com'
    sysconfdir='${prefix}/etc'
    target='i686-pc-linux-gnu'
    target_alias=''
    target_cpu='i686'
    target_os='linux-gnu'
    target_vendor='pc'
    unsermake_enable_pch_FALSE=''
    unsermake_enable_pch_TRUE='#'
    x_includes='.'
    x_libraries='/usr/lib'
    xdg_appsdir=''
    xdg_directorydir=''
    xdg_menudir=''
    
    ## ----------- ##
    ## confdefs.h. ##

    I fired up YAST and I have libjpeg, and all qt that look relevant. Where do I go from here?
    Read it, its telling you what it needs.
    1) You need the DEV package for libjpeg.
    2) Also need libqt-dev package between 3.2 or better but not 4.0 or higher.

    Dev packages are files needed for compiling certain programs that depend on them. The other package is just the standalone binaries.

    BTW when you compile a program from source you install both.
    Need a sleek Avatar or a awesome Case Badge? You can grab the artwork needed to make on from my Picasa page.
    http://picasaweb.google.com/exodist2009

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •