Results 1 to 10 of 10

Thread: Configure Opensuse 11.1 as Router

  1. #1
    testpil0t NNTP User

    Default Configure Opensuse 11.1 as Router

    Hello everybody, im currently trying to set up OS11.1 as a router!
    I was following different guides but hat no luck, this post and this. Im a bit confused what steps i have to take to make work!

    ifconfig shows this:

    Code:
    dsl0      Link encap:Punkt-zu-Punkt Verbindung  
              inet Adresse:ip  P-z-P:62.218.100.15  Maske:255.255.255.255
              UP PUNKTZUPUNKT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:358 errors:0 dropped:0 overruns:0 frame:0
              TX packets:412 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:3 
              RX bytes:317217 (309.7 Kb)  TX bytes:74680 (72.9 Kb)
    
    eth0      Link encap:Ethernet  Hardware Adresse 00:22:15:06:10:F4  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:582 errors:0 dropped:0 overruns:0 frame:0
              TX packets:951 errors:0 dropped:0 overruns:0 carrier:6
              collisions:0 Sendewarteschlangenlänge:1000 
              RX bytes:421074 (411.2 Kb)  TX bytes:210545 (205.6 Kb)
              Interrupt:218 
    
    lo        Link encap:Lokale Schleife  
              inet Adresse:127.0.0.1  Maske:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:110 errors:0 dropped:0 overruns:0 frame:0
              TX packets:110 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:0 
              RX bytes:8466 (8.2 Kb)  TX bytes:8466 (8.2 Kb)
    
    pan0      Link encap:Ethernet  Hardware Adresse 7E:81:29:7A:3E:0A  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:0 
              RX bytes:0 (0.0 b)  TX bytes:384 (384.0 b)
    ifconfig eth1

    Code:
    eth1      Link encap:Ethernet  Hardware Adresse FF:FF:FF:FF:FF:FF
              inet Adresse:192.168.1.1  Bcast:192.168.1.255  Maske:255.255.255.0
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:1000
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:17 Basisadresse:0x4000
    dsl0 is the internet connection (pppoe), eth0 is the adapter the dsl modem is connected to (with dhcp), eth1 is the card for the internal network (static ip with 192.168.1.1)! Today i realized that i might have a hardware problem with eth1, when restarting the network devices with rcnetwork restart this shows up:

    Code:
    Shutting down network interfaces:
        dsl0      name: DSL-Verbindung
        dsl0                                                                                done
        eth0      device: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
        eth0                                                                                done
        eth1      device: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
        eth1                                                                                done
    Shutting down service network  .  .  .  .  .  .  .  .  .                                done
    Hint: you may set mandatory devices in /etc/sysconfig/network/config
    Setting up network interfaces:
        eth0      device: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
        eth0      Starting DHCP4 client. . . . . . . .
        eth0      DHCP4 continues in background
        eth0                                                                                waiting
        eth1      device: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
        eth1      IP address: 192.168.1.1/24
    interface eth1 is not up
        eth1                                                                                done
        dsl0      name: DSL-Verbindung
        dsl0                                                                                done
    Setting up service network  .  .  .  .  .  .  .  .  .  .                                done
    In Yast2 the network configuration shows "ff:ff:ff:ff:ff:ff" as mac address for the network card, which cant't be correct! The card is a Longshine LCS-8037TXR which uses a Realtek Chipset (don't know which one). On the hardware tab of the eth1 card i can see that the module "r8169" is loaded! Is it possible that incorrect drivers are loaded ? The card should be supported, i've tested it with ubuntu a year ago!

    When i try to ping another pc with the ip 192.168.1.2 i get
    Code:
    icmp_seq=1 Destination Host Unreachable
    Any tips ? Thank you all in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Configure Opensuse 11.1 as Router

    This does not look good to me. AFAIK dsl0 should not be there, eth0 should get an IP-address from the modem (62.218.100.15), all traffic from eth1 should be routed to eth0.
    Now eth0 has no IP address so you cannot route any traffic to it.

    But I have to admit I'm no specialist in this matter
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    testpil0t NNTP User

    Default Re: Configure Opensuse 11.1 as Router

    Thanks for your quick reply! Im connecting to internet over pppoe and have to supply username/password, so it's bascially a point to point tunnel (correct me if i'm wrong)! The modem itself was a router but i've configured it to a bridge mode so that i can use it with my wrt54gl! That always worked like a charm for me!

    So you think that its not working because the dsl0 connection is there ? I could reset the modem to it's defaults so that the modem does the connection, but it also has nat translation so i would end up with a firewall behind a nat!

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,830

    Default Re: Configure Opensuse 11.1 as Router

    I think the same as Knurpht. Either you have a seperate modem where you connect to with eth0. Or the DSL line is connected directly to your system and then you use dsl0. Try to make a picture of your network on a post. I know it is not easy in 'ASCII art', but it may help a lot in our understanding.
    Henk van Velden

  5. #5
    testpil0t NNTP User

    Default Re: Configure Opensuse 11.1 as Router

    Ok i'll try

    The Current Setup:


    Code:
    Modem -> Router -> Client
    
    Modem= Tilgin Vood 422 ADSL Modem in Bridge Modus
           Connected to the Wan port of the Router
    
    Router= WRT54GL dials in with pppoe username & password
    
    Clients= pc connected to the internal switch of the wrt54gl
    Future Setup:

    Code:
    Modem -> eth0 -> openSUSE -> eth1 -> clients
    
    eth0 is connected with the modem, with yast i've created an DSL connection which uses eth0 to establish an pppoe connection /w username & password!

    I wan't to repalce the WRT54Gl /w opensuse!
    Like i said before, the Modem itself can act as a router (nat, dhcp etc.) i've disabled this and set it to bridge mode so that the wrt can establish the connection!

    I made an DSL connection which uses eth0 (eth0 is hooked up to the modem, configured with dhcp) and that "dials in" with my username and password! IIRC the only possibility to do this! Works the same way on win xp!

    The connection is an ADSL, if that helps any1!
    thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,830

    Default Re: Configure Opensuse 11.1 as Router

    Thanks, I did get a better idea, though I do not quite understand why you do not use the modem as router, but that is p to you. For me it is a same sort of thing, but it loks that dsl0 is a logical thing running over eth0. dsl0 gets the IP address and eth0 not (but it is UP).

    You do not tell us if the connection between this sytem and the outside world is functioning or not.

    Leaving all this beside, I think you are right that there is something wrong with eth1. The MAC address is not recocnised and it is not up and running (trying to use it with ping or whatever does not work then for sure).
    Henk van Velden

  7. #7
    testpil0t NNTP User

    Default Re: Configure Opensuse 11.1 as Router

    The modem can act as router, but it sometimes crashes and page loading times are not acceptable! The webinterface is **** and there are also problems with port forwarding etc. Apart from that i just like to experiment with such things And routing with opensuse seemed to be an interessting project!

    I want to replace the WRT54GL with a small box that handles all my services (ftp, openvpn, etc.)! So what do you recommend ? Reset the modem to act as a router, hook up eth0 with the modem, configure eth1 with an ip address and connect the clients via a switch on eth1?

    The modem automatically takes 192.168.1.1, so eth0 would be 192.168.1.2, eth1 192.168.1.3! I also would like to use dhcp on eth1 so that ips above 192.168.1.3 would be assigend to clients!

    I'm going to replace eth1 with an old intel 100mbps card i have laying arround!
    Isn't there a way to route traffic from dsl0 to eth1 ? Is setting ip_forward 1 enough to enable the routing ?
    Thanks for your efforts!

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Configure Opensuse 11.1 as Router

    You could try a dedicated router distro like IPCop or Endian Firewall. They are designed for ease of management. But you would need to keep another PC running.

    You could also try to flash the WRT54GL with a Linux based distro like dd-wrt or openwrt and do better than the mfr supplied firmware.

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,830

    Default Re: Configure Opensuse 11.1 as Router

    IMHO you have two networks here, one between eth0 and the modem and one between eth1 and te other systems. Those two networls can not have the same network address.
    So when eth0 - modem is 192.168.1.0/24 you can not have 192.168.1.3 as an IP address on eth1. You should take another range (e.g. 10.0.0.0/8 or a subnet of it). When you want to use DHCP on that net you need to run a DHCP server, the router system being the best candidate for it.
    Henk van Velden

  10. #10
    testpil0t NNTP User

    Default Re: Configure Opensuse 11.1 as Router

    Thanks for all your help, routing is now working properly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •