Results 1 to 7 of 7

Thread: Alt-F1 (Kmenu) not working

  1. #1
    Join Date
    Jul 2009
    Location
    Mumbai, India
    Posts
    19

    Default Alt-F1 (Kmenu) not working

    Hi guys,
    I know this might be a stupid question but anyway I can't figure out what to do.
    I'm on KDE 4.1.3 on my openSuSE 11.1.
    Once while playing around with the Plasma Widget I accidentally deleted the KMenu Widget. Though I did get it back, I am unable to use the shortcut key (Alt+F1) since. I checked the Keyboard Shortcuts and found that the Alt+F1 key is mapped as a shortcut to the Application Launcher under Plasma Workspace.
    Any help will be appreciated and thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Alt-F1 (Kmenu) not working

    Right click the menu - Application Launcher settings
    keyboard shortcut
    configure there
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jul 2009
    Location
    Mumbai, India
    Posts
    19

    Default Re: Alt-F1 (Kmenu) not working

    Actually I'd tried that but the Application Launcher Settings just has one setting, viz Switch tabs on Hover.

  4. #4
    Join Date
    Sep 2009
    Posts
    41

    Default Re: Alt-F1 (Kmenu) not working

    The I have the same system and the same problem.

  5. #5
    Join Date
    Sep 2009
    Posts
    41

    Default Re: Alt-F1 (Kmenu) not working

    I fixed the problem in such a way:

    find file:
    /home/username/.kde4/share/config/plasma-appletsrc

    In the file look for the line plugin=simplelauncher

    There should be a block like:
    Code:
    [Containments][38][Applets][131]
    geometry=0,11,24,24
    immutability=1
    plugin=simplelauncher
    zvalue=0
    Your numbers like [38] and [131] should be different form mine.

    Then add the following block after of before the current:

    Code:
    [Containments][3][Applets][14]
    geometry=0,11,24,24
    immutability=1
    plugin=simplelauncher
    zvalue=0
    
    
    [Containments][38][Applets][131][Shortcuts]
    global=Alt+F1
    Logout and log in - has to work.

    Explanation:

    The block
    Code:
    [Containments][3][Applets][14]
    geometry=0,11,24,24
    immutability=1
    plugin=simplelauncher
    zvalue=0
    is the original definition of the Application Launcher. By adding this, the Launcher will not be shown, but will be somewhere in memory. This "empty" definition is needed to make the hotkey work.

    I'm not sure, if the numbers in brackets 3 and 14 has to be exactly 3 and 14, but theese were in a fresh user's config file file.

    The block
    Code:
    [Containments][38][Applets][131][Shortcuts]
    global=Alt+F1
    defines default hotkey for my current Application Launcher Widget.

  6. #6
    Join Date
    Mar 2010
    Location
    UK
    Posts
    6

    Default Re: Alt-F1 (Kmenu) not working

    Thanks to 'gruz', just one correction:

    In new version, the correct entry to find is:
    plugin=launcher
    rather than
    plugin=simplelauncher

    So steps once again
    1) open the file 'plasma-appletsrc' available at:

    /home/<user>/.kde4/share/config/

    2) find:

    plugin=launcher

    3) below it, you will find something like:

    [Containments][4][Applets][5][Shortcuts]

    4) add the following line underneath it:

    global=Alt+F1


    I had the same problem, and I didn't know the above solution, so I had to reset the kde by deleting (renaming to be precise) the .kde4 directory (available at /home/<user>/), then rebooted the system to auto-rebuild .kde4 directory. It worked but I lost my many customized settings. So I recommend the above approach.

    Good luck
    Eddie Kumar

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,432
    Blog Entries
    14

    Default Re: Alt-F1 (Kmenu) not working

    Quote Originally Posted by Aditya_Shrivastava View Post
    I had the same problem, and I didn't know the above solution, so I had to reset the kde by deleting (renaming to be precise) the .kde4 directory (available at /home/<user>/), then rebooted the system to auto-rebuild .kde4 directory. It worked but I lost my many customized settings. So I recommend the above approach.
    First: a reboot is hardly ever needed, a logout/login should be enough.
    Second: removing the entire ~/.kde4 is hardly ever needed either. Usually it's enough to remove the files concerning the malfunctioning app
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •