Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Problems with samba server

  1. #1

    Unhappy Problems with samba server

    Hi! I was following this guide about porting windows forms apps to linux using Mono: Guide: Porting Winforms Applications - Mono
    But it uses an older version of OpenSuse (10.2) and the VMWare image that I have is Opensuse 11.1 and I can't find the "Samba server" option in "Network Services".

    # Click the "Computer" menu in the bottom left, choose Control Center.
    # Choose "YaST" at the bottom, the password is "mono".
    # Choose "Network Services", then "Samba Server".
    # Check "Allow Users to Share Their Directories" on the "Shares" tab.
    # Choose "Finish".
    Can you tell me where I can find this option or another way to do whatever it does?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Problems with samba server

    You can edit /etc/samba/smb.conf directly via your favorite editor. I prefer using a CLI edtitor like pico, but thats a matter of personal preference. As with many servers, they often run without graphical desktops, so manual configuration is necessary. (I had such a task assigned to me this week). If you have a graphical desktop, you might like to use

    kdesu kwrite /etc/samba/smb.conf (KDE Desktop)

    gnomesu gedit /etc/samba/smb.conf (Gnome Desktop)

    Swerna's excellent samba guide is a useful reference for configuring smb.conf as required.

  3. #3

    Default Re: Problems with samba server

    I did what you told me and I get this:
    Code:
    [global]
    	workgroup = MONO
    	security = user
    	passdb backend = smbpasswd
    	username map = /etc/samba/smbusers
    
    [homes]
    	inherit acls = Yes
    	browseable = No
    	read only = No
    
    [htdocs]
    	inherit acls = Yes
    	browseable = Yes
    	path = /srv/www/htdocs/
    	read only = No
    In the guide it says I have to Allow Users to Share Their Directories. What do I have to change?

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Problems with samba server

    You need to add share entries . For example, a publicly shared directory

    [shared]
    path = /path/to/shared/directory
    public = yes
    only guest = yes
    writable = yes
    printable = no

    Lots more share examples here.

    If you explain how you want to set up access (with/without passord, which group(s), r/w access), then someone may be able to help create the exact entry required. I'm sure you'll figure it out if you take the time to read the examples though.


    BTW: Don't forget to restart the samba server if you make changes to smb.conf

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Problems with samba server

    Don't fixate on the old "allow users to share directories....". The wording leads ppl to think that's a good way to share stuff over Samba. It's not much good at all, just a beginning, and better set elsewhere.

    Have a read of this: Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 10, 11
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Problems with samba server

    Code:
    [global]
           workgroup = MONO
           netbios name = name_of_this_workstation
           name resolve order = bcast host lmhosts wins
           server string = ""
           printing = cups
           printcap name = cups
           printcap cache time = 750
           cups options = raw
           use client driver = yes
           map to guest = Bad User
           local master = yes
           os level = 33
           usershare allow guests = Yes
           usershare max shares = 100
           usershare owner only = False
    
    [homes]
    	comment = Home Directories
    	valid users = %S
    	browseable = No
    	read only = No
    	inherit acls = Yes
    
    [htdocs]
    	path = /srv/www/htdocs/
    	read only = No
           force user = billybob
    (force user should be considered for htdocs if you make your htdocs over to ownership of "billybob" with sudo chown -r billybob:users /srv/www/htdocs)
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7

    Default Re: Problems with samba server

    Sorry but I don't use Linux usually and I don't understand half of the things.

    If you explain how you want to set up access (with/without passord, which group(s), r/w access), then someone may be able to help create the exact entry required.
    This is what I need to do:

    To transfer the application to the Mono image, we need to create a NClass directory and turn on directory sharing.

    * Right click the desktop, choose Create Directory, name the directory NClass.
    * Click the "Computer" menu in the bottom left, choose Control Center.
    * Choose "YaST" at the bottom, the password is "mono".
    * Choose "Network Services", then "Samba Server".
    * Check "Allow Users to Share Their Directories" on the "Shares" tab.
    * Choose "Finish".
    * Back on the desktop, Right click the "NClass" folder you created and choose "Sharing Options".
    * Check "Share this folder" and "Allow other people to write to this folder".
    * Click "Modify Share".

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Problems with samba server

    You can do all those steps -- if you're using Gnome Desktop. Are you?
    If not using Gnome, there's a different way to do it. And even if using Gnome, there's an optional alternate way to do it.

    Q1: What are you using, Gnome or KDE?

    Q2: and is there (in your case) really a directory called NClass on the Desktop?

    Q3: I'm wondering which Samba RPMs you have installed. Can you run this command and copy the results back here:
    Code:
    rpm -qa | grep samba
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  9. #9

    Default Re: Problems with samba server

    Q1: I'm using GNOME
    Q2: The directorie on my desktop is called "GDH"
    Q3:
    Code:
    samba-3.2.7-11.3.2
    samba-client-3.2.7-11.3.2

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Problems with samba server

    AHA -- I think we've found the problem. Go to Yast --> soptware module and install the apps yast2-samba-server and yast2-samba-client. Then try again for the module "samba server" in Yast --> network services. While you're installing software, make sure the nautilus sharing tool is installed. The RPM is nautilus-share.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •