Results 1 to 3 of 3

Thread: wireless works with gnome but not with KDE

  1. #1

    Cool wireless works with gnome but not with KDE

    I just began to work with wireless connections in my job, and I could not make KNetworkManager to connect, the program shows the wireless signals and everything is fine until then, after saving and connectng to the wireless provider... nothing happens!!! what is missing? On the other side, if a work with GNOME, the wireless connection works just fine, but I haven't been able to enable the software update utility.

    Also, I was able to set Firefox up to work with my proxy (http) but both, Pidgin and Kopete do not work. Again, what am I missing?

    Thanks in advance.

    Antonio.

    N.B. KNetworkManager, Pidgin and Kopete work just fine when I connect with the ethernet connection.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: wireless works with gnome but not with KDE

    Quote Originally Posted by antonio_maximo View Post
    I just began to work with wireless connections in my job, and I could not make KNetworkManager to connect, the program shows the wireless signals and everything is fine until then, after saving and connectng to the wireless provider... nothing happens!!!.
    I think its a KDE4 bug that still has not been sorted, ... maybe by KDE-4.4 ?

    It works in KDE-3.5.10.

    But there is no need to use the Network Manager in KDE4. I sent this to a friend in an email for guidance:


    .... You could use the "traditional ifup" or instead use wicd (I
    have both instructions for the traditional, and also a link below about
    wicd).

    KNetworkManager: Some details:

    The state of wireless management in KDE4 is still not as good as that of KDE3, although progress is being made, and is almost there. I note these links:

    In my case, both of my laptop's have Intel wireless, with support right in the kernel [and recent KDE4 testing was on an Intel Wireless Pro 5300 AGN].

    But although the hardware network wireless driver is already in place when I was testing the openSUSE-11.1 KDE-4.3. liveCD, and also testing the openSUSE-11.2 milestone-6 liveCD with KDE-4.3, I noted Network Manager in the lower right corner did not work well with wireless.

    In both cases I ended up going to YaST > Network Devices > Network Settings and
    [1] acknowledge the warning about NetworkManagement controlling the Network
    [2] under Global Options Tab select the "Traditional method with ifup"
    [3] disable ipv6 (it will ask for a reboot, don't do that now)
    [4] Overview Tab - select your wireless card and select edit. Go for the default settings except as I noted below
    [5] while in Edit Select "next"
    [6] Under Network Name ESSID select scan network, and then in drop down list select your SSID
    [7] Select your authentication mode (in our case it is WPA-PSK)
    [8] Enter your passphrase
    [9] Select Next
    [10] Select OK
    [11] You may get a notification from Network Management that it is disabled.

    And wireless then works. Also, next time you reboot ipv6 will be disabled but hopefully you do not need to rush that reboot. Disabling ipv6 is just a performance tuning measure.

    But as noted, you may prefer to install wicd.

    Wicd:

    Until KNetworkManager is sufficiently mature for KDE4, many wireless "gurus" are recommending one instead use "wicd" for openSUSE. There is guidance here: Wicd - openSUSE

  3. #3

    Default Re: wireless works with gnome but not with KDE

    Dear oldcpu,

    I just installed and configured Wicd in my laptop and works great. Your help was pretty clear and helpful. Everything woks just fine now. Take care and again, I appreciate your kind help.

    Antonio.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •