Results 1 to 6 of 6

Thread: Opensuse 10.2 - HELP!

  1. #1
    suporte_aleris NNTP User

    Default Opensuse 10.2 - HELP!

    Hi guys, good afternoon,

    Could you please help me?

    I'm having a problem with a Linux Server, this server runs the OpenSuse 10.2...

    Since a few days ago, this server is "crashing", but i don't know whay!

    I've checked the hardware status, with the SmartStart application of HP, this tool dont reported me any error!

    In a Forum, here in Brazil, someone told me that could be the temperature of the CPU, but the machine stays in a room with air conditioned!

    Before the machine crashes, I run the "top" command, to see if there is a proccess consuming to many CPU resource. Nothing weird...

    saopaulx03:~ # top
    top - 13:11:57 up 44 min, 3 users, load average: 0.08, 0.07, 0.53
    Tasks: 90 total, 2 running, 88 sleeping, 0 stopped, 0 zombie
    Cpu(s): 25.6%us, 3.3%sy, 0.0%ni, 70.4%id, 0.7%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 964008k total, 716400k used, 247608k free, 60968k buffers
    Swap: 2096440k total, 0k used, 2096440k free, 455720k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    4745 wwwrun 24 0 63680 11m 3108 S 19.7 1.3 0:01.83 httpd2-prefork
    2903 mysql 15 0 108m 17m 4320 S 9.0 1.9 0:04.72 mysqld
    1 root 15 0 740 284 240 S 0.0 0.0 0:00.15 init
    2 root RT 0 0 0 0 S 0.0 0.0 0:00.00 migration/0
    3 root 34 19 0 0 0 S 0.0 0.0 0:00.05 ksoftirqd/0
    4 root 10 -5 0 0 0 S 0.0 0.0 0:00.02 events/0
    5 root 11 -5 0 0 0 S 0.0 0.0 0:00.00 khelper
    6 root 12 -5 0 0 0 S 0.0 0.0 0:00.00 kthread
    8 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 xenwatch
    9 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 xenbus
    11 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kblockd/0
    12 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
    78 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 cqueue/0
    80 root 17 -5 0 0 0 S 0.0 0.0 0:00.00 kseriod
    113 root 25 0 0 0 0 S 0.0 0.0 0:00.00 pdflush
    114 root 15 0 0 0 0 S 0.0 0.0 0:00.15 pdflush
    115 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 kswapd0
    saopaulx03:~ #

    Right now i just can't boot the machine, after the GRUB screen a error shows up, saying:

    CPU 0 Fatal Trap 18 error_code 0000

    I have pretty sure that this problem doesn't caused by a hardware failure... but by a logical problem...

    I've trying to access the machine with a LIVE CD, but without success.

    I'd like to post the /var/log/messages log here, but until the moment, i can't access these log files!

    Thanks!
    Best regards

    Ariel

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Opensuse 10.2 - HELP!

    Quote Originally Posted by suporte aleris
    Hi guys, good afternoon,

    Could you please help me?

    I'm having a problem with a Linux Server, this server runs the OpenSuse
    10.2...

    Since a few days ago, this server is "crashing", but i don't know
    whay!

    I've checked the hardware status, with the SmartStart application of
    HP, this tool dont reported me any error!

    In a Forum, here in Brazil, someone told me that could be the
    temperature of the CPU, but the machine stays in a room with air
    conditioned!

    Before the machine crashes, I run the "top" command, to see if there is
    a proccess consuming to many CPU resource. Nothing weird...

    saopaulx03:~ # top
    top - 13:11:57 up 44 min, 3 users, load average: 0.08, 0.07, 0.53
    Tasks: 90 total, 2 running, 88 sleeping, 0 stopped, 0 zombie
    Cpu(s): 25.6%us, 3.3%sy, 0.0%ni, 70.4%id, 0.7%wa, 0.0%hi, 0.0%si,
    0.0%st
    Mem: 964008k total, 716400k used, 247608k free, 60968k
    buffers
    Swap: 2096440k total, 0k used, 2096440k free, 455720k
    cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    4745 wwwrun 24 0 63680 11m 3108 S 19.7 1.3 0:01.83
    httpd2-prefork
    2903 mysql 15 0 108m 17m 4320 S 9.0 1.9 0:04.72 mysqld
    1 root 15 0 740 284 240 S 0.0 0.0 0:00.15 init
    2 root RT 0 0 0 0 S 0.0 0.0 0:00.00
    migration/0
    3 root 34 19 0 0 0 S 0.0 0.0 0:00.05
    ksoftirqd/0
    4 root 10 -5 0 0 0 S 0.0 0.0 0:00.02 events/0
    5 root 11 -5 0 0 0 S 0.0 0.0 0:00.00 khelper
    6 root 12 -5 0 0 0 S 0.0 0.0 0:00.00 kthread
    8 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 xenwatch
    9 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 xenbus
    11 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kblockd/0
    12 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
    78 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 cqueue/0
    80 root 17 -5 0 0 0 S 0.0 0.0 0:00.00 kseriod
    113 root 25 0 0 0 0 S 0.0 0.0 0:00.00 pdflush
    114 root 15 0 0 0 0 S 0.0 0.0 0:00.15 pdflush
    115 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 kswapd0
    saopaulx03:~ #

    Right now i just can't boot the machine, after the GRUB screen a error
    shows up, saying:

    CPU 0 Fatal Trap 18 error_code 0000

    I have pretty sure that this problem doesn't caused by a hardware
    failure... but by a logical problem...

    I've trying to access the machine with a LIVE CD, but without success.

    I'd like to post the /var/log/messages log here, but until the moment,
    i can't access these log files!

    Thanks!
    Best regards

    Ariel
    Hi
    Boot from the openSUSE 10.2 cd/dvd and run the memory check, does it
    crash? This should put some load on it as well (just to further
    eliminate any hardware issues).

    10.2 is no longer supported, so you may be hard pressed to find a
    software type fix if that is required.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 7 days 1:27, 2 users, load average: 0.31, 0.14, 0.10
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Opensuse 10.2 - HELP!

    On Thu, 27 Aug 2009 18:16:01 +0000, suporte aleris wrote:

    > CPU 0 Fatal Trap 18 error_code 0000


    This seems to be some sort of a software issue - if I've found the error
    code properly, it's essentially an integer division problem (probably a
    divide by zero).

    I'd second Malcom's suggestion to boot from the install media and see if
    you can run a memory test. If that doesn't work, grab a copy of
    memtest86 and give that a whirl.

    If you can't boot a liveCD, it may be a hardware fault as well.

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: Opensuse 10.2 - HELP!

    > In a Forum, here in Brazil, someone told me that could be the
    > temperature of the CPU, but the machine stays in a room with air
    > conditioned!


    A system where the CPU cooling fan had stopped would still have serious
    problems even in AC. Since the HP tools aren't throwing errors I kind of
    doubt it is hardware. Assuming those tools perform adequate hardware tests.
    What about disk space? Are you low or out?




  5. #5
    suporte_aleris NNTP User

    Default Re: Opensuse 10.2 - HELP!

    Hi guys,

    We replaced the RAM memory...
    Until now, the server is OK!

    I think that this Thread can be closed!

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Opensuse 10.2 - HELP!

    Quote Originally Posted by suporte aleris
    Hi guys,

    We replaced the RAM memory...
    Until now, the server is OK!

    I think that this Thread can be closed!
    Hi
    Thanks for the feedback, glad your up and running again

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 11:34, 2 users, load average: 0.03, 0.06, 0.07
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •