Results 1 to 5 of 5

Thread: pulseaudio annoyance

  1. #1

    Default pulseaudio annoyance

    I'm going through /var/log/messages fixing things ...

    If you see the following (or something similar) in your log:

    Code:
    pulseaudio[30854]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz
    and it annoys or worries you, edit

    Code:
    ~/.pulse/daemon.conf
    appending the line

    Code:
    default-sample-rate = 48000
    and then restart pulseaudio

  2. #2
    goldie NNTP User

    Default Re: pulseaudio annoyance

    some folks find happiness by just using YaST to uninstall pulseaudio..

    use search to check around..

    --
    goldie
    Note: Accuracy, completeness, legality, or usefulness of this posting
    may be illusive.

  3. #3

    Default Re: pulseaudio annoyance

    Quote Originally Posted by goldie View Post
    some folks find happiness by just using YaST to uninstall pulseaudio.
    That's good advice I took in the past, but I had to come back to the dark side because mplayer (but not vlc) suddenly decided to lose audio, complaining about waitpid() and pulse - despite pulseaudio being disabled in YaST and uninstalled too.

    I've just Googled for something similar to the messages I remember mplayer giving:
    Code:
    E: context.c: waitpid(): No child processes
    AO: [pulse] Init failed: Internal error
    Failed to initialize audio driver 'pulse'
    I tried e.g '-ao sdl' and the like to persuade mplayer not to use pulse (which wasn't there anymore) but that didn't help.

    When I re-installed pulseaudio. I noticed YaST *removing* a library with 'pulse' in its name that might have been the cause of the mess, since the mplayer/vlc dependencies seem to change with the wind.

    mplayer started working again so I kept pulseaudio and set it all up properly once more..

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: pulseaudio annoyance

    It does appear pulse is here to stay, so if there are problems that are repeatable, and if not too serious (forcing a removal of pulse), then maybe raising bug reports on the appropriate openSUSE version is good approch Submitting Bug Reports - openSUSE ... else the problems will perpetuate forever.

  5. #5

    Default Re: pulseaudio annoyance

    ^^ hi oldcpu

    Well, I updated ALSA after the update appeared, and my sound went "crunchy". So I disabled pulseaudio in YaST, tried restarting stuff by hand, gave up, did the noob thing and rebooted and now I have "smooth" sound. YaST says I don't have pulseaudio, but the fancy dialogs such as "open volume control" are still there. I'm really confused (but happy).

    I'll keep an eye/ear on this. I agree oldcpu, moaning is not the answer, and we need to give the developers and maintainers some solid feedback. When I figure this out, I'll do as you recommend (and as ever oldcpu, thanks for being the sound guru on here)

    PS I notice that i don't have the "bouncy bar" VU meter thing anymore in the "open volume control" dialog - possible culpit/clue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •