I'm going through /var/log/messages fixing things ...

If you see the following in your log and want to fix it, or if you want the gnome keyring dialog to pop up, read on:

Code:
gnome-keyring-daemon: couldn't lookup keyring component setting: Failed to contact configura
tion server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash.
 See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Not running within active session)gnome-keyring-daemon: couldn't lo
okup ssh component setting: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for OR
Bit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Not running
within active session)gnome-keyring-daemon: couldn't lookup pkcs11 component setting: Failed to contact configuration server; some possible c
auses are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/pr
ojects/gconf/ for information. (Details -  1: Not running within active session)
I found it annoying, and I quite like the gnome keyring dialog.

There are many posts on Google about this, and it seems the bug exists and will be fixed in due course.

I've found a workaround - which is to replace gdm with kdm4 (!) as one's display manager (this can be done via YaST). My gnome keyring dialog is back, and the log is quiet.

(The converse applies - using gdm disables the gnome keyring dialog and restores the irritating log message.)

The catch? You can't shutdown from the desktop, you have to logout and then shutdown from kdm4. <sigh>