Results 1 to 2 of 2

Thread: Simple printing problem on Hp

  1. #1

    Default Simple printing problem on Hp

    Recently updated to Kde 4.3.0 everything is updated and working great. Only problem I have experienced so far is when printing out a webpage today was unable to get the HP deskjet 5550 to print. Its worked many times with no problems until the update to 4.3. HP Device manager recognizes the printer ( get ink levels etc). Am able to print to file with PDF. Kjobviewer lists the job with an error, the pending jobs do not show up in HP device manager ( shows Idle) . Print test page does not work either. Nor does printing a local pdf file.
    I think this is cups related? ( am technically inclined but still new to linux ). I looked around in yast and the printer settings but didn't find anything that I saw was incorrect. Driver shows to be installed. Direct connected device shows the HP with serial number on usb #1. Below is the output from the Kjobviewer :

    Attribute Values
    job-more-info -- ipp://localhost:631/jobs/42
    job-preserved--True
    job-printer-up-time--Wed Aug 26 16:03:13 2009
    job-state-reasons--job-stopped
    job-uri-- ipp://localhost:631/jobs/42
    printer-uri ipp://localhost/printers/deskjet_5550
    job-originating-user-name root
    job-name YaST2testprint_deskjet_5550
    document-format application/postscript
    media --Letter
    sides---- one-sided
    finishings 0x3
    copies 1
    job-hold-until no-hold
    job-priority 50
    number-up 1
    job-sheets none
    none page-label
    deskjet_5550:YaST2testprint@XG319 job-uuid
    urn:uuid:630e550d-2663-3cb4-4108-213fd71de496
    job-originating-host-name localhost
    time-at-creation Wed Aug 26 15:38:44 2009
    time-at-processing Wed Aug 26 16:02:44 2009
    time-at-completed

    job-id 42
    job-state 0x6
    job-media-sheets-completed 0
    job-printer-uri ipp://XG319.site:631/printers/deskjet_5550
    job-name YaST2testprint_deskjet_5550
    job-k-octets 17

    Sure this has got to be some simple setting I'm missing, just not sure where?
    Thank you for any advice.

  2. #2

    Default Re: Simple printing problem on Hp

    Ok so I got some time today to look at the problem again. After doing an update and rebooting, going through the Yast printer settings looking for problems and removing/downgrading cups. Still nothing.

    I finally got an error message Cups-missing-filter. Googled and tried a few things . An ubuntu forum [ubuntu] CUPS-missing-filter - Page 2 - Ubuntu Forumssuggested deleting the driver or try and changing the driver. I deleted the printer under yast printer settings, opened HP device manager and removed the printer there as well. The automatic wizard popped up, ran through it..... and I'm printing again.

    So for anyone else reading this that may have the same problem the 2 top ways of resolving were reinstalling or downgrading cups. Or ( What eventually worked for me) delete the printer and run the wizard again. Have no Idea why the printer decided to stop working in the first place. Hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •